Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE

Deploying a web service incurs 'Invalid thread access'

Deploying a web service incurs 'Invalid thread access'

Problem

When deploying a service interface to an enterprise server instance, why does Eclipse display an 'Invalid thread access' error message?

Resolution

When deploying a service Interface, the following error message box may be displayed:

This message indicates that an 'object' has not yet been saved prior to deploying. It could be that a Program has not been saved. This message also occurs if an Operation has been added but not saved.

To resolve this issue, you can issue the Save All command either by using the icons on the toolbar:

 

or by clicking on 'File' and using the dropdown menu:

 

DISCLAIMER:

Some content on Community Tips & Information pages is not officially supported by Micro Focus. Please refer to our Terms of Use for more detail.
Top Contributors
Version history
Revision #:
1 of 1
Last update:
‎2015-02-12 20:29
Updated by:
 
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.