Murzda Absent Member.
Absent Member.
2614 views

3rd party imaging problem

I have installed the WAIK in my ZCM 10.2 server imaging setup and can launch PXE on the device to be imaged and the WAIK interface comes up just fine.

I setup the share on my ZCM server to store the image and tried imaging with both local and server and keep getting "TFTP Operation failed to download file".

Do I need to define option 66 on my DHCP server? I do not need to do this when using my Linux Imaging CD's.

Has anyone gotten this to work in ZCM? If so, what did you do. There isn't much documentation on Novell's site on this.

Thanks in advance.

Chris

Labels (2)
0 Likes
7 Replies
AndrewMallett Absent Member.
Absent Member.

Re: 3rd party imaging problem

I think the option 62 and if you are using PXE you will need it if your
DHCP Server is on the same box as your ZCM Server or at least the
Proxy-DHCP Server. If they are on the same box the dhdcp server must be
set with option 62 set to "PXEClient". Easy to add on Linux but on
windows you need to use netsh to create the option as it is not set by
default. You will also need to configure the novell-proxydhcp.conf to
tell proxydhcp to listen on port 4011 not 67 "LocalDHCPFlag"

To access txhe share on the windows box you will also need to add
credentials to the credentials vault . This is on the main config page
soemwhere below you zcm administrators. This will be the username and
password required to acess the imaging share.

I have used this, not in anger, but just testing and wim does work well.

Happy to help more if needed

0 Likes
Murzda Absent Member.
Absent Member.

Re: 3rd party imaging problem

Thanks Andrew,

I looked in the file and did not see the port setting anywhere set to 67. Do I need to add this line? Could you post your novell-proxydhcp.conf file so that I can see how it should look like?

Thanks in advance.

Chris

0 Likes
AndrewMallett Absent Member.
Absent Member.

Re: 3rd party imaging problem

67 is the default and relates to LocalDHCPFlag = 0 ; this says the dhcp
server and Proxy dhcp are on differnt servers. In this case no config
changes are needed. Just start the Proxy-dhcp service

See below from documentation


You can install Configuration Management (which includes Preboot
Services) on the same server where DHCP is installed and running.
However, you must do the following to make it work:

•Set option tag 60 on the DHCP server so that it can work with
novell-proxydhcp. See the steps in the previous section (Configuring LAN
Environments for Preboot Services).

•On the server, edit the novell-proxydhcp.conf file and change:

LocalDHCPFlag = 0
to

LocalDHCPFlag = 1
The file is located at:

Windows: %ZENWORKS_HOME%\conf\preboot\

Linux: /etc/opt/novell/

0 Likes
Murzda Absent Member.
Absent Member.

Re: 3rd party imaging problem

Okay great! Since my DHCP server is not on the ZCM server, my config looks ok but I am still getting the "TFTP Operation failed to download file error". What needs to be changed then and where?

Chris

0 Likes
AndrewMallett Absent Member.
Absent Member.

Re: 3rd party imaging problem

can you TFTP to your server from another client. If you can issue the
command

get nvlnbp.sys

This is the first file that PXE will download

0 Likes
peheiss Absent Member.
Absent Member.

Re: 3rd party imaging problem

is there somewhere an option for "nextserver" to specify the adress from the tftp on the dhcp server? just a thought
0 Likes
AndrewMallett Absent Member.
Absent Member.

Re: 3rd party imaging problem

This is provided through the Proxy-dhcp server 🙂

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.