Highlighted
Absent Member.
Absent Member.
1711 views

Another ZCM 10.3.3 to 11.2 upgrade question

Hi folks, Im looking to upgrade our ZCM install.

Currently at zcm 10.3.3 with an external SQL server 2005.

According to the documentation I need to upgrade SQL to 2008 before upgrading the server.

The doco also states to start the zcm services after upgrading the SQL and before trying to upgrade ZCM.

Im sure I read somewhere that ZCM 10.3.3 wont run on SQL 2008.

I did read a comment about it running if SQL2008 was in 2005 compatibility mode, but apparently this Is not officially supported.

So Im confused about what the best practice upgrade path actually is. Can anyone shed some light on this for me ?
Labels (2)
0 Likes
10 Replies
Highlighted
Absent Member.
Absent Member.

5m3g head,

>
> Hi folks, Im looking to upgrade our ZCM install.
>
> Currently at zcm 10.3.3 with an external SQL server 2005.
>
> According to the documentation I need to upgrade SQL to 2008 before
> upgrading the server.
>
> The doco also states to start the zcm services after upgrading the SQL
> and before trying to upgrade ZCM.
>
> Im sure I read somewhere that ZCM 10.3.3 wont run on SQL 2008.
>
> I did read a comment about it running if SQL2008 was in 2005
> compatibility mode, but apparently this Is not officially supported.
>
> So Im confused about what the best practice upgrade path actually is.
> Can anyone shed some light on this for me ?


I would recommend you too upgrade to SQL2008R2.

Well it might not be supported, but your ZCM 10.3.3 should be able to
run on SQL2008. And as it's proparbly just a very short amount of time
you should be fine. Do you plan on upgrading all at one time or over
days?

--

Niels Poulsen

Novell Knowledge Partner

-------------------------------
A TRUE RED DEVIL

-- Niels I have always liked... Cowabunga! If you find this post helpful, please show your appreciation by clicking on the star below. A member must be logged in before s/he can assign reputation points.
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

"Compatibility Mode" would be necessary while doing that, though its
still not "Supported". However by being in 2005 Compatibility Mode the
Server should totally act like a 2005 server making ZCM clueless it's not.

On 5/8/2012 2:39 AM, Niels Poulsen wrote:
> 5m3g head,
>
>>
>> Hi folks, Im looking to upgrade our ZCM install.
>>
>> Currently at zcm 10.3.3 with an external SQL server 2005.
>>
>> According to the documentation I need to upgrade SQL to 2008 before
>> upgrading the server.
>>
>> The doco also states to start the zcm services after upgrading the SQL
>> and before trying to upgrade ZCM.
>>
>> Im sure I read somewhere that ZCM 10.3.3 wont run on SQL 2008.
>>
>> I did read a comment about it running if SQL2008 was in 2005
>> compatibility mode, but apparently this Is not officially supported.
>>
>> So Im confused about what the best practice upgrade path actually is.
>> Can anyone shed some light on this for me ?

>
> I would recommend you too upgrade to SQL2008R2.
>
> Well it might not be supported, but your ZCM 10.3.3 should be able to
> run on SQL2008. And as it's proparbly just a very short amount of time
> you should be fine. Do you plan on upgrading all at one time or over
> days?
>



--
Craig Wilson - MCNE, MCSE, CCNA
Novell Knowledge Partner

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
Highlighted
Absent Member.
Absent Member.

does putting it into "Compatibility Mode" affect other databases on the
SQL server? Hosting 12 db on the SQL server is becoming a mine field as
each program seems to have its own version requirements now.

On 5/8/2012 6:52 AM, craig wilson wrote:
> "Compatibility Mode" would be necessary while doing that, though its
> still not "Supported". However by being in 2005 Compatibility Mode the
> Server should totally act like a 2005 server making ZCM clueless it's not.
>
> On 5/8/2012 2:39 AM, Niels Poulsen wrote:
>> 5m3g head,
>>
>>>
>>> Hi folks, Im looking to upgrade our ZCM install.
>>>
>>> Currently at zcm 10.3.3 with an external SQL server 2005.
>>>
>>> According to the documentation I need to upgrade SQL to 2008 before
>>> upgrading the server.
>>>
>>> The doco also states to start the zcm services after upgrading the SQL
>>> and before trying to upgrade ZCM.
>>>
>>> Im sure I read somewhere that ZCM 10.3.3 wont run on SQL 2008.
>>>
>>> I did read a comment about it running if SQL2008 was in 2005
>>> compatibility mode, but apparently this Is not officially supported.
>>>
>>> So Im confused about what the best practice upgrade path actually is.
>>> Can anyone shed some light on this for me ?

>>
>> I would recommend you too upgrade to SQL2008R2.
>>
>> Well it might not be supported, but your ZCM 10.3.3 should be able to
>> run on SQL2008. And as it's proparbly just a very short amount of time
>> you should be fine. Do you plan on upgrading all at one time or over
>> days?
>>

>
>


0 Likes
Highlighted
Absent Member.
Absent Member.

Steve B <cns965+nospam@gmail.com> wrote:
> does putting it into "Compatibility Mode" affect other databases on the
> SQL server? Hosting 12 db on the SQL server is becoming a mine field as
> each program seems to have its own version requirements now.
>
> On 5/8/2012 6:52 AM, craig wilson wrote:
>> "Compatibility Mode" would be necessary while doing that, though its
>> still not "Supported". However by being in 2005 Compatibility Mode the
>> Server should totally act like a 2005 server making ZCM clueless it's not.
>>
>> On 5/8/2012 2:39 AM, Niels Poulsen wrote:
>>> 5m3g head,
>>>
>>>>
>>>> Hi folks, Im looking to upgrade our ZCM install.
>>>>
>>>> Currently at zcm 10.3.3 with an external SQL server 2005.
>>>>
>>>> According to the documentation I need to upgrade SQL to 2008 before
>>>> upgrading the server.
>>>>
>>>> The doco also states to start the zcm services after upgrading the SQL
>>>> and before trying to upgrade ZCM.
>>>>
>>>> Im sure I read somewhere that ZCM 10.3.3 wont run on SQL 2008.
>>>>
>>>> I did read a comment about it running if SQL2008 was in 2005
>>>> compatibility mode, but apparently this Is not officially supported.
>>>>
>>>> So Im confused about what the best practice upgrade path actually is.
>>>> Can anyone shed some light on this for me ?
>>>
>>> I would recommend you too upgrade to SQL2008R2.
>>>
>>> Well it might not be supported, but your ZCM 10.3.3 should be able to
>>> run on SQL2008. And as it's proparbly just a very short amount of time
>>> you should be fine. Do you plan on upgrading all at one time or over
>>> days?
>>>

>>
>>


No, you only set it on that one DB, so no effect on the others.

--
Niels

-- Niels I have always liked... Cowabunga! If you find this post helpful, please show your appreciation by clicking on the star below. A member must be logged in before s/he can assign reputation points.
0 Likes
Highlighted
Absent Member.
Absent Member.

Thanks
0 Likes
Highlighted
Absent Member.
Absent Member.

Steve B wrote:

> Thanks


You're welcome.

--

--
Niels Poulsen

Novell Knowledge Partner

-------------------------------
A TRUE RED DEVIL

-- Niels I have always liked... Cowabunga! If you find this post helpful, please show your appreciation by clicking on the star below. A member must be logged in before s/he can assign reputation points.
0 Likes
Highlighted
Absent Member.
Absent Member.

nop1983;2194295 wrote:
5m3g head,

>
> Hi folks, Im looking to upgrade our ZCM install.
>
> Currently at zcm 10.3.3 with an external SQL server 2005.
>
> According to the documentation I need to upgrade SQL to 2008 before
> upgrading the server.
>
> The doco also states to start the zcm services after upgrading the SQL
> and before trying to upgrade ZCM.
>
> Im sure I read somewhere that ZCM 10.3.3 wont run on SQL 2008.
>
> I did read a comment about it running if SQL2008 was in 2005
> compatibility mode, but apparently this Is not officially supported.
>
> So Im confused about what the best practice upgrade path actually is.
> Can anyone shed some light on this for me ?


I would recommend you too upgrade to SQL2008R2.

Well it might not be supported, but your ZCM 10.3.3 should be able to
run on SQL2008. And as it's proparbly just a very short amount of time
you should be fine. Do you plan on upgrading all at one time or over
days?

--

Niels Poulsen

Novell Knowledge Partner

-------------------------------
A TRUE RED DEVIL


I want to do the upgrade all at once. So ZCM 10.3.3. shouldnt need to run on SQL 2008 for long.

Can I simply stop ZCM services, upgrade SQL then upgrade ZCM with the old ZCM services shut down ?
0 Likes
Highlighted
Absent Member.
Absent Member.

So what is the supported upgrade path ? I couldnt seem to find it in the Doco.

craig_wilson;2194343 wrote:
"Compatibility Mode" would be necessary while doing that, though its
still not "Supported". However by being in 2005 Compatibility Mode the
Server should totally act like a 2005 server making ZCM clueless it's not.

On 5/8/2012 2:39 AM, Niels Poulsen wrote:
> 5m3g head,
>
>>
>> Hi folks, Im looking to upgrade our ZCM install.
>>
>> Currently at zcm 10.3.3 with an external SQL server 2005.
>>
>> According to the documentation I need to upgrade SQL to 2008 before
>> upgrading the server.
>>
>> The doco also states to start the zcm services after upgrading the SQL
>> and before trying to upgrade ZCM.
>>
>> Im sure I read somewhere that ZCM 10.3.3 wont run on SQL 2008.
>>
>> I did read a comment about it running if SQL2008 was in 2005
>> compatibility mode, but apparently this Is not officially supported.
>>
>> So Im confused about what the best practice upgrade path actually is.
>> Can anyone shed some light on this for me ?

>
> I would recommend you too upgrade to SQL2008R2.
>
> Well it might not be supported, but your ZCM 10.3.3 should be able to
> run on SQL2008. And as it's proparbly just a very short amount of time
> you should be fine. Do you plan on upgrading all at one time or over
> days?
>



--
Craig Wilson - MCNE, MCSE, CCNA
Novell Knowledge Partner

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
0 Likes
Highlighted
Absent Member.
Absent Member.

5m3g_head;2194563 wrote:
I want to do the upgrade all at once. So ZCM 10.3.3. shouldnt need to run on SQL 2008 for long.

Can I simply stop ZCM services, upgrade SQL then upgrade ZCM with the old ZCM services shut down ?


Yes, you should be able to since the upgrade installer connects directly to the database and does not use zcm services to connect.
0 Likes
Highlighted
Absent Member.
Absent Member.

5m3g head,

>
> So what is the supported upgrade path ? I couldnt seem to find it in
> the Doco.


Did you look in this:
http://www.novell.com/documentation/zenworks11/zen11_upgrade/?page=/docu
mentation/zenworks11/zen11_upgrade/data/bookinfo.html

Part "2.3 Understanding the Upgrade Order"


--

Niels Poulsen

Novell Knowledge Partner

-------------------------------
A TRUE RED DEVIL

-- Niels I have always liked... Cowabunga! If you find this post helpful, please show your appreciation by clicking on the star below. A member must be logged in before s/he can assign reputation points.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.