Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
antuk Contributor.
Contributor.
1318 views

COULD_NOT_LAUNCH_ANALYZE on Patch Scan

Hi,

On a handful on our machines (Windows 10 LTSB) we're getting this message when attempting to do a 'zac ps':

Starting patch scan .....
There was an error scanning the computer: COULD_NOT_LAUNCH_ANALYZE

However the zmd-messages.log is somewhat contradictory as it says all is well:

[Before call to ParseArgs] [] [] [] [ZENworks Agent]
[Before call to ProcessCommand] [] [] [] [ZENworks Agent]
[Processing Command for handler patch-scan] [] [] [] [ZENworks Agent]
[Finished Processing Command for handler patch-scan. Result = SUCCESS] [] [] [] [ZENworks Agent]
[After call to ProcessCommand. Result = SUCCESS] [] [] [] [ZENworks Agent]
[After call to ParseArgs. Result = SUCCESS] [] [] [] [ZENworks Agent]
[After call to StopDisplaySpinner()] [] [] [] [ZENworks Agent]

According to the ZCC, the last time the device reported back from a ps was a few weeks ago. Have tried 'zac cc' and 'zac ref', but no joy.

We're running ZENworks 2017 Update 1.

Cheers,

Anthony
Labels (2)
0 Likes
2 Replies
AutomaticReply Absent Member.
Absent Member.

Re: COULD_NOT_LAUNCH_ANALYZE on Patch Scan

antuk,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.
https://www.partnernetprogram.com/partnerfinder/find.html

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.microfocus.com/faq.php

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team
http://forums.microfocus.com



0 Likes
antuk Contributor.
Contributor.

Re: COULD_NOT_LAUNCH_ANALYZE on Patch Scan

Turns out analyze.exe wasn't in the client's zpm folder. If we leave our clients alone for a while after installation, the zpm folder is populated and all is well.

It doesn't take three months - only another client came across my path and I was reminded of this post!

Ant
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.