Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
ictssoe Contributor.
Contributor.
1452 views

Dell Optiplex 7050m does not work with PXE

Hello,

The last couple of days I have been trying to get the Dell Optiplex 7050m to work with PXE but I haven't succeeded. The strange thing is that using a bootable USB stick made from the bootcd works fine.

What I have tried:

Booting from USB with drivers from the bootcd March driver update 2018 works (haven't tried the August 2018 update yet).
Booting PXE with the August driver update 2018 does not work (Error: Can not find the repository).
Inserting newid="0x8086 0x15e3,e1000e" (found by booting the USB drive in Manual mode and using the command hwinfo --netcard) in z_maintx64.cfg stops the boot process of PXE when trying to load the driver e1000e.

I am baffled by this. Can someone help me with this?

Thanks in advance.

Regards,

David
Labels (1)
0 Likes
9 Replies
Micro Focus Expert
Micro Focus Expert

Re: Dell Optiplex 7050m does not work with PXE

Check the Linux Kernel Version when you Boot PXE vs USB.
Make sure PXE is booting the Expected 64bit version as referenced in the August Imaging Update and not the old 32bit Kernel.

Check do you have the latest nvlnbp.sys in srv/tftp , if this is wrong and outdated....it may cause you to use the old 32bit Kernel.

May also want to check other devices to see if they are loading the newer Kernel as expected.....
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
ictssoe Contributor.
Contributor.

Re: Dell Optiplex 7050m does not work with PXE

Hi Craig,

Sorry for the late reply but I was ill and couldn't do the checks you asked for. Now I am back at work I have done some checking and here are the results.

Booting from usb-disk (March driver update 2018) says the Linux kernel version is 4.4.21-69-default.

Booting from the server with pxe (August driver update 2018) says the Linux kernel version is 3.0.101-63-default which is weird. It should be the same version as the usb-disk or higher.

After this I reinstalled the August driver update 2018 but it had the same result. I checked the logfile for errors but there weren't any and I checked if all files copied were actually copied which they were.

I did some more checking and booting from the server starts the 32-bit Linux version even though it states it is using the z_maintx64.cfg (Tried it on two laptops, one is a Dell Latitude E6440 and the other a Dell Latitude E5530 both in BIOS mode). Then I found in TID 7022453 that computers in BIOS mode get a 32-bit version of Linux.

Next I checked NVLNPB.SYS and indeed it hadn't been copied so I copied it maually. After that I started the Dell Optiplex 7050m in UEFI-mode and hey presto it works.

Thanks for your advice.

Regards,

David
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Dell Optiplex 7050m does not work with PXE

Thanks David! Glad it is working now.

The NVLNPB.SYS issue of not always getting updated was SUPPOSED to have been fixed....but looks like that issue is still sticking around some times.....
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
ictssoe Contributor.
Contributor.

Re: Dell Optiplex 7050m does not work with PXE

Hi Craig,

Well I thought everything would be working correctly now but it doesn't. Putting an image on the Dell works fine but after rebooting, the system should start up and detect and install the devices in Windows 10 LTSB 2016. That doesn't happen. The dotted circle starts turning around and never stops. This happened in June/July 2018 when I first started making and testing a UEFI-mode image (See: https://forums.novell.com/showthread.php/508306-Creating-UEFI-image-Trying-to-make-GPT-based-image-from-BI?p=2482014). Now this has returned and I am baffled by it. The Zenserver is now running the August driver update 2018. When I got it working in July it was running the March driver update 2018. Since then I have installed the August and September 2018 PRU (I am not sure of the July 2018 PRU. This could have been installed prior to March driver update 2018). I still have to install Zenworks 2017 Update 3 but I am not sure if that is wise at the moment.

Have you got any suggestions where I should look to overcome this problem?

Regards,

David
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Dell Optiplex 7050m does not work with PXE

This is a common issue with Windows 10 Imaging....
Most likely not related to the Imaging Code in any way...…..

Some Tips...…

#1 - Disable the SIDChanger….I've seen this cause some issues.....
https://www.novell.com/documentation/zenworks11/zen11_cm_preboot_imaging/data/bg4iu9s.html
I prefer creating the RestoreMask.xml

#2 - For the Win10 Image.....Create the Image without Internet Connectivity to ensure no patching occurs as part of the image...Just use a Base 1803.
It seems there are often issues with various "Store Apps" update.

#3 - Use of the Tuxera Driver is strongly recommended.


If you continue to have issues....best to post a new thread....
But don't reference the hardware specifically as it is almost certainly a more generic issue that can even be seen in a native WinPE environment....
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
ictssoe Contributor.
Contributor.

Re: Dell Optiplex 7050m does not work with PXE

Hi Craig,

Thanks for the advice and I agree it has something to do with Windows but I still can't get see where to look for the problem.

#1. The problem occurs before the Zen agent is installed. To be clear the image is made by installing Windows 10 Enterprise LTSB 2016 on a virtual machine (VirtualBox) with UEFI enabled. All windows updates are then installed, some adjustments in the registry and the group policy are done, a folder for add-on images is installed and then sysprep.exe is run with the options /oobe /generalize /shutdown /unattend:<path to unattend file> (not forgetting to make some snapshots of the vm).

#2. I am using Enterprise LTSB 2016 which doesn't have the Windows Store and apps installed so it should be ok.

#3. I use the Tuxera driver.

One more question:

Does Zenworks Update 3 alter/replace the imaging files compared to Zenworks update 2 with August driver update 2018?

Thanks in advance.

Regards,

David
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Dell Optiplex 7050m does not work with PXE

Your issue is probably caused by THIS part... "All windows updates are then installed".
Try just the Windows install and the Add-on Images Folder....
See how it goes....
Then add stuff on....
Less Experience with the LTSB Stuff...most folks seem to be doing other stuff...…
Not suggesting you avoid LTSB....just my troubleshooting experience has been around other flavors of Win10...


Note: There will be a Sept 2018 Imaging Update Specifically For ZCM 2017 Update 3 shipping very soon.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
ictssoe Contributor.
Contributor.

Re: Dell Optiplex 7050m does not work with PXE

Hi Craig,

Thank you for pointing me in the right direction. I made a an image of a bare Windows 10 LTSB 2016 instrallation that had no connection to the internet and after restoring it to the testlaptop it worked. Then I went back to the vm that wasn't working and set it back to the snapshot I made in July, syspreped it, made an image, restored it to the testlaptop and it worked fine. This meant that either a Windows update (since July) or one of my adjustments caused the problem. After another test it turned out to be a Windows update that must have gone wrong because after applying the updates to the snapshot image from above, sysprepping and restoring it worked fine (the snapshot from July had the same adjustments as the image that didn't work).

So, a massive thanks for your help.

Regards,

David
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Dell Optiplex 7050m does not work with PXE

Great News!
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.