Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
schiggieh Absent Member.
Absent Member.
2137 views

Deploying a Workstation Image Bundle to a Virtual Machine

I just ran into the problem, that my current Windows XP Image wont run on a VMware virtual machine. (Windows XP Base Image with sysprepped XP, a few Addon Images)

When just applying one of the hardwarespecific (Base Image XP, Driver Image with Drivers, hal.dll, ntoskrnl.exe and ntkrnlpa.exe)configurations to the virtual machine, it comes up with corrupt ntfs.sys message

So I took the hal.dll, ntoskrnl.exe, ntkrnlpa.exe and ntfs.sys from a manual installed WinXP on a virtual machine, build an "Driver Image" just containing these additional files. In this case a Bluescreen pops up (followed by an instant reboot...):
A problem has been detected and Windows... ... ... ... Technical Information:
*** STOP: 0x0000007B (0xF8AD5528, 0xC0000034, 0x00000000, 0x00000000)

I tested setting the Hard drive to SCSI and checked the VMs BIOS parameters, but it didnt change anything.

The Windows 7 Images work flawless on VMs so far.

Any ideas would be greatly appreciated!

Once upon a time there was a guy named Ömse...
Labels (2)
0 Likes
5 Replies
Knowledge Partner
Knowledge Partner

Re: Deploying a Workstation Image Bundle to a Virtual Machin

schiggieh;2088896 wrote:
I just ran into the problem, that my current Windows XP Image wont run on a VMware virtual machine. (Windows XP Base Image with sysprepped XP, a few Addon Images)

When just applying one of the hardwarespecific (Base Image XP, Driver Image with Drivers, hal.dll, ntoskrnl.exe and ntkrnlpa.exe)configurations to the virtual machine, it comes up with corrupt ntfs.sys message

So I took the hal.dll, ntoskrnl.exe, ntkrnlpa.exe and ntfs.sys from a manual installed WinXP on a virtual machine, build an "Driver Image" just containing these additional files. In this case a Bluescreen pops up (followed by an instant reboot...):
A problem has been detected and Windows... ... ... ... Technical Information:
*** STOP: 0x0000007B (0xF8AD5528, 0xC0000034, 0x00000000, 0x00000000)

I tested setting the Hard drive to SCSI and checked the VMs BIOS parameters, but it didnt change anything.

The Windows 7 Images work flawless on VMs so far.

Any ideas would be greatly appreciated!


I have had similar issues using vmware, never found a solution... so I gave virtualbox a try and everything worked... Don't know if it is vmware hw or bios that causes BSOD.

Thomas
0 Likes
patrick_reeder Absent Member.
Absent Member.

Re: Deploying a Workstation Image Bundle to a Virtual Machin

Do the following to get it to boot:

1.) Open the VM's configuration file (.VMX) using a text editor while the VM is powered off.
2.) Find the following line towards the top of the file:


scsi0.present = "TRUE"


3.) Change the line to "FALSE"
4.) Save the file and try to boot your VM again.
5.) In the case you might have to revert to a previous snapshot, check the file again because this can change it back to TRUE.

DEV - ZCM 10.3.4/MS-SQL Database (2 Primaries & 2 Sats running 64-bit SLES 10.2 w/ ENGL Imaging Toolkit 7) PROD - ZCM 10.3.4/MS-SQL Database (5 Primaries & 11 Sats running 64-bit SLES 10.2 w/ ENGL Imaging Toolkit 7 ~7500 Managed Devices)
0 Likes
patrick_reeder Absent Member.
Absent Member.

Re: Deploying a Workstation Image Bundle to a Virtual Machin

In addition to changing that setting, I've also had to pre- partition and format the drive sometimes before applying an image to a new XP VM.

DEV - ZCM 10.3.4/MS-SQL Database (2 Primaries & 2 Sats running 64-bit SLES 10.2 w/ ENGL Imaging Toolkit 7) PROD - ZCM 10.3.4/MS-SQL Database (5 Primaries & 11 Sats running 64-bit SLES 10.2 w/ ENGL Imaging Toolkit 7 ~7500 Managed Devices)
0 Likes
schiggieh Absent Member.
Absent Member.

Re: Deploying a Workstation Image Bundle to a Virtual Machin

Hey Patrick,

worked right away... I bow to your magical VM-Imaging Skills! 🙂
Thank you very very much!

Once upon a time there was a guy named Ömse...
0 Likes
patrick_reeder Absent Member.
Absent Member.

Re: Deploying a Workstation Image Bundle to a Virtual Machin

You are very welcome!

🙂

schiggieh;2092601 wrote:
Hey Patrick,

worked right away... I bow to your magical VM-Imaging Skills! 🙂
Thank you very very much!

DEV - ZCM 10.3.4/MS-SQL Database (2 Primaries & 2 Sats running 64-bit SLES 10.2 w/ ENGL Imaging Toolkit 7) PROD - ZCM 10.3.4/MS-SQL Database (5 Primaries & 11 Sats running 64-bit SLES 10.2 w/ ENGL Imaging Toolkit 7 ~7500 Managed Devices)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.