Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
dduvall Absent Member.
Absent Member.
7841 views

Flurry of "The analyze process failed" errors from DAU

For the last few weeks I've been getting this error on a couple hundred of my Zen11 workstations. This is the error that shows up server-side per-workstation, a few times a day...

Message Detail Information
Full Message: The analyze process failed to complete correctly.{}
Additional Information: None
Severity: Error
Date: August 18, 2011 8:55:07 AM
Acknowledged Date: None
Source: /Devices/Workstations/workstationname
Message ID: The analyze process failed to complete correctly.
Probable Cause URL: None
Log ID: d192a44aeec85e0d7bcf0e58b258580c
Related Objects: /Bundles/ZPM/DAU/Discover Applicable Updates Windows-x86-en-WIN7sp0

Generally speaking when I get errors with a ZCM patch management component I wait a few days and hope that an subscription update comes down that will fix the issue. This time that has not worked, however.

Any suggestions for first steps on resolving it, short of doing a full ZPM reset?

Thanks a bunch,

Don
Labels (2)
0 Likes
39 Replies
shaunpond Absent Member.
Absent Member.

Re: Flurry of "The analyze process failed" errors from DAU

Dduvall,

http://download.novell.com/Download?buildid=vUDOcy5XJ08~ might help -
but I expect to release a newer version of this tomorrow if I get time
(with the ZCM 11.1 versions of these files, that have more fixes)

--

Shaun Pond


0 Likes
jena_hillenbran Absent Member.
Absent Member.

Re: Flurry of "The analyze process failed" errors from DAU

dduvall,
If it is any consolation, I don't think it is just ZCM 11.1. We are at ZCM 10.3.1 and just started getting this error this week - and it is in masses. I am currently working with tech support to try and get a solution, but I am going to check if there is a 10.3.1 version for what Shaun recommended.

Jena Hillenbrand
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Flurry of "The analyze process failed" errors from DAU

Jena,

there's no 10.3.1 version, that I know... (since I'm the guy that posts
the patches :))

--

Shaun Pond


0 Likes
shaunpond Absent Member.
Absent Member.

Re: Flurry of "The analyze process failed" errors from DAU

Shaun,

but that doesn't mean that one can't be created!

--

Shaun Pond


0 Likes
jalloway Absent Member.
Absent Member.

Re: Flurry of "The analyze process failed" errors from DAU

I wanted to add that we are having the same problem. We are on version 10.3.3 with some agents still on 10.3.1 and are getting the error "The analyze process failed to complete correctly" on every workstation. It is causing performance issues since the DUA task seems to run repeatedly throughout the day since it keeps failing. Can I apply the patch you mentioned to computers with both 10.3.3 and 10.3.1?
0 Likes
smosby01 Absent Member.
Absent Member.

Re: Flurry of "The analyze process failed" errors from DAU

How would one go about getting the patched created for 10.3.1?


spond;2129735 wrote:
Shaun,

but that doesn't mean that one can't be created!

--

Shaun Pond
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Flurry of "The analyze process failed" errors from DAU

Smosby01,

you'd need to start by raising a Service Request, but I can tell you
that it's going to get increasingly difficult for Novell to devote
resources to create fixes for old versions...

--

Shaun Pond


0 Likes
schiggieh Absent Member.
Absent Member.

Re: Flurry of "The analyze process failed" errors from DAU

Hey Shaun,

Iam facing the same problem, I've already opened a SR regarding this, we are currently at 10.3.1 and in a application freeze state, due to the win7 rollout. (iam so looking forward to 11 🙂 )

We will use PM only for win7 devices, so it would be okay to just disable PM for all XP devices. Is there any way to do this automatically for the entire zone?
I can switch the Agent Settings for single devices/groups but the workstation groups contain win7 as well as winXP devices. dynamic groups dont offer any agent settings...

Additionally to the loads of "The analyze process failed to complete correctly" errors the XP machines start getting REAL slow since PM ist installed.
the system process hogs up to 60-100% of the cpu, could this be related?

The support guys told me, that Uninstalling the ZCM agent fixes the cpu-hogging, i disabled PM on a few XP devices to find out more, but it will take untill tomorrow to get any results
I wasnt able to recreate the cpu-hogging on any of my testmachines, will keep them running and check again tomorrow.

regards
Alex

Once upon a time there was a guy named Ömse...
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Flurry of "The analyze process failed" errors from DAU

Schiggieh,

I could only think of doing it by creating a folder for XP machines and
moving them there, and overriding the agent settings for those
folders... you could use scripting and zman wgm to get the list, I
guess

--

Shaun Pond


0 Likes
schiggieh Absent Member.
Absent Member.

Re: Flurry of "The analyze process failed" errors from DAU

Hey Shaun,

thanks for your fast reply
regrettably this wont be an option, The customer ist pretty fond of his folder structure 😞

For the time being I just disabled ZPM for the entire zone and only activated it for my testfolders.
The technician offered the solution of unassigning the DAU Bundle for the XP machines (x86 de XP SP3). Could I just disable this bundle or would this lead to any predictable problems?

Might be an option to "break" the freeze state and move to 10.3.3 (whith the mentioned 10.3.3 zpm patch) or directly to 11.1 - but there will be a few hours of negotiations before this can be decided. 😞

Once upon a time there was a guy named Ömse...
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Flurry of "The analyze process failed" errors from DAU

Schiggieh,

the bundle is recreated every time a patch subscription is run - don't
know if it would stay disabled, but I don't see that it would hurt to
try

--

Shaun Pond


0 Likes
schiggieh Absent Member.
Absent Member.

Re: Flurry of "The analyze process failed" errors from DAU

Hey Shaun,

Okay I'll give it a try.
Thanks again!

Once upon a time there was a guy named Ömse...
0 Likes
Highlighted
shaunpond Absent Member.
Absent Member.

Re: Flurry of "The analyze process failed" errors from DAU

Schiggieh,

let me know, I'd like to understand what happens, for future reference

--

Shaun Pond


0 Likes
dduvall Absent Member.
Absent Member.

Re: Flurry of "The analyze process failed" errors from DAU

OK, so I'm sick and tired of the constant errors and constant re-running of analyze.exe all day long. I'm finally going to try to resolve this.

NOVELL: Downloads - ZCM 11.0 and 10.3.3 - remediate error patch - see TID 7008538

Is this still valid? I see it's been superceded but Cumulative Patch 2a. The thing is CP2a looks like a nightmare (seriously, stop the Zen service and have the MS scheduler do the install?) to install when remediate error patch looks pretty simple to take care of with a pretty easy bundle.

Will I have problems down the road if I use the analyze.exe and remediate.exe out of the simple remediate patch with installation of a new ZCM client down the road, say when I decide to pull the trigger on SP1?

edit: Oh, also, does SP1 include this fix or is there a post-SP1 fix required for SP1?
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.