Knowledge Partner
Knowledge Partner
150 views

Have a single MSI here that I can't upload to ZCM 2017

Hi.

Trying to deploy Kofax POwerPDF (https://www.kofax.de/sitecore/content/German/products/power-pdf) which comes as a regular msi. However, for some reason, their .msi file fails to upload to ZCM 17.4.1. Even uploading just the single MSI produces an error message box immediately after uploading it
"Error Unable to upload, Please try again".

Every other msi works. Now you say the .msi is corrupt, but of course it installs just fine using msiexec.

The error message happens at the point where ZCC would usually produce the result screen with the MMSI options and all that, so I have to assume that it fails reading those values from the msi or some such.

Anybody before I open a SR?

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
Labels (2)
0 Likes
4 Replies
Knowledge Partner
Knowledge Partner

Re: Have a single MSI here that I can't upload to ZCM 2017

And here's what zcc.log has to say:

I assume it trips over the index 1 parameter apparently being empty!?

 

[DEBUG] [11/28/2019 15:47:28.830] [3718] [ZENServer] [2285] [zenworks]
[ZCC] [] [MSI Comamnd Line Params before processing :] [] [] [] [ZENServer]
[DEBUG] [11/28/2019 15:47:28.830] [3718] [ZENServer] [2285] [zenworks]
[ZCC] [] [MSI Comamnd Line Params after processing] [] [] [] [ZENServer]
[DEBUG] [11/28/2019 15:47:28.830] [3718] [ZENServer] [2285] [zenworks]
[ZCC] [] [Parameter at index'0' is : /i] [] [] [] [ZENServer]
[DEBUG] [11/28/2019 15:47:28.830] [3718] [ZENServer] [2285] [zenworks]
[ZCC] [] [Parameter at index'1' is :] [] [] [] [ZENServer]
[DEBUG] [11/28/2019 15:47:28.831] [3718] [ZENServer] [2285] [zenworks]
[ZCC] [] [Parameter at index'2' is : /qn] [] [] [] [ZENServer]
[DEBUG] [11/28/2019 15:47:28.831] [3718] [ZENServer] [2285] [zenworks]
[ZCC] [] [MSI Comamnd Line Params before processing :] [] [] [] [ZENServer]
[DEBUG] [11/28/2019 15:47:28.831] [3718] [ZENServer] [2285] [zenworks]
[ZCC] [] [MSI Comamnd Line Params after processing] [] [] [] [ZENServer]
[DEBUG] [11/28/2019 15:47:28.831] [3718] [ZENServer] [2285] [zenworks]
[ZCC] [] [Parameter at index'0' is : /x] [] [] [] [ZENServer]
[DEBUG] [11/28/2019 15:47:28.831] [3718] [ZENServer] [2285] [zenworks]
[ZCC] [] [Parameter at index'1' is :] [] [] [] [ZENServer]
[DEBUG] [11/28/2019 15:47:28.831] [3718] [ZENServer] [2285] [zenworks]
[ZCC] [] [Parameter at index'2' is : /qn] [] [] [] [ZENServer]
[DEBUG] [11/28/2019 15:47:28.831] [3718] [ZENServer] [2285] [zenworks]
[ZCC] [] [MSI Comamnd Line Params before processing :] [] [] [] [ZENServer]
[DEBUG] [11/28/2019 15:47:28.831] [3718] [ZENServer] [2285] [zenworks]
[ZCC] [] [MSI Comamnd Line Params after processing] [] [] [] [ZENServer]
[DEBUG] [11/28/2019 15:47:28.831] [3718] [ZENServer] [2285] [zenworks]
[ZCC] [] [Parameter at index'0' is : /f] [] [] [] [ZENServer]
[DEBUG] [11/28/2019 15:47:28.831] [3718] [ZENServer] [2285] [zenworks]
[ZCC] [] [Parameter at index'1' is :] [] [] [] [ZENServer]
[DEBUG] [11/28/2019 15:47:28.832] [3718] [ZENServer] [2285] [zenworks]
[ZCC] [] [Parameter at index'2' is : /qn] [] [] [] [ZENServer]
[DEBUG] [11/28/2019 15:47:29.148] [3718] [ZENServer] [2927] [zenworks]
[ZCC] [] [Ping received] [] [] [] [ZENServer]

 

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Have a single MSI here that I can't upload to ZCM 2017

Can you uploading it for use with an "Install File Action"?  That would eliminate anything about it reading or processing the MSI itself.  

One time I saw a  case where the content trying to be uploaded was being quarantined by AV software, preventing an upload....wonder if it's something like that....

--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
Knowledge Partner
Knowledge Partner

Re: Have a single MSI here that I can't upload to ZCM 2017

Yes, I can upload it as regular file just fine. Also, when I originally started with it, I uploaded the .msi and all files underneath. In that case, it too uploads all files, and then fails when it attempts to show the next screen which lists the MSI parameters. To me, it's pretty obvious that that is what fails, ZCM can't handle that very MSI file when it tried to read what parameters it has and supports. The zcclog seems to agree with me, as it's clearly reading the msi specs there...

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Have a single MSI here that I can't upload to ZCM 2017

Never really saw this before....so SR may be best.

Perhaps some unusual default property values that could be removed via Orca, then add anything necessary back in the bundle properties.

--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.