Highlighted
Absent Member.
Absent Member.
1115 views

Install stuck at upgrading packages 85%

Server: windows 2012R2 fully patched. 10GB ram and 150GB of free space. System is running as a VM on VMware.
Zenworks 11.4 - fully patched.

I have made two attempts to upgrade my ZENworks and both times it seems to stop at "Upgrading Packages 85% completed." It takes about 25 minutes to get to this point and I have let it sit here for over 3 hours.

I have attempted the install with the ISO mounted through windows and mounted via VMware console.

Labels (1)
0 Likes
4 Replies
Highlighted
Absent Member.
Absent Member.

Re: Install stuck at upgrading packages 85%

I have been looking through the logs and these are the last entries in the system-update.log file.

[INFO] [02/19/2017 18:57:26.619] [4156] [ZENUpdater] [] [USERNAME-REMOVED] [SystemUpdate] [INSTALLING_PERCENTAGE] [INSTALLING] [85] [] [] [ZENworks]
[DEBUG] [02/19/2017 18:57:26.619] [4156] [ZENUpdater] [] [USERNAME-REMOVED] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: ZENWORKS_BIN] [] [] [ZENworks]
[DEBUG] [02/19/2017 18:57:26.619] [4156] [ZENUpdater] [] [USERNAME-REMOVED] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: ZENWORKS_BIN] [] [] [ZENworks]
[DEBUG] [02/19/2017 18:57:26.619] [4156] [ZENUpdater] [] [USERNAME-REMOVED] [SystemUpdate] [] [DEBUG] [Starting process: C:\Program Files (x86)\Novell\ZENworks\bin\novell-zenworks-configure.bat Option : -c AddAllowLinkingToXMLConfigureAction -nopause] [] [] [ZENworks]
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Install stuck at upgrading packages 85%

UPDATE:
I ended up rebooting the server and starting the upgrade again. It picked-up where it left off and again stopped at Upgrading Packages 85% complete. Rebooted a 2nd time and this time it finished but with errors. Going through the many logs I found one reference to could not shutdown the ZISD service.

Any ideas where I should look for the failure? For the time being I have reverted the snapshot and I'm back up and running. I will try the upgrade a a later date.

Joel
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Install stuck at upgrading packages 85%

You can ignore the ZISD Service errors, that is normal background noise.

You could run a ZDC Report to see how things look?
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Install stuck at upgrading packages 85%

I cloned my Zen system and have been playing with upgrading it and got it to upgrade.

On a whim, I did a virtual (VMware) unplug of the network cable and attempted the upgrade again. It worked like a champ.

Now to try it on my production system.

Joel
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.