Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
MCCFL_MLA
New Member.
1523 views

Invenotry Only Agent - Not Connecting - Server 2012R2 Win 10

Inventory Only agent does not seem to connect / report to ZCM 2017 Server.

I have tried on a win10 Enterprise and Server 2012R2 Standard. Both are Brand New Fresh Install, fully updated Critical and Recommended including .net.

Neither device will talk to the ZCM server. I may need to adjust something, but with the previous version ZCM 11.4.x and 11.3.x I did not.

Both have windows firewalls disabled.
Service is running on both.

I attached the ZenCollector.log

However here is a brief example of what it shows.

[INFO] [06/07/2017 12:16:51.916] [4080] [ZENWorksCollector] [16] [HardwareCollector] [] [Object reference not set to an instance of an object.] [] [] [] [ZENWorks]
[DEBUG] [06/07/2017 12:16:51.932] [4080] [ZENWorksCollector] [16] [HardwareCollector] [] [ at Novell.Zenworks.Inventory.ZenCollector.HWCollectionFramework.MouseHandler.GetMouseDataFromWmi()
at Novell.Zenworks.Inventory.ZenCollector.HWCollectionFramework.MouseHandler.RunTest()] [] [] [] [ZENWorks]
[INFO] [06/07/2017 12:16:51.932] [4080] [ZENWorksCollector] [16] [HardwareCollector] [] [Object reference not set to an instance of an object.] [] [] [] [ZENWorks]
[DEBUG] [06/07/2017 12:16:51.932] [4080] [ZENWorksCollector] [16] [HardwareCollector] [] [ at Novell.Zenworks.Inventory.ZenCollector.HWCollectionFramework.MouseHandler.AddComponent()] [] [] [] [ZENWorks]
[INFO] [06/07/2017 12:17:13.580] [4080] [ZENWorksCollector] [1] [InventoryCollector] [] [Zen Inventory collector Failed with Exception] [] [] [] [ZENWorks]
[INFO] [06/07/2017 12:17:13.580] [4080] [ZENWorksCollector] [1] [InventoryCollector] [] [Object reference not set to an instance of an object.] [] [] [] [ZENWorks]
[DEBUG] [06/07/2017 12:17:13.580] [4080] [ZENWorksCollector] [1] [InventoryCollector] [] [ at Novell.Zenworks.Inventory.ZenCollector.MainFramework.ScanInfo.GetScanInfoSuiteOptions(String data)
at Novell.Zenworks.Inventory.ZenCollector.MainFramework.ScanInfo.GetOptions(InventoryOptions Options)
at Novell.Zenworks.Inventory.ZenCollector.MainFramework.ScanInfo.GetScanInfo(Boolean IsManaged, InventoryOptions Options)
at Novell.Zenworks.Inventory.ZenCollector.MainFramework.InventoryCollector.ProcessWifData(InventoryOptions options, Boolean isManaged)
at Novell.Zenworks.Inventory.ZenCollector.MainFramework.InventoryCollector.RunScan()] [] [] [] [ZENWorks]


Thanks!

Patrick
Labels (1)
0 Likes
5 Replies
Highlighted
AutomaticReply Absent Member.
Absent Member.

Re: Invenotry Only Agent - Not Connecting - Server 2012R2 Win 10

MCCFL,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.
https://www.partnernetprogram.com/partnerfinder/find.html

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.microfocus.com/faq.php

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team
http://forums.microfocus.com



0 Likes
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: Invenotry Only Agent - Not Connecting - Server 2012R2 Wi

Are you on ZENworks 2017 Update 1?

Is there any kind of pop up occurring during install of agent or first inventory scan?

Are you using IPv6?
0 Likes
MCCFL_MLA
New Member.

Re: Invenotry Only Agent - Not Connecting - Server 2012R2 Wi

As far as IPV6 I have tried it with it disabled and enabled on multiple servers and server versions.

Server itself is updated to 17.1.0.0


  • ZCM : 17.1.0.0
  • ZAM : 17.1.0.1287
  • ZPM : 17.1.0.857
  • ZESM : 17.1.0.1287
  • ZFDE : 17.1.0.1287


I got the install / status screen during the install. But that's it. No error, nothing.

If I check the details on the .exe Inventory Only agent installer executable. The installer version is "11.0.0.29891" ** I find that odd!

After its installed:
zenumia.exe

  • Product Version: 17.1.0
  • File Version: 17.1.0.1


zenumsvc.exe

  • Product Version: 17.1.0
  • File Version: 17.1.0.1


ZenCollector

  • Product Version: 17.1.0.19242
  • File Version: 17.1.0.19242


Colw32.exe

  • Product Version: 17.0.0.1
  • File Version: 17.0.0.1



In the ZenCollectorLog
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[DEBUG] [09/08/2017 02:01:15.795] [7624] [ZENWorksCollector] [1] [InventoryCollector] [] [Hardware collection started ] [] [] [] [ZENWorks]
[DEBUG] [09/08/2017 02:01:19.423] [7624] [ZENWorksCollector] [1] [InventoryCollector] [] [Hardware collection finished ] [] [] [] [ZENWorks]
[DEBUG] [09/08/2017 02:01:19.423] [7624] [ZENWorksCollector] [1] [InventoryCollector] [] [Software collection started ] [] [] [] [ZENWorks]
[DEBUG] [09/08/2017 02:01:36.247] [7624] [ZENWorksCollector] [9] [SoftwareCollector] [] [SWVerificationTest :None of the recognized product has standard registry test] [] [] [] [ZENWorks]
[DEBUG] [09/08/2017 02:01:46.889] [7624] [ZENWorksCollector] [9] [SoftwareCollector] [] [SWVerificationTest :None of the recognized product has standard registry test] [] [] [] [ZENWorks]
[DEBUG] [09/08/2017 02:01:47.389] [7624] [ZENWorksCollector] [9] [SoftwareCollector] [] [SWVerificationTest :None of the recognized product has standard registry test] [] [] [] [ZENWorks]
[DEBUG] [09/08/2017 02:02:05.926] [7624] [ZENWorksCollector] [1] [InventoryCollector] [] [Software collection finished ] [] [] [] [ZENWorks]
[INFO] [09/08/2017 02:02:05.926] [7624] [ZENWorksCollector] [1] [InventoryCollector] [] [Object reference not set to an instance of an object.] [] [] [] [ZENWorks]
[DEBUG] [09/08/2017 02:02:05.926] [7624] [ZENWorksCollector] [1] [InventoryCollector] [] [ at Novell.Zenworks.Inventory.ZenCollector.MainFramework.ScanInfo.GetScanInfoSuiteOptions(String data)
at Novell.Zenworks.Inventory.ZenCollector.MainFramework.ScanInfo.GetOptions(InventoryOptions Options)
at Novell.Zenworks.Inventory.ZenCollector.MainFramework.ScanInfo.GetScanInfo(Boolean IsManaged, InventoryOptions Options)
at Novell.Zenworks.Inventory.ZenCollector.MainFramework.InventoryCollector.ProcessWifData(InventoryOptions options, Boolean isManaged)
at Novell.Zenworks.Inventory.ZenCollector.MainFramework.InventoryCollector.RunScan()] [] [] [] [ZENWorks]

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Thoughts?

Thanks!
Patrick

strj500;2465864 wrote:
Are you on ZENworks 2017 Update 1?

Is there any kind of pop up occurring during install of agent or first inventory scan?

Are you using IPv6?
0 Likes
MCCFL_MLA
New Member.

Re: Invenotry Only Agent - Not Connecting - Server 2012R2 Wi

As this is till an issue with the latest updates, I submitted an SR.

Service Request: 101135765091

Is anyone successfully using the Inventory only agent? Does this use a different port that maybe did not get opened on the ZCM Server? Just looking for ideas!

Thanks!

Patrick


MCCFL_MLA;2465866 wrote:
As far as IPV6 I have tried it with it disabled and enabled on multiple servers and server versions.

Server itself is updated to 17.1.0.0


  • ZCM : 17.1.0.0
  • ZAM : 17.1.0.1287
  • ZPM : 17.1.0.857
  • ZESM : 17.1.0.1287
  • ZFDE : 17.1.0.1287


I got the install / status screen during the install. But that's it. No error, nothing.

If I check the details on the .exe Inventory Only agent installer executable. The installer version is "11.0.0.29891" ** I find that odd!

After its installed:
zenumia.exe

  • Product Version: 17.1.0
  • File Version: 17.1.0.1


zenumsvc.exe

  • Product Version: 17.1.0
  • File Version: 17.1.0.1


ZenCollector

  • Product Version: 17.1.0.19242
  • File Version: 17.1.0.19242


Colw32.exe

  • Product Version: 17.0.0.1
  • File Version: 17.0.0.1



In the ZenCollectorLog
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[DEBUG] [09/08/2017 02:01:15.795] [7624] [ZENWorksCollector] [1] [InventoryCollector] [] [Hardware collection started ] [] [] [] [ZENWorks]
[DEBUG] [09/08/2017 02:01:19.423] [7624] [ZENWorksCollector] [1] [InventoryCollector] [] [Hardware collection finished ] [] [] [] [ZENWorks]
[DEBUG] [09/08/2017 02:01:19.423] [7624] [ZENWorksCollector] [1] [InventoryCollector] [] [Software collection started ] [] [] [] [ZENWorks]
[DEBUG] [09/08/2017 02:01:36.247] [7624] [ZENWorksCollector] [9] [SoftwareCollector] [] [SWVerificationTest :None of the recognized product has standard registry test] [] [] [] [ZENWorks]
[DEBUG] [09/08/2017 02:01:46.889] [7624] [ZENWorksCollector] [9] [SoftwareCollector] [] [SWVerificationTest :None of the recognized product has standard registry test] [] [] [] [ZENWorks]
[DEBUG] [09/08/2017 02:01:47.389] [7624] [ZENWorksCollector] [9] [SoftwareCollector] [] [SWVerificationTest :None of the recognized product has standard registry test] [] [] [] [ZENWorks]
[DEBUG] [09/08/2017 02:02:05.926] [7624] [ZENWorksCollector] [1] [InventoryCollector] [] [Software collection finished ] [] [] [] [ZENWorks]
[INFO] [09/08/2017 02:02:05.926] [7624] [ZENWorksCollector] [1] [InventoryCollector] [] [Object reference not set to an instance of an object.] [] [] [] [ZENWorks]
[DEBUG] [09/08/2017 02:02:05.926] [7624] [ZENWorksCollector] [1] [InventoryCollector] [] [ at Novell.Zenworks.Inventory.ZenCollector.MainFramework.ScanInfo.GetScanInfoSuiteOptions(String data)
at Novell.Zenworks.Inventory.ZenCollector.MainFramework.ScanInfo.GetOptions(InventoryOptions Options)
at Novell.Zenworks.Inventory.ZenCollector.MainFramework.ScanInfo.GetScanInfo(Boolean IsManaged, InventoryOptions Options)
at Novell.Zenworks.Inventory.ZenCollector.MainFramework.InventoryCollector.ProcessWifData(InventoryOptions options, Boolean isManaged)
at Novell.Zenworks.Inventory.ZenCollector.MainFramework.InventoryCollector.RunScan()] [] [] [] [ZENWorks]

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Thoughts?

Thanks!
Patrick
0 Likes
MCCFL_MLA
New Member.

Re: Invenotry Only Agent - Not Connecting - Server 2012R2 Wi

Opened an SR (Service Request: 101135765091)

Its a confirmed bug. (Bug 1075430 - Inventory Only ZENCollector fails when file scan not enabled)

Short Answer the ZenCollector.exe for ZCM 2017 Errors out if a value in the options.xml file is NULL

You can see a few errors in the debug logs once enabled.

For me the workaround is to go into the inventory only settings in ZCC ( ZCC > Configuration > Inventory > Inventory Only )

Under Software Files Enable the following:


  • Collect .EXE
  • System
  • Ancillary Application
  • Other



Without these set my devices would not show up in non-managed inventory.


To help trouble shoot, you can enable debug for the zenumia service in the registry ( I also enabled it in the ZCC Invenotry ONly Settings Page, this sets the OPTIONS.XML, otherwise if you manually make the change, it will reset when the service restarts)

https://www.novell.com/support/kb/doc.php?id=3418069

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Novell\ZCM\UMIA\Debugging]
"LogName"="zenumia.log"
"LogLevel"=dword:00000001

For diagnostic (most verbose) logging create a file in C:\Program Files (x86)\Novell\ZENworks\bin\ folder called cps.ini with the following:

[CollectionClient]
Diagnostic=2

Restart the service in services.msc or reboot

Logs can be found:
C:\Program Files (x86)\Novell\ZENworks\Logs\zenumia.log
C:\Program Files (x86)\Novell\ZENworks\bin\logs\ZenCollector.log




Trigger a collection / inventory

C:\Program Files (x86)\Novell\ZENworks\bin\zenumia.exe scannow
or
C:\Program Files (x86)\Novell\ZENworks\bin\ZenCollector.exe


Patrick
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.