Highlighted
Absent Member.
Absent Member.
955 views

Linux satellite 10.3.4: ZMD.RefreshHandlerException warning

Running ZCM 10.3.4.
Both our satellite servers suddenly started (during my holidays, where no changes were made) getting a warning. It occours every hour at Refresh.
Both satellites are running Linux 64 bit. One is SLES 10SP2 the other is SLES 11.

The warning is:
Full Message:
Unexpected exception received when refreshing handler ISSTFTPContentHandler(PartialRefresh): nullZMD.MessagePassedIsNull

Additional Information: None
Severity: Warning
Date: August 10, 2012 4:27:07 PM
Acknowledged Date: None
Source: /Devices/Servers/ztsat01
Message ID: ZMD.RefreshHandlerException
Probable Cause URL: None
Log ID: b1319b1320eb94cb9fb378712d545349
Related Objects: None

Anybody knows what could be causing this? Found a few old threads (2010) in the forum - but no solution. Have tried running some commands on the satellites:
zac satcc
zac cvc
zac cchk
zac satrc
Both cvc and cchk reported that every thing was ok. Also tried restarting both satellites. The primaries that the satellites refer to is also OK and have also had their services restarted.

Thanks
Anders
Labels (2)
0 Likes
3 Replies
Highlighted
Absent Member.
Absent Member.

martinusen,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.novell.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://forums.novell.com/

0 Likes
Highlighted
Absent Member.
Absent Member.

Set your logging level to DEBUG then perform a refresh:

zac logger level DEBUG
zac ref

Check the agent log (zmd-messages) to see if there are any errors reported.

DEV - ZCM 10.3.4/MS-SQL Database (2 Primaries & 2 Sats running 64-bit SLES 10.2 w/ ENGL Imaging Toolkit 7) PROD - ZCM 10.3.4/MS-SQL Database (5 Primaries & 11 Sats running 64-bit SLES 10.2 w/ ENGL Imaging Toolkit 7 ~7500 Managed Devices)
0 Likes
Highlighted
Absent Member.
Absent Member.

Sorry for not getting back on this one.

The problem went away after Sep 2012 PRU was applied.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.