sgardiner Absent Member.
Absent Member.
1552 views

Migration tool Error

I'm in the process of testing the migration from ZFD4 to ZCM. I'm currently using the migration tool to upload our apps. For some of the apps I'm seeing

Exception Thrown USAGE_ERROR: 2;The UID is not valid

This is an MSI based application.

As anyone seen this issue before ?

Thanks

Stephen Gardiner
Labels (2)
0 Likes
6 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Migration tool Error

For Grins, Try building a new application object in the ZFD Tree using the
"New Application->Existing Application Object" option for one of the ones
that is failing.
Let me know if that works. Then we can go from there.

--
Craig Wilson - MCNE, MCSE, CCNA
Novell Support Forums Volunteer Sysop

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
"sgardiner" <sgardiner@no-mx.forums.novell.com> wrote in message
news:sgardiner.3x5zjb@no-mx.forums.novell.com...
>
> I'm in the process of testing the migration from ZFD4 to ZCM. I'm
> currently using the migration tool to upload our apps. For some of the
> apps I'm seeing
>
> Exception Thrown USAGE_ERROR: 2;The UID is not valid
>
> This is an MSI based application.
>
> As anyone seen this issue before ?
>
> Thanks
>
> Stephen Gardiner
>
>
> --
> sgardiner
> ------------------------------------------------------------------------
> sgardiner's Profile: http://forums.novell.com/member.php?userid=9359
> View this thread: http://forums.novell.com/showthread.php?t=383572
>



0 Likes
sgardiner Absent Member.
Absent Member.

Re: Migration tool Error

Thanks Craig, I thought it may be something to do with the orginal app, I've all ready regenerated new GUIDs in ConsoleOne and the migration tool ran without issue. Fortunately its not a force run app assigned to everyone.

when I rebuild the test lab to redo the migration process again. I'll test the option of generating new application from existing object.

Thanks

Craig Wilson;1843425 wrote:
For Grins, Try building a new application object in the ZFD Tree using the
"New Application->Existing Application Object" option for one of the ones
that is failing.
Let me know if that works. Then we can go from there.

--
Craig Wilson - MCNE, MCSE, CCNA
Novell Support Forums Volunteer Sysop

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
"sgardiner" <sgardiner@no-mx.forums.novell.com> wrote in message
news:sgardiner.3x5zjb@no-mx.forums.novell.com...
>
> I'm in the process of testing the migration from ZFD4 to ZCM. I'm
> currently using the migration tool to upload our apps. For some of the
> apps I'm seeing
>
> Exception Thrown USAGE_ERROR: 2;The UID is not valid
>
> This is an MSI based application.
>
> As anyone seen this issue before ?
>
> Thanks
>
> Stephen Gardiner
>
>
> --
> sgardiner
> ------------------------------------------------------------------------
> sgardiner's Profile: NOVELL FORUMS - View Profile: sgardiner
> View this thread: Migration tool Error - NOVELL FORUMS
>
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Migration tool Error

Since the New GUID helped, I suspect one of two issues that ZCM does not
like the "Version Number" or the "GUID" number.
I would start with checking the "Version Number", since what is considered a
valid "Version Number" has varied greatly over the many years that ZDM has
been around.

--
Craig Wilson - MCNE, MCSE, CCNA
Novell Support Forums Volunteer Sysop

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
"sgardiner" <sgardiner@no-mx.forums.novell.com> wrote in message
news:sgardiner.3x65k4@no-mx.forums.novell.com...
>
> Thanks Craig, I thought it may be something to do with the orginal app,
> I've all ready regenerated new GUIDs in ConsoleOne and the migration
> tool ran without issue. Fortunately its not a force run app assigned to
> everyone.
>
> when I rebuild the test lab to redo the migration process again. I'll
> test the option of generating new application from existing object.
>
> Thanks
>
> Craig Wilson;1843425 Wrote:
>> For Grins, Try building a new application object in the ZFD Tree using
>> the
>> "New Application->Existing Application Object" option for one of the
>> ones
>> that is failing.
>> Let me know if that works. Then we can go from there.
>>
>> --
>> Craig Wilson - MCNE, MCSE, CCNA
>> Novell Support Forums Volunteer Sysop
>>
>> Novell does not officially monitor these forums.
>>
>> Suggestions/Opinions/Statements made by me are solely my own.
>> These thoughts may not be shared by either Novell or any rational
>> human.
>> "sgardiner" <sgardiner@no-mx.forums.novell.com> wrote in message
>> news:sgardiner.3x5zjb@no-mx.forums.novell.com...
>> >
>> > I'm in the process of testing the migration from ZFD4 to ZCM. I'm
>> > currently using the migration tool to upload our apps. For some of

>> the
>> > apps I'm seeing
>> >
>> > Exception Thrown USAGE_ERROR: 2;The UID is not valid
>> >
>> > This is an MSI based application.
>> >
>> > As anyone seen this issue before ?
>> >
>> > Thanks
>> >
>> > Stephen Gardiner
>> >
>> >
>> > --
>> > sgardiner
>> >

>> ------------------------------------------------------------------------
>> > sgardiner's Profile: 'NOVELL FORUMS - View Profile: sgardiner'

>> (http://forums.novell.com/member.php?userid=9359)
>> > View this thread: 'Migration tool Error - NOVELL FORUMS'

>> (http://forums.novell.com/showthread.php?t=383572)
>> >

>
>
> --
> sgardiner
> ------------------------------------------------------------------------
> sgardiner's Profile: http://forums.novell.com/member.php?userid=9359
> View this thread: http://forums.novell.com/showthread.php?t=383572
>



0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Migration tool Error

Craig Wilson,

>
>Since the New GUID helped, I suspect one of two issues that ZCM does not
>like the "Version Number" or the "GUID" number.
>I would start with checking the "Version Number", since what is considered
>a valid "Version Number" has varied greatly over the many years that ZDM
>has been around.


Why would it throw a UID attr error if the version number was incorrectly
formatted? Or is it a bogus error in that the bundle failed to create
because of an error farther up the stream?

--
Jared Jennings
Novell Support Forums Sysop
Senior Systems Architect, Data Technique, Inc.
http://www.datatechnique.com

My Blog and Wiki with Tips, Tricks, and Tutorials
http://jaredjennings.org
Twitter@ http://twitter.com/jaredljennings
0 Likes
sgardiner Absent Member.
Absent Member.

Re: Migration tool Error

The complete error message was
Migrating from tree to zone

Error Migrating cn=Microsoft Project 2000to /~bundles~/Applications/zfd4/MSI/Microsoft Project 2000
Exception Thrown USAGE_ERROR: 2;The UID is not valid: 71c84fa196d521b8000a4647c in Migrate
Stack Trace: at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at PluginInterface.BundleAdminService.BundleAdminServiceService.existsByUID(String uid)
at Apps.Plugin.Migrate(MigrationInfoStruct myMigrationInfoStruct)
Aborting Migration Task
Migration failed for cn=Microsoft Project 2000
Migration of this object took: 0 hours, 0 minutes, 0 seconds, 187 milliseconds

looking on Novell support I see mention of GUID problems with ZFD4 and console one snapins used to create the app, causing issues with deployement. The app is fully deployed, so I'm unsure if should have seen an issue in our current environment. Generating a new GUID looks to have resolved the issue.

The app is question is Microsoft Project 2000, using a network installation point, as was used for other Microsoft Apps, like Office 2000 and 2003, standard and professional.

Steve Gardiner

Jared Jennings;1843919 wrote:
Craig Wilson,

>
>Since the New GUID helped, I suspect one of two issues that ZCM does not
>like the "Version Number" or the "GUID" number.
>I would start with checking the "Version Number", since what is considered
>a valid "Version Number" has varied greatly over the many years that ZDM
>has been around.


Why would it throw a UID attr error if the version number was incorrectly
formatted? Or is it a bogus error in that the bundle failed to create
because of an error ****her up the stream?

--
Jared Jennings
Novell Support Forums Sysop
Senior Systems Architect, Data Technique, Inc.
Data Technique, Inc. | Information Technology Consulting Solutions

My Blog and Wiki with Tips, Tricks, and Tutorials
Main Page - ZENWorks Wiki
Twitter@ Jared Jennings (jaredljennings) on Twitter
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Migration tool Error

sgardiner,

>looking on Novell support I see mention of GUID problems with ZFD4 and
>console one snapins used to create the app, causing issues with
>deployement. The app is fully deployed, so I'm unsure if should have
>seen an issue in our current environment. Generating a new GUID looks
>to have resolved the issue.


I think I remember that the uid error is just a symptom. In actuality the
app failed to create because of some other problem and in this case the
Version Number or the GUID.

--
Jared Jennings
Novell Support Forums Sysop
Senior Systems Architect, Data Technique, Inc.
http://www.datatechnique.com

My Blog and Wiki with Tips, Tricks, and Tutorials
http://jaredjennings.org
Twitter@ http://twitter.com/jaredljennings
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.