Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Highlighted
Anonymous_User Absent Member.
Absent Member.
1682 views

New ZCM 11.1a Install problems

I'm trying to setup a new ZCM 11.1a server in our environment.

Server is an ESXi 4.1 guest running SLES10sp4, fully patched. Nothing else installed/configured on the server, it's just for Zenworks.

The initial installation failed with a problem creating packages, but I continued anyway, thinking that was relatively minor and I could go back and resolve it later. All the services appear to be running, but I know it's broken. Running ZDC 11.1 turns up the following error, which also shows up in various log files. I've tried to reinstall hoping to fix the problem, but it wants to connect to the database, which it can't do. I installed it using an internal CA (logged into the server as root) and internal Sybase database. The database service is running, as well as all the zenworks services.

Here's the output of the ZDC:

+ Starting ZENworks Diagnostic Center.

+ ----------------------------------
System Information:
+ ----------------------------------
OS: SUSE Linux Enterprise Server 10 64 bit
Database: Unknown Database
ZCM Version: 11.1.0

+ Loading configuration.
java.io.FileNotFoundException: /etc/opt/novell/zenworks/datamodel/zdm.xml (No such file or directory)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:106)
at com.novell.zenworks.zdc.config.Configuration.loadDatabaseConfiguration(Configuration.java:368)
at com.novell.zenworks.zdc.config.Configuration.initialize(Configuration.java:222)
at com.novell.zenworks.zdc.DiagnoseZen.startZDC(DiagnoseZen.java:99)
at com.novell.zenworks.zdc.DiagnoseZen.start(DiagnoseZen.java:64)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.novell.zenworks.zdc.boot.Bootstrap.main(Bootstrap.java:113)

Basically the zdm.xml is missing (which it is). Is there a way to create this manually? I tried doing the install previously and ended up just wiping the guest and rebuilding it (only takes an hour or so) because of all the problems it was having. I can't run the upgrade because it knows ZCM is already installed but it wants to connect to an external database. (probably because it can't connect to the one internally)
Labels (2)
0 Likes
1 Reply
shaunpond Absent Member.
Absent Member.

Re: New ZCM 11.1a Install problems

Ncoppersmith,

is this the ZDC from the ISO, or the one from
http://download.novell.com/Download?buildid=IuWRC-qliTo~ ?

--

Shaun Pond


0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.