GuillaumeBDEB Absent Member.
Absent Member.
3120 views

Novell client - Silent install - setup.exe_unknown error

Hi, first of all I'm sorry if I post this in the wrong place. I wasn't sure if I should post this in the Netware client forum or the ZENworks forum. Lately I'm having a rough time to silently deploy the Novell client 2 SP3 IR3 using a ZENworks bundle. The bundle was working great the last 2 years. With each new version all I did was update my bundle with the new files. But lately my bundle will just freeze during the setup.exe execution. And it just sits there without any errors or crash. After checking the logs I get a log about the application setup.exe_unknown that crash with error 1000 from the Application journal.

Journal: Application
Source: Application Error
Event: 1000
Category: (100)
Nom de l’application défaillante setup.exe_unknown, version : 5.0.69.1831, horodatage : 0x51f74458
Nom du module défaillant : setup.exe, version : 5.0.69.1831, horodatage : 0x51f74458
Code d’exception : 0x40000015
Décalage d’erreur : 0x00118f69
ID du processus défaillant : 0x230
Heure de début de l’application défaillante : 0x01ce99f8d803285f
Chemin d’accès de l’application défaillante : C:\Temp\NC2SP3IR3\setup.exe
Chemin d’accès du module défaillant: C:\Temp\NC2SP3IR3\setup.exe
ID de rapport : 163e85d0-05ec-11e3-a80c-4437e63c8e49

I can restart the computer 10 times in a row and the setup.exe will crash every single time. But sometimes it will pass without any problem! It's driving me crazy! By the way we are using ZENworks 11.2.3a MU1 and Windows 7 Ent. SP1 x64 French.

Thanks in advance for the help!
Labels (2)
0 Likes
13 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Novell client - Silent install - setup.exe_unknown error

On 8/16/2013 2:16 PM, GuillaumeBDEB wrote:
>
> Hi, first of all I'm sorry if I post this in the wrong place. I wasn't
> sure if I should post this in the Netware client forum or the ZENworks
> forum. Lately I'm having a rough time to silently deploy the Novell
> client 2 SP3 IR3 using a ZENworks bundle. The bundle was working great
> the last 2 years. With each new version all I did was update my bundle
> with the new files. But lately my bundle will just freeze during the
> setup.exe execution. And it just sits there without any errors or crash.
> After checking the logs I get a log about the application
> setup.exe_unknown that crash with error 1000 from the Application
> journal.
>


I bet if you run the Client install directly, you will see a Windows UAC
prompt. See my discussion with Alan Adams in the thread "NC2 SP2 IR3
NICI Installation Error" in the Client forum about pre-distributing the
code signing certificate.

Client 2 SP3 IR3 has an updated code signing certificate (previous one
expired on 4/26/2013). If you are already pre-distributing the
certificate in your bundle, you will need to re-export the new one
(expires 6/3/2016) and update it in your bundle.

--
Jason Doering

Address is munged; I already get enough spam.
Remove three nospams to reply.
0 Likes
GuillaumeBDEB Absent Member.
Absent Member.

Re: Novell client - Silent install - setup.exe_unknown error

Then I missed something here because I already input the new one in my bundle (4D8494B2925253999601FB1C749AFE098593B7FD). I found the new one under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SystemCertificates\TrustedPublisher\certificates\4D8494B2925253999601FB1C749AFE098593B7FD. Unless only pushing the registry key before isn't enough or I’m not doing it correctly.

Thanks again for the help!
0 Likes
GuillaumeBDEB Absent Member.
Absent Member.

Re: Novell client - Silent install - setup.exe_unknown error

After some reading I decide to modify my bundle in the way that I push my certificate. So I add these 3 steps to my bundle before launching the installation of the client.

1- Copy the certificate file (.cer) on the target computer.
2- Launch the certificate import command: certutil -addstore TrustedPublisher <certificate>
3- Delete the certificate file (.cer)

I now have some testing to do. Will let you know if it helps...
Guillaume
0 Likes
Knowledge Partner
Knowledge Partner

Re: Novell client - Silent install - setup.exe_unknown error

GuillaumeBDEB,
> 1- Copy the certificate file (.cer) on the target computer.
> 2- Launch the certificate import command: certutil -addstore
> TrustedPublisher <certificate>
> 3- Delete the certificate file (.cer)


That is retty much what I do here

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
GuillaumeBDEB Absent Member.
Absent Member.

Re: Novell client - Silent install - setup.exe_unknown error

Hi Anders, for the certificate part it indeed works as expected. But my problem remain the same! My ZENworks bundle starts and just stop at setup.exe. The process setup.exe remains in memory but doesn't do anything. The CPU is using 0% for this process. The steps in my bundle are as follows.

1- Import the new certificate following the steps that I already mention earlier. That is working perfectly.
2- I copy in C:\Temp my folder containing the client installation files and unzip everything in a new temporary sub folder.
3- I then copy the files Install.ini and Unattend.txt in this same sub folder to make my install a silent one.
4- Finaly, I launch the command setup.exe with the switches /ACU /NCPF:Unattend.txt /L:FRANCAIS
I use the same steps since the Novell client 2 SP1 for Windows IR1!

In the Windows logs I found this under Application.

Nom de l’application défaillante setup.exe_unknown, version : 5.0.69.1831, horodatage : 0x51f74458
Nom du module défaillant : setup.exe, version : 5.0.69.1831, horodatage : 0x51f74458
Code d’exception : 0x40000015
Décalage d’erreur : 0x00118f69
ID du processus défaillant : 0x95c
Heure de début de l’application défaillante : 0x01ce9ec398623b5b
Chemin d’accès de l’application défaillante : C:\Temp\NC2SP3IR3\setup.exe
Chemin d’accès du module défaillant: C:\Temp\NC2SP3IR3\setup.exe
ID de rapport : d685cb09-0ab6-11e3-8fa1-002710c924e0
Journal: Application
Source: Application Error
Évènement: 1000
Catégorie: (100)


I'm going mad here! I can't find any other useful information. The setup.exe just stop and nothing happens. There's no popup, no warning, etc. And, because this bundle stop then no other bundle ever launch until I kill the setup.exe process. I also get an error when I'm trying to just update a computer with this new version. It doesn't happen on all computers but enough that it gets notice.

Erreur lors de l'installation de l'infrastructure NICI (Novell International Cryptographic Infrastructure). Code d'erreur: 1603


Which basically means that the NICI installation has just crash with a 1603 MSI error.

Thanks again for the help!

AndersG;2277709 wrote:
GuillaumeBDEB,
> 1- Copy the certificate file (.cer) on the target computer.
> 2- Launch the certificate import command: certutil -addstore
> TrustedPublisher <certificate>
> 3- Delete the certificate file (.cer)


That is retty much what I do here

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms
0 Likes
Knowledge Partner
Knowledge Partner

Re: Novell client - Silent install - setup.exe_unknown error

GuillaumeBDEB,
> Code d’exception : 0x40000015


Try googling for that error code. Does it happen on just one PC or
several?

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
GuillaumeBDEB Absent Member.
Absent Member.

Re: Novell client - Silent install - setup.exe_unknown error

The error code 0x40000015 is too general. But many people say that it could have something to do with some incompatible applications. But I still haven't found anything useful other than that. Maybe I could try with process monitor running during the installation. And for the other question it happens on each new installation. So, yes, it is very annoying you can imagine.

Note: Because of this problem I recreated my Windows 7 Ent. SP1 x64 base image with the latest updates. I also recreated my Novell client 2 SP3 IR3 ZENworks bundle. Which haven't change a thing.

Thanks again for the help!
Guillaume

AndersG;2278547 wrote:
GuillaumeBDEB,
> Code d’exception : 0x40000015


Try googling for that error code. Does it happen on just one PC or
several?

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms
0 Likes
Knowledge Partner
Knowledge Partner

Re: Novell client - Silent install - setup.exe_unknown error

GuillaumeBDEB,
> The error code 0x40000015 is too general. But many people say that it
> could have something to do with some incompatible applications. But I
> still haven't found anything useful other than that. Maybe I could try
> with process monitor running during the installation. And for the other
> question it happens on each new installation. So, yes, it is very
> annoying you can imagine.


What about yanking up MSI logging (voicewarmup) and looking for clues in
the MSI log?

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
GuillaumeBDEB Absent Member.
Absent Member.

Re: Novell client - Silent install - setup.exe_unknown error

AndersG;2278841 wrote:
GuillaumeBDEB,
> The error code 0x40000015 is too general. But many people say that it
> could have something to do with some incompatible applications. But I
> still haven't found anything useful other than that. Maybe I could try
> with process monitor running during the installation. And for the other
> question it happens on each new installation. So, yes, it is very
> annoying you can imagine.


What about yanking up MSI logging (voicewarmup) and looking for clues in
the MSI log?

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms


Sorry for the delay but I had a few things to fix since the beginning of the new semester. That said I finally found where the problem is. It's the name of my answer file that I created with nciman64.exe! In the Novell documentation it is said that we can use any name, for example workstation_properties.txt. So I use the name Unattend.txt for my file and I also use it in my Install.ini file. This doesn't work. I tried to launch the installation manually. It doesn't work. I tried by command line using "setup.exe /ACU /NCPF /L:FRANCAIS", "setup.exe /ACU /NCPF:Unattend.txt /L:FRANCAIS" or just "setup.exe /ACU" and it still won't work. Bus as soon as I use the name "NovellClientProperties.txt" instead then everything works. By the way, since it crash before anything got installed there's no msi logs, no Windows error other than the famous setup.exe_unknown error. And there's no switch that we can add to the Novell client setup to be able to generate some logs, like setup.exe /L logfile.txt etc. So, is this a bug? Is it only me that have this problem?

Thanks anyway for the help!
Guillaume
0 Likes
Knowledge Partner
Knowledge Partner

Re: Novell client - Silent install - setup.exe_unknown error

Interesting! Let me run that past Novell...

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
GuillaumeBDEB Absent Member.
Absent Member.

Re: Novell client - Silent install - setup.exe_unknown error

AndersG;2284042 wrote:
Interesting! Let me run that past Novell...

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms


I discovered this morning that sometimes I still get the setup.exe_unknown error. But I just restart the workstation and the Novell client will then install properly. So it's not a 100% perfect solution but close enough for me.

Guillaume
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.