Anonymous_User Absent Member.
Absent Member.

Re: Novell client - Silent install - setup.exe_unknown error

On 8/22/2013 10:36 AM, GuillaumeBDEB wrote:
>
> Hi Anders, for the certificate part it indeed works as expected. But my
> problem remain the same! My ZENworks bundle starts and just stop at
> setup.exe. The process setup.exe remains in memory but doesn't do
> anything. The CPU is using 0% for this process. The steps in my bundle
> are as follows.
>
> 1- Import the new certificate following the steps that I already
> mention earlier. That is working perfectly.
> 2- I copy in C:\Temp my folder containing the client installation files
> and unzip everything in a new temporary sub folder.
> 3- I then copy the files Install.ini and Unattend.txt in this same sub
> folder to make my install a silent one.
> 4- Finaly, I launch the command setup.exe with the switches /ACU
> /NCPF:Unattend.txt /L:FRANCAIS
> I use the same steps since the Novell client 2 SP1 for Windows IR1!
>
>


A couple thoughts here:

1) Are you using McAfee AV? If so, it has a default rule to block or at
least complain about running .exe files in folders named "Temp". This
might be getting in your way.

2) Assuming your Install.ini is fully configured, have you tried calling
the install with just the acu.exe with no switches? That is how I run my
bundle and I have seen no issues.

--
Jason Doering

Address is munged; I already get enough spam.
Remove three nospams to reply.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Novell client - Silent install - setup.exe_unknown error

I am not sure if it is related, but when I deployed Novell Client 2 SP3
(IR2) with either the ZCM Patch bundle or a bundle I created myself I
received copy file errors during the install process. Either type of bundle
launches the install as Dynamic Administrator. As such, if someone is
logged into the workstation the installation process pops up various
progress boxes. When the install gets to the file copy process, on most
machines it would halt at some point with an error like: "Setup cannot copy
the file ncnetprovider.dll" (the name of the dll file differed from machine
to machine). If I clicked the "retry" option the file would be copied and
the installation would continue. On a few machines the installation
happened without error, but on most machines I received the setup cannot
copy error on 1 to 6 files. Clicking "retry" each time allowed the
installation to complete successfully, but there was no way I could deploy
this as a silent install.

I contacted Zenworks support and the technician thought this might be a
bundle timing error. So I modified the bundles to add some delay, and I
also distributed the bundles well before installation. This did not make a
difference.

I finally created a shortcut to the bundle on the users desktops and ask
them to double click on the icon to install the upgrade with instructions to
click "retry" each time the setup cannot copy error came up. This worked
pretty well, but it certainly was more hassle then a simple silent install.

Brad Johnson

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.