Knowledge Partner
Knowledge Partner
2122 views

PCs registering with wrong name

Windows 7 64 bit on PCs. ZCM 11.2. Apply image (which was originally
created under ZCM 10) to PC. PC is registered with the name of the PC
used to create the image rather than assigning the PC Name that I
entered using zisedit. I didn't have this problem with ZCM 10. Any
suggestions?

Thanks,
Ken
--
Ken
Knowledge Partner

Create and vote for enhancements!
Idea Exchange sites within this community are now coming online for some of the Collaboration Products!
GroupWise Idea Exchange - https://community.microfocus.com/t5/GroupWise-Idea-Exchange/idb-p/GWideas
SMG Idea Exchange - https://community.microfocus.com/t5/Secure-Messaging-Gateway-Idea/idb-p/SMG_Ideas
Old method is still available for some products here: https://www.microfocus.com/products/enhancement-request.html
Labels (2)
0 Likes
10 Replies
nop19832 Absent Member.
Absent Member.

Re: PCs registering with wrong name

KeN Etter wrote:

> Windows 7 64 bit on PCs. ZCM 11.2. Apply image (which was originally
> created under ZCM 10) to PC. PC is registered with the name of the PC
> used to create the image rather than assigning the PC Name that I
> entered using zisedit. I didn't have this problem with ZCM 10. Any
> suggestions?
>
> Thanks,
> Ken


The name you entered using zisedit? After the boot (after sysprep),
does it still have the name you entered? And then when installing the
ZCM Agent it changes it back to the original?

Else... it sounds like you've already installed the agent? Then you'll
need to run zac fsg -d on the device before uploading the image. But it
depends on; is the agent predeployed or not?

--

--
Niels Poulsen

Novell Knowledge Partner

-------------------------------
A TRUE RED DEVIL

-- Niels I have always liked... Cowabunga! If you find this post helpful, please show your appreciation by clicking on the star below. A member must be logged in before s/he can assign reputation points.
0 Likes
Knowledge Partner
Knowledge Partner

Re: PCs registering with wrong name

On Tue, 22 May 2012 22:38:01 GMT, "Niels Poulsen" <nop@viborg.dk>
wrote:

>Else... it sounds like you've already installed the agent? Then you'll
>need to run zac fsg -d on the device before uploading the image.


Yes, the agent is already installed and I did run zac fsg -d before
uploading the image. However, I found a little note in the docs
(ZENworks 11 SP2 Preboot Services and Imaging Reference) that states:

"If you want to take an image of a Windows device or copy a Virtual
machine that has ZENworks 10.3.x Agent installed on it, delete the
coninfo.dat file available in the %ZENworks_HOME%\bin\ folder to avoid
the creation of duplicate device objects."

This image had the ZCM 10.3 agent on it - I had created the image
prior to my upgrade to 11. So I assume this is the problem.

Regards,
Ken
--
Ken
Knowledge Partner

Create and vote for enhancements!
Idea Exchange sites within this community are now coming online for some of the Collaboration Products!
GroupWise Idea Exchange - https://community.microfocus.com/t5/GroupWise-Idea-Exchange/idb-p/GWideas
SMG Idea Exchange - https://community.microfocus.com/t5/Secure-Messaging-Gateway-Idea/idb-p/SMG_Ideas
Old method is still available for some products here: https://www.microfocus.com/products/enhancement-request.html
0 Likes
nop19832 Absent Member.
Absent Member.

Re: PCs registering with wrong name

KeN Etter,

> Yes, the agent is already installed and I did run zac fsg -d before
> uploading the image. However, I found a little note in the docs
> (ZENworks 11 SP2 Preboot Services and Imaging Reference) that states:
>
> "If you want to take an image of a Windows device or copy a Virtual
> machine that has ZENworks 10.3.x Agent installed on it, delete the
> coninfo.dat file available in the %ZENworks_HOME%\bin\ folder to avoid
> the creation of duplicate device objects."
>
> This image had the ZCM 10.3 agent on it - I had created the image
> prior to my upgrade to 11. So I assume this is the problem.
>
> Regards,
> Ken


Okay, yes this could be the reason. Have you considered to recreate the
image with the ZCM 11 agent installed instead of the old version?

--

Niels Poulsen

Novell Knowledge Partner

-------------------------------
A TRUE RED DEVIL

-- Niels I have always liked... Cowabunga! If you find this post helpful, please show your appreciation by clicking on the star below. A member must be logged in before s/he can assign reputation points.
0 Likes
Knowledge Partner
Knowledge Partner

Re: PCs registering with wrong name

On Wed, 23 May 2012 11:46:42 GMT, "Niels Poulsen" <nop@viborg.dk>
wrote:

>Okay, yes this could be the reason. Have you considered to recreate the
>image with the ZCM 11 agent installed instead of the old version?


I'm doing that as I have time. Way too much on the to do list right
now.

Ken
--
Ken
Knowledge Partner

Create and vote for enhancements!
Idea Exchange sites within this community are now coming online for some of the Collaboration Products!
GroupWise Idea Exchange - https://community.microfocus.com/t5/GroupWise-Idea-Exchange/idb-p/GWideas
SMG Idea Exchange - https://community.microfocus.com/t5/Secure-Messaging-Gateway-Idea/idb-p/SMG_Ideas
Old method is still available for some products here: https://www.microfocus.com/products/enhancement-request.html
0 Likes
Highlighted
nop19832 Absent Member.
Absent Member.

Re: PCs registering with wrong name

KeN Etter,

> I'm doing that as I have time. Way too much on the to do list right
> now.
>
> Ken


Okay, yes as there always are...

--

--
Niels Poulsen

Novell Knowledge Partner

-------------------------------
A TRUE RED DEVIL

-- Niels I have always liked... Cowabunga! If you find this post helpful, please show your appreciation by clicking on the star below. A member must be logged in before s/he can assign reputation points.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: PCs registering with wrong name

I would recommend enabling Differentiation if it is not and set it to
"Computer Name" and "Mac Address".

On 5/23/2012 1:55 PM, Niels Poulsen wrote:
> KeN Etter,
>
>> I'm doing that as I have time. Way too much on the to do list right
>> now.
>>
>> Ken

>
> Okay, yes as there always are...
>



--
Craig Wilson - MCNE, MCSE, CCNA
Novell Knowledge Partner

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
nop19832 Absent Member.
Absent Member.

Re: PCs registering with wrong name

craig wilson wrote:

> I would recommend enabling Differentiation if it is not and set it to
> "Computer Name" and "Mac Address".
>
> On 5/23/2012 1:55 PM, Niels Poulsen wrote:
> > KeN Etter,
> >
> > > I'm doing that as I have time. Way too much on the to do list
> > > right now.
> > >
> > > Ken

> >
> > Okay, yes as there always are...
> >


Yep.

--
--

Niels Poulsen

Novell Knowledge Partner

-------------------------------
A TRUE RED DEVIL

-- Niels I have always liked... Cowabunga! If you find this post helpful, please show your appreciation by clicking on the star below. A member must be logged in before s/he can assign reputation points.
0 Likes
WilHue Absent Member.
Absent Member.

Re: PCs registering with wrong name

Did you have the zcm11.2 monthly update 2 installed?

I have a problem with registration ws too.

greetings wilfred
0 Likes
casutton Frequent Contributor.
Frequent Contributor.

Re: PCs registering with wrong name

All of my workstations are doing weird things with registration as well. When I reimage a workstation that was already in the system, it changes its name to a random windows-xxxxxxx name. In 11.1 and earlier it would keep the old workstation name on the workstation after imaging as well as in the ZENWorks database. This is highly annoying.
0 Likes
nop19832 Absent Member.
Absent Member.

Re: PCs registering with wrong name

casutton wrote:

>
> All of my workstations are doing weird things with registration as
> well. When I reimage a workstation that was already in the system,
> it changes its name to a random windows-xxxxxxx name. In 11.1 and
> earlier it would keep the old workstation name on the workstation
> after imaging as well as in the ZENWorks database. This is highly
> annoying.


How did you configure your Device Dynamic Rename and Reconcile settings?

--
Niels

-- Niels I have always liked... Cowabunga! If you find this post helpful, please show your appreciation by clicking on the star below. A member must be logged in before s/he can assign reputation points.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.