Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
reverendjb
Visitor.
3737 views

Prevent ZAPP from opening automatically at login?

I'm starting to roll out ZCM 2017a agent to workstations here, and the application window is automatically opening for some users at login.

I'm not talking about just starting the agent service, but the application window opens up. I have not observed this behavior by default in any previous versions of ZCM.

Any reason for this? I can't find any setting related to this, nothing in startup folders or known (to me) registry keys.
Labels (1)
0 Likes
22 Replies
Micro Focus Expert
Micro Focus Expert

Re: Prevent ZAPP from opening automatically at login?

You can remove ZAPP from the Run Registry key if you wish, but that is likely not the desired result.
There is a ticket opened with dev about this, and there may be a better option in Update 1.

Seems to be a timing issue.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
Highlighted
adrockk Trusted Contributor.
Trusted Contributor.

Re: Prevent ZAPP from opening automatically at login?

CRAIGDWILSON;2456446 wrote:
You can remove ZAPP from the Run Registry key if you wish, but that is likely not the desired result.
There is a ticket opened with dev about this, and there may be a better option in Update 1.

Seems to be a timing issue.


Hi Craig,

Any hints at when we can expect update 1? or an FTF to fix this? Is it worth opening an SR for?
This is a pretty big oversight, in my opinion, and I'm sure it will annoy and confuse my users endlessly.

0 Likes
shaunpond Absent Member.
Absent Member.

Re: Prevent ZAPP from opening automatically at login?

Adrockk,

Craig's said in other threads, that it's looking like it might be mid
to late June

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Prevent ZAPP from opening automatically at login?

So currently in 11.x the App launcher opening at login , user being able to
x out of it or not ( I set these some where a long time ago. but I can't
actually find those settings right now:(, manual refresh enabled, explorer
settings, common settings etc is controlled through the NAL policy. This
policy came with Zen. Not having played with 2017 yet is this policy baked
in and available to config?

"adrockk" wrote in message
news:adrockk.7z3rk1@no-mx.forums.microfocus.com...


CRAIGDWILSON;2456446 Wrote:
> You can remove ZAPP from the Run Registry key if you wish, but that is
> likely not the desired result.
> There is a ticket opened with dev about this, and there may be a better
> option in Update 1.
>
> Seems to be a timing issue.


Hi Craig,

Any hints at when we can expect update 1? or an FTF to fix this? Is it
worth opening an SR for?
This is a pretty big oversight, in my opinion, and I'm sure it will
annoy and confuse my users endlessly.


--
adrockk
------------------------------------------------------------------------
adrockk's Profile: https://forums.novell.com/member.php?userid=1638
View this thread: https://forums.novell.com/showthread.php?t=503536

0 Likes
dbriese
New Member.

Re: Prevent ZAPP from opening automatically at login?

I solved it by creating a new GPO to disable ZAPP autostart but do note this is on Windows 10 1607! With Windows 7 you probably need to completey remove the ZAPP entry in HKLM\Software\Microsoft\...\Run.

Computerconfiguration > Windows Settings > Registry

Action: Replace
Structure: HKEY_LOCAL_MACHINE
Key: SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\StartupApproved\Run32
Name: ZAPP
Type: REG_BINARY
Data: 03000000245C8C86EDD2D201

To re-enable ZAPP autostart just use:
Data: 023000000000000000000000

I found those two values by manually deactivating and re-activating zapp autostart from within Task Manager. Setting those values via GPO/registry also results in Task Manager correctly representing its (de)activated state.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Prevent ZAPP from opening automatically at login?

This remove the ZENworks Icon from the System Tray as well.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
dbriese
New Member.

Re: Prevent ZAPP from opening automatically at login?

CRAIGDWILSON;2458397 wrote:
This remove the ZENworks Icon from the System Tray as well.


Nope, tray icon is still there! 🙂
0 Likes
fraunhoferpt Absent Member.
Absent Member.

Re: Prevent ZAPP from opening automatically at login?

Icon is not there to me when using the registry hack.
Also, even with Zenworks 2017 Update 1, Zenworks Application still shows after login.
Any idea how to fix it and still have the icon in the tray area?

Thanks.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Prevent ZAPP from opening automatically at login?

It should be called with this parm in the RUN registry key....
C:\Program Files (x86)\Novell\Zenworks\bin\zapp-launcher.exe /runonce
(This is auto-updated with SP1....)
That should stop the Window from running.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
fraunhoferpt Absent Member.
Absent Member.

Re: Prevent ZAPP from opening automatically at login?

/runonce is present but still ZAPP opens.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Prevent ZAPP from opening automatically at login?

Definitely recommend a ticket...........Unless you can find some other source that may be calling ZAPP, such as a bundle set to run at logon etc....
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
gturcsik Absent Member.
Absent Member.

Re: Prevent ZAPP from opening automatically at login?

CRAIGDWILSON;2456446 wrote:
You can remove ZAPP from the Run Registry key if you wish, but that is likely not the desired result.
There is a ticket opened with dev about this, and there may be a better option in Update 1.

Seems to be a timing issue.


Hi,

I upgraded a zone from ZENworks 11.4.1 to ZENworks 2017 Update 1. We started to upgrade the agents but the application window is automatically opening on the upgraded workstations.
Only ZAM activated in the zone. Customer use ZENworks Appliance. The Z-icon hided on workstations with ZENworks policy.

Is there a bug for the issue?

Regards,
Gergely
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Prevent ZAPP from opening automatically at login?

Not aware of that being a known issue.....

But you can remove zapp-launcher.exe from hklm\software\wow6432node\microsoft\windows\currentversion\run
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
jvzuijlen Absent Member.
Absent Member.

Re: Prevent ZAPP from opening automatically at login?

We have this as well with some users. Removing zapp-launcher.exe /runonce from hklm\software\wow6432node\microsoft\windows\currentversion\run removes the auto-start, but also doesn't start the taskbar icon.
disabling the nalview.exe which is also set in registry does not help anything. (Nalview autostart should have been removed by previous updates?!).
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.