sjdimare1 Absent Member.
Absent Member.
421 views

Push REG key to HKLM - works but then is erased after user l

Hello all,

I am trying to push a registry key change to HKLM for the Legalnoticecaption and Legalnoticetext.

I have created a simple Windows Bundle - Install - RegEdit and Imported the keys. I have it set to install as System and the keys are set to create always.

I have assigned the bundle to a couple of systems; Distribution, on Event, Device Boot and checked the box to install immediately after distribution.

If the system is powered down completely and then powered on, the keys distribute and after a CTRL+ALT+DEL, the user is presented with the message and then they can click OK and then login.

If the user logs off or the computer is restarted, the next user will not be presented with the Legal Notice. If you shut the computer down completely and then power on, the key is distributed and the first user will get the notice.

Other things of note, we use DLU non-volatile for staff and volatile for students.

Any thoughts on this matter are greatly appreciated.

Thanks,

Steve D.
Labels (2)
0 Likes
2 Replies
Micro Focus Expert
Micro Focus Expert

Re: Push REG key to HKLM - works but then is erased after us

Do you have bundles set to uninstall after 0 days of not being assigned?
This can cause flakiness and may cause the bundle to uninstall unexpectedly and remove the keys.

It may also be possible you have another bundle that is pushing different values to that same location.
I would verify if the keys and values are actually being removed.

However, if the keys are remaining in place but not always working, I'm suspect that is more of a Windows issue.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
sjdimare1 Absent Member.
Absent Member.

Re: Push REG key to HKLM - works but then is erased after us

Thanks for your reply.

I am not sure that we have set any items to uninstall after 0 days. Where would I find that settings? Is it global or per bundle?

I have double checked any bundles that are making registry edits and it does not appear that they reference the same keys. It will take time to go through them all to really make sure but I will check.

It is definitely an issue with either the Novell Client or ZCM because if I make the changes using a local Admin account and login and restart and login again as the same local Admin, the settings stick. As soon as a login as a DLU user (withou or even with Novell login, the registry keys become blank again.

More digging to do.

Steve D.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.