New Ranks & Badges For The Community!
Notice something different? The ranks and associated badges have gone "Star Fleet". See what they all mean HERE
Highlighted
Absent Member.
Absent Member.
1667 views

Questions after updating to ZCM 2017

I successfully updated my single primary appliance to ZENworks 2017, and I can log into the Appliance portal and more importantly I can login to the ZENworks Control Center, see all the WS and deploy an agent out to a WS, however:

1. In the Appliance portal, when I click on System Services to turn on ssh for the appliance, I get a screen with no services listed and clicking on the 'Close' button doesn't do anything. The same thing happens for Time - I click the Time icon in the portal, eventually the time screen will come up but I can't edit anything and the 'OK' and 'Cancel' buttons don't work.

2. In the Appliance portal, when clicking on 'Online Update', I get the error:
com.google.gwt.user.client.rpc.IncompatibleRemoteServiceException: Type 'com.google.gwt.user.client.rpc.XsrfToken' was not assignable to
'com.google.gwt.user.client.rpc.IsSerializable' and did not have a custom field serializer. For security purposes, this type will not be deserialized.

and when I cancel out of the popup I can't register to get updates. I click Register from the dropdown, select 'Micro Focus Customer Center', specify the host
I want to register, click to register and get an rpc communications error again.

How do I fix this?

3. Also, from the VMware Console screen, I can't enable the ssh shell because it is not under /etc. How do I turn it on manually?

4. On Windows 10 machines, it looks like Windows Explorer still has to be manually refreshed before you can deploy the agent. This was the same problem
that we had updating from the 11.4.2 to the 11.4.3 agent which is a real pain.

Help!

Dan
Labels (1)
0 Likes
10 Replies
Highlighted
Absent Member.
Absent Member.

Any thoughts on how I can enable SSH? I can't upload the 2017 ZDC to the appliance because ssh is disabled. I can't even view all the results from the System-Status command from the VMware console window because the new appliance has removed the scroll bars. I had them with the 11.4.3 appliance but they are no longer there in the ZCM 2017 appliance.

Dan
0 Likes
Highlighted
Absent Member.
Absent Member.

Shaun, with all due respect, I KNOW how to start the system services. If you read my initial post, you will see that when I went to the System Services option of the Portal, I got an error message, which I provided, and no services were listed. This happened to my the night that I upgraded my system to ZCM 2017 and multiple times when I tried the next day.

Today, I tried it again and finally I see the SSH and Proxy DHCP service listed under system services. Is it normal that it takes 3 or 4 days for this to show up? I have a small system with a single ZCM 2017 Appliance and about 200 WS.

Now that I can see the SSH option in System Services, I highlight it, click Actions | Start, get a brief progress bar and then see it is still stopped. I try it multiple times with the same results. I can set the SSH service to Automatic from Manual and I can set the Proxy DHCP service to automatic as well as start the service without a problem. Why won't the SSH service start? What log file should I look at to further troubleshoot this?

Dan
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

I don't recall anyone reporting these issues before.
I would recommend ensuring your RAM is Dedicated in VMware.....just a common recommendation when odd things are seen since so often that is missed for one reason or another.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
Highlighted
Absent Member.
Absent Member.

Do you mean setting a VMware reservation for memory in VMware? I have never had to do this for other VMs. Is this a recommendation? Would you reserve the total amount of memory that is allocated? In my case I have allocated 12 GB. Active guest memory right now is 1.6 GB.

I was able to get the SSH service to finally start by rebooting the appliance but it bugs me that it doesn't work by just turning it on and off from the Services option of the Portal.

dan
0 Likes
Highlighted
Absent Member.
Absent Member.

Dan, sorry - for some reason I didn't see the first message, only your
comment - no idea why, must be getting old 😞

With Craig's recommendation for memory, it is definitely the case that
all memory for the VM should be reserved: ZCM is mostly java, and
that's sensitive to timing and doesn't play well if it has to wait for
memory to be allocated.



0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Yes, There are some TIDs about this that point to VMware Recommendations about Java.
Rules apply to other Virtualization Platforms as well.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
Highlighted
Absent Member.
Absent Member.

Thanks, Shaun and Craig, I'll look into this.

Dan
0 Likes
Highlighted
Absent Member.
Absent Member.

For anyone else struggling with item #2 - can't get into Online Update for the appliance after upgrading to ZCM 2017, the problem is a typo. To fix it:

1. Delete the repo “vmware-tools-collection” [ zypper rr vmware-tools-collection ]

2. Correct the URL in the script: /opt/novell/va_install/install_vmware_tools. It should be sles11sp3” instead of “sles11.3". The whole command should be:

zypper addservice --type=YUM http://packages.vmware.com/tools/esx/latest/sles11sp3/x86_64 vmware-tools-collection

3. Save the file.

4. Try registering again.

It worked for me this time. BTW, as of today there are no updates available so after doing all this when you go to online update, it will show no updates.

Dan



0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Skip #2 and #3.
They are not valid for the Appliance.
The entire script is removed in Update 1, since it was never intended to be included.

No, there are not any updates available.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.