Anonymous_User Absent Member.
Absent Member.
2841 views

Run as dynamic administrator with credential for network access - any success?

It drives me mad. Yet is should be so simple

Most software will NOT install as a user in Windows 7, as it requires higher
privileges

So the dynamic administrator is supposed to fix that. And it does

But all my software is on NSS volume and I am not prepared to move it to ZCM
repository (where I can not ie edit/adjust/change a single file or group of
files etc)
Something that is trivial if one can access it in filesystem

Also some of the software that uses network distribution share often has
options changed etc

So no, I am not moving it to Repository!

Hence credential for network access

And here the fun starts, some applications (ie GroupWise client will install
OK), but most that I have so far tried does NOT

No version of Office will install (have separate thread about it)

Acrobat 9 Pro will NOT (if run bootstrap setup that uses setup.ini I get
language selection & then error:

The installation package could not be opened

Ofcourse the network access user HAS RF rights to the install source

Has anybody managed to get this setup working (as expected) ?

ZCM 11.2.2 MU2 with Win7 x86 (to make it simple)

Seb


Labels (2)
0 Likes
24 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Run as dynamic administrator with credential for network access - any success?

The command used it rather simple

msiexec /i "\\server\images\software\Adobe CS3
Design\payloads\AdobeAcrobat9Pro\Acrobat9\AcroPro.msi" /t
"\\server\images\software\Adobe CS3
Design\payloads\AdobeAcrobat9Pro\Acrobat9\AcroPro.mst" /qn /log
c:\temp\acro9pro.log

which works perfectly fine if run directly on the workstation

During install I need to provide admin credentials (AD admin user is fine,
as this workstation is in AD) so the install carries on fine

Seb


"Sebastian Cerazy" <sebastian.cerazy@(nospam)spgs.org> wrote in message
news:%EtQs.2571$vO3.1018@kovat.provo.novell.com...
> It drives me mad. Yet is should be so simple
>
> Most software will NOT install as a user in Windows 7, as it requires
> higher privileges
>
> So the dynamic administrator is supposed to fix that. And it does
>
> But all my software is on NSS volume and I am not prepared to move it to
> ZCM repository (where I can not ie edit/adjust/change a single file or
> group of files etc)
> Something that is trivial if one can access it in filesystem
>
> Also some of the software that uses network distribution share often has
> options changed etc
>
> So no, I am not moving it to Repository!
>
> Hence credential for network access
>
> And here the fun starts, some applications (ie GroupWise client will
> install OK), but most that I have so far tried does NOT
>
> No version of Office will install (have separate thread about it)
>
> Acrobat 9 Pro will NOT (if run bootstrap setup that uses setup.ini I get
> language selection & then error:
>
> The installation package could not be opened
>
> Ofcourse the network access user HAS RF rights to the install source
>
> Has anybody managed to get this setup working (as expected) ?
>
> ZCM 11.2.2 MU2 with Win7 x86 (to make it simple)
>
> Seb
>
>



0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Run as dynamic administrator with credential for network access - any success?

Same applies to Autocad 2011 network install

\\server\images\software\AC2011\AdminImage\Setup.exe /I
\\server\images\software\AC2011\AdminImage\AutoCAD2011Edu.ini /language
en-us

Really simple (should be)

Setup starts & gives an error Setup section not found (looks like it does
NOT read the ini which is in the command line box

Seb


"Sebastian Cerazy" <sebastian.cerazy@(nospam)spgs.org> wrote in message
news:8WtQs.2574$vO3.2063@kovat.provo.novell.com...
> The command used it rather simple
>
> msiexec /i "\\server\images\software\Adobe CS3
> Design\payloads\AdobeAcrobat9Pro\Acrobat9\AcroPro.msi" /t
> "\\server\images\software\Adobe CS3
> Design\payloads\AdobeAcrobat9Pro\Acrobat9\AcroPro.mst" /qn /log
> c:\temp\acro9pro.log
>
> which works perfectly fine if run directly on the workstation
>
> During install I need to provide admin credentials (AD admin user is fine,
> as this workstation is in AD) so the install carries on fine
>
> Seb
>
>
> "Sebastian Cerazy" <sebastian.cerazy@(nospam)spgs.org> wrote in message
> news:%EtQs.2571$vO3.1018@kovat.provo.novell.com...
>> It drives me mad. Yet is should be so simple
>>
>> Most software will NOT install as a user in Windows 7, as it requires
>> higher privileges
>>
>> So the dynamic administrator is supposed to fix that. And it does
>>
>> But all my software is on NSS volume and I am not prepared to move it to
>> ZCM repository (where I can not ie edit/adjust/change a single file or
>> group of files etc)
>> Something that is trivial if one can access it in filesystem
>>
>> Also some of the software that uses network distribution share often has
>> options changed etc
>>
>> So no, I am not moving it to Repository!
>>
>> Hence credential for network access
>>
>> And here the fun starts, some applications (ie GroupWise client will
>> install OK), but most that I have so far tried does NOT
>>
>> No version of Office will install (have separate thread about it)
>>
>> Acrobat 9 Pro will NOT (if run bootstrap setup that uses setup.ini I get
>> language selection & then error:
>>
>> The installation package could not be opened
>>
>> Ofcourse the network access user HAS RF rights to the install source
>>
>> Has anybody managed to get this setup working (as expected) ?
>>
>> ZCM 11.2.2 MU2 with Win7 x86 (to make it simple)
>>
>> Seb
>>
>>

>
>



0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Run as dynamic administrator with credential for network access - any success?

Honestly no comments on this?

It is flawed design?
Is it **** implementation?
It simply does not work?
Nobody using it this way? - then why it is there?
Nobody has any issues with it (just me?)

Anything is appreciated

Seb




"Sebastian Cerazy" <sebastian.cerazy@(nospam)spgs.org> wrote in message
news:pYvQs.2583$vO3.126@kovat.provo.novell.com...
> Same applies to Autocad 2011 network install
>
> \\server\images\software\AC2011\AdminImage\Setup.exe /I
> \\server\images\software\AC2011\AdminImage\AutoCAD2011Edu.ini /language
> en-us
>
> Really simple (should be)
>
> Setup starts & gives an error Setup section not found (looks like it does
> NOT read the ini which is in the command line box
>
> Seb
>
>
> "Sebastian Cerazy" <sebastian.cerazy@(nospam)spgs.org> wrote in message
> news:8WtQs.2574$vO3.2063@kovat.provo.novell.com...
>> The command used it rather simple
>>
>> msiexec /i "\\server\images\software\Adobe CS3
>> Design\payloads\AdobeAcrobat9Pro\Acrobat9\AcroPro.msi" /t
>> "\\server\images\software\Adobe CS3
>> Design\payloads\AdobeAcrobat9Pro\Acrobat9\AcroPro.mst" /qn /log
>> c:\temp\acro9pro.log
>>
>> which works perfectly fine if run directly on the workstation
>>
>> During install I need to provide admin credentials (AD admin user is
>> fine, as this workstation is in AD) so the install carries on fine
>>
>> Seb
>>
>>
>> "Sebastian Cerazy" <sebastian.cerazy@(nospam)spgs.org> wrote in message
>> news:%EtQs.2571$vO3.1018@kovat.provo.novell.com...
>>> It drives me mad. Yet is should be so simple
>>>
>>> Most software will NOT install as a user in Windows 7, as it requires
>>> higher privileges
>>>
>>> So the dynamic administrator is supposed to fix that. And it does
>>>
>>> But all my software is on NSS volume and I am not prepared to move it to
>>> ZCM repository (where I can not ie edit/adjust/change a single file or
>>> group of files etc)
>>> Something that is trivial if one can access it in filesystem
>>>
>>> Also some of the software that uses network distribution share often has
>>> options changed etc
>>>
>>> So no, I am not moving it to Repository!
>>>
>>> Hence credential for network access
>>>
>>> And here the fun starts, some applications (ie GroupWise client will
>>> install OK), but most that I have so far tried does NOT
>>>
>>> No version of Office will install (have separate thread about it)
>>>
>>> Acrobat 9 Pro will NOT (if run bootstrap setup that uses setup.ini I get
>>> language selection & then error:
>>>
>>> The installation package could not be opened
>>>
>>> Ofcourse the network access user HAS RF rights to the install source
>>>
>>> Has anybody managed to get this setup working (as expected) ?
>>>
>>> ZCM 11.2.2 MU2 with Win7 x86 (to make it simple)
>>>
>>> Seb
>>>
>>>

>>
>>

>
>



0 Likes
Knowledge Partner
Knowledge Partner

Re: Run as dynamic administrator with credential for network access - any success?

I have not seen what you are seeing, but I could try duplicating, but
it will take some time so I guess the fastes way to have it looked at
is to open an SR.

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Run as dynamic administrator with credential for network access - any success?

I said many times before
SR on my licensing costs MORE then the licensing.
I do not have it FREE and I can not afford it

I could understand if I had a problem with a single application, but I have
problem with MOST applications (only GroupWise installed OK)

You have not see the problem and you ARE using install this way? (from NSS
volume via specified network credentials & dynamic admin?)

What was the biggest one you install this way?

Seb

"Anders Gustafsson" <AndersG@no-mx.forums.novell.com> wrote in message
news:VA.00004de4.004587ae@no-mx.forums.novell.com...
>I have not seen what you are seeing, but I could try duplicating, but
> it will take some time so I guess the fastes way to have it looked at
> is to open an SR.
>
> --
> Anders Gustafsson (NKP)
> The Aaland Islands (N60 E20)
>
> Have an idea for a product enhancement? Please visit:
> http://www.novell.com/rms
>



0 Likes
Knowledge Partner
Knowledge Partner

Re: Run as dynamic administrator with credential for network access - any success?

Sebastian Cerazy,
> I said many times before
> SR on my licensing costs MORE then the licensing.
> I do not have it FREE and I can not afford it


Sorry, but I cannot remember what customer has what SR-options, here
all customers with maintenance have free SRs.

Like I said, I can try to set up a test install this way, preferably
one that you had problems with. But just to test, can you try running
the autocad setup, but put the INI-file on a local path, just to test?

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Run as dynamic administrator with credential for network access - any success?

I probably could, strange that on my 3 tries, one was no go instantly,
second got so another screen then choked, third try was about to start
copying files & then choked

Almost like the second network login "got lost" mid-flight

Seb

"Anders Gustafsson" <AndersG@no-mx.forums.novell.com> wrote in message
news:VA.00004de8.00430e81@no-mx.forums.novell.com...
> Sebastian Cerazy,
>> I said many times before
>> SR on my licensing costs MORE then the licensing.
>> I do not have it FREE and I can not afford it

>
> Sorry, but I cannot remember what customer has what SR-options, here
> all customers with maintenance have free SRs.
>
> Like I said, I can try to set up a test install this way, preferably
> one that you had problems with. But just to test, can you try running
> the autocad setup, but put the INI-file on a local path, just to test?
>
> --
> Anders Gustafsson (NKP)
> The Aaland Islands (N60 E20)
>
> Have an idea for a product enhancement? Please visit:
> http://www.novell.com/rms
>



0 Likes
Knowledge Partner
Knowledge Partner

Re: Run as dynamic administrator with credential for network access - any success?

Sebastian Cerazy,
> I probably could,


Well, it could help.

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Run as dynamic administrator with credential for network access - any success?

Log file created in the temp administrator folder

=== Verbose logging started: 12/02/2013 17:57:33 Build type: SHIP UNICODE
5.00.7601.00 Calling process: C:\Windows\System32\msiexec.exe ===
MSI (c) (00:18) [17:57:33:091]: Font created. Charset: Req=0, Ret=0, Font:
Req=MS Shell Dlg, Ret=MS Shell Dlg

MSI (c) (00:18) [17:57:33:091]: Font created. Charset: Req=0, Ret=0, Font:
Req=MS Shell Dlg, Ret=MS Shell Dlg

MSI (c) (00:CC) [17:57:33:106]: Resetting cached policy values
MSI (c) (00:CC) [17:57:33:106]: Machine policy value 'Debug' is 0
MSI (c) (00:CC) [17:57:33:106]: ******* RunEngine:
******* Product: \\server\images\software\Adobe CS3
Design\payloads\AdobeAcrobat9Pro\Acrobat9\AcroPro.msi
******* Action:
******* CommandLine: **********
MSI (c) (00:CC) [17:57:33:106]: Note: 1: 2203 2:
\\server\images\software\Adobe CS3
Design\payloads\AdobeAcrobat9Pro\Acrobat9\AcroPro.msi 3: -2147287035
MSI (c) (00:CC) [17:57:33:122]: MainEngineThread is returning 1619
=== Verbose logging stopped: 12/02/2013 17:57:33 ===




"Anders Gustafsson" <AndersG@no-mx.forums.novell.com> wrote in message
news:VA.00004dea.0082ee30@no-mx.forums.novell.com...
> Sebastian Cerazy,
>> I probably could,

>
> Well, it could help.
>
> --
> Anders Gustafsson (NKP)
> The Aaland Islands (N60 E20)
>
> Have an idea for a product enhancement? Please visit:
> http://www.novell.com/rms
>



0 Likes
Knowledge Partner
Knowledge Partner

Re: Run as dynamic administrator with credential for network access - any success?

Sebastian Cerazy,
> Design\payloads\AdobeAcrobat9Pro\Acrobat9\AcroPro.msi 3: -2147287035
> MSI (c) (00:CC) [17:57:33:122]: MainEngineThread is returning 1619
> === Verbose logging stopped: 12/02/2013 17:57:33 ===


ERROR_INSTALL_PACKAGE_
OPEN_FAILED 1619 This installation package could not be
opened. Verify that the package exists
and
that you can access it, or contact the
application vendor to verify that this
is
a valid Windows Installer package.

That does indeed look like it cannot access the network path. I guess
the nest step would be to take a wireshark trace to see if it indeed
tries to log in with the correct credentials.

FWIW, what I normally do is to split up installs so that the bundle
first copies down the files to a local dir, creates whatever required
installer INIs, then runs the install, then cleans up.

Most of the time copying down the installer that way is 10x faster than
running it over the net.

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
heinkonijn1 Absent Member.
Absent Member.

Re: Run as dynamic administrator with credential for network

I am pretty sure that I know why it doesn't work.
If you install a bundle with elevated rights it uses this user to access the NSS volume. This user has not authenticated to eDir and is rejected.
The easy solution is to give the eDirectory object [Public] rights to the files. This means everything can access the files, without being authenticated to eDirectory.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.