Absent Member.
Absent Member.
688 views

Spaces in Location names

Does anyone use locations ? if so, do they have space in them


cbrzcm3:~:root                                                                                                                                             
$ zac cl;zac zc;zac zc -l

Processing Command: cl

Current Configuration Location: cbr

Current Configuration Environment: cbr Network Environment


Processing Command: zc

Zone Configuration Server(s): https://dc2zcm1:443


Processing Command: zc

Role Servers
------------------------------+----------------------------------------------------------------------------------------------------------------------------
http://cbrzcm3:8080/
Collection: http://10.247.1.153:8080/
http://dc2zcm1:80/
http://10.242.1.102:80/
Configuration: https://dc2zcm1:443/
https://10.242.1.102:443/
http://cbrzcm3:8080/zenworks-content/
Content: http://10.247.1.153:8080/zenworks-content/
http://dc2zcm1:80/zenworks-content/
http://10.242.1.102:80/zenworks-content/



rename the location and add a space, wait ten minutes, refresh and this happens.

cbrzcm3:~:root
$ zac ref

Processing Command: ref

Refreshing device information...

Device refresh is complete.

Device refresh completed after 5.246 seconds.



Total refresh time: 5.248 seconds.

cbrzcm3:~:root
$ zac cl;zac zc;zac zc -l

Processing Command: cl

Current Configuration Location: cbr cbr

Current Configuration Environment: cbr Network Environment


Processing Command: zc

Zone Configuration Server(s): https://dc2zcm1:443


Processing Command: zc

Closest servers not found for any role.



i am confused.

zcm 11.2.0 (on sles 11sp1) - we are testing multiple things to evaluate how we broke locations in production.

things were broken in 11.2.0 in prod before any upgrades so we are only looking at this level.

zac commands run on a satellite on sles 11sp1

this particular iteration of test has internal CA certs. prod has external.

the cbr location was created manually through the http interface, not zman scripting (which prod was)


p
Labels (2)
0 Likes
2 Replies
Absent Member.
Absent Member.

i put the location back to cbr and waited an hour and the servers came back.

p
0 Likes
Absent Member.
Absent Member.

Peter,

We use spaces in a number of our locations and network environments and I've never seen this happen, if you create a new location with a space in it do you see the same thing in the results?

H
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.