Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Anonymous_User Absent Member.
Absent Member.
784 views

UEFI image and add-on

Hi,

I'm trying to create my first Windows 10 UEFI base image. If I take the
image of all the hard drive, everything works fine. If I try to create an
image for each partition and restore these partitions on a different hard
drive and add add-on images, it doesn't work.

Can someone help me with this ?

Here's my script:

#Create Partitions
img -pd -all
img -pc 1 -type=NTFS -size=500 -guid=WRE
img -pc 2 -type=FAT32 -size=100 -guid=ESP
img -pc 3 -type=NTFS -size=128 -guid=MRP
img -pc 4 -type=NTFS -guid=MBD
#Restore Images
img -rp UEFI/RESTORE_1.zmg -ap=a1:p1
img -rp UEFI/SYSTEM_2.zmg -ap=a1:p2
img -rp UEFI/MSR_3.zmg -ap=a1:p3
img -rp UEFI/DATA_4 -ap=a1:p4.zmg
img -rp addon-image IMG-DRIVERS-Optiplex7060.zmg -ap=a1:p4
img -rp addon-image IMG-WIN10-UTILITIES.zmg -ap=a1:p4

What am I doing wrong ?

Thanks.

Normand

Labels (1)
0 Likes
5 Replies
brommo
Visitor.

Re: UEFI image and add-on

How are your addon images created?

When I create an addon image in Image Explorer, I create 4 partitions and put the contents on the 4th partition.
You should be able to restore your Windows base image first then your addon images without any problems nor bothering with partitions.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: UEFI image and add-on

Also precisely what does not work....
In both scenarios...do you end up with the same number of partitions?
In same order?
Is the same partition set as active?
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: UEFI image and add-on

Craig,

After image restore, at reboot I have a blue screen with a message saying
that a necessary device is missing or unavailable. 0x0000000e

Here's what I do for testing:

Install Windows and all softwares in Audit mode;
Do a sysprep;
Reboot and take the image manually (img mp imagename.zmg);
Restore image on a device (img rp imagename.zmg);
After the restore, I have a message about SID.

And at reboot, I have the error message with the blue screen.

If I restore the image on the original computer everything is working fine.

Everything is identically configured in the BIOS.

Normand


"CRAIGDWILSON" a écrit dans le message de groupe de discussion :
CRAIGDWILSON.8s4bcn@no-mx.forums.microfocus.com...


Also precisely what does not work....
In both scenarios...do you end up with the same number of partitions?
In same order?
Is the same partition set as active?


--
--
Any Opinions, Thoughts, Solutions, or Blog Entries are my own and may or
may not be shared by Micro Focus or any Sane Person
Please Use at your Own Risk.

Blog - https://forums.novell.com/blog.php/5830-CRAIGDWILSON

https://ideas.microfocus.com/mfi/novell-zcm

Want to Turbo charge your apps and put an end to compatability issues?
https://www.microfocus.com/products/zenworks/desktop-containers
------------------------------------------------------------------------
CRAIGDWILSON's Profile: https://forums.novell.com/member.php?userid=5830
View this thread: https://forums.novell.com/showthread.php?t=510638

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: UEFI image and add-on

CRAIG,

After doing the sysprep on the source device, take the image and restore the
image to a new device, the error message after the image restoration is:

Unable to update the SID of the device. Restore the image of the device
again. If the problem persist, disable the SIDchanger.

If I do a sidChange -i command, I have a segmentation fault error.

Any help would be very appreciated.

Normand


"CRAIGDWILSON" a écrit dans le message de groupe de discussion :
CRAIGDWILSON.8s4bcn@no-mx.forums.microfocus.com...


Also precisely what does not work....
In both scenarios...do you end up with the same number of partitions?
In same order?
Is the same partition set as active?


--
--
Any Opinions, Thoughts, Solutions, or Blog Entries are my own and may or
may not be shared by Micro Focus or any Sane Person
Please Use at your Own Risk.

Blog - https://forums.novell.com/blog.php/5830-CRAIGDWILSON

https://ideas.microfocus.com/mfi/novell-zcm

Want to Turbo charge your apps and put an end to compatability issues?
https://www.microfocus.com/products/zenworks/desktop-containers
------------------------------------------------------------------------
CRAIGDWILSON's Profile: https://forums.novell.com/member.php?userid=5830
View this thread: https://forums.novell.com/showthread.php?t=510638

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: UEFI image and add-on

CRAIG,

One more detail:

It happens when the image that is restore is very large. With a 20Gb image,
it works fine but with a 80Gb image, it fails.

And the 80 Gb image is created based on the 20Gb image.

Normand



"CRAIGDWILSON" a écrit dans le message de groupe de discussion :
CRAIGDWILSON.8s4bcn@no-mx.forums.microfocus.com...


Also precisely what does not work....
In both scenarios...do you end up with the same number of partitions?
In same order?
Is the same partition set as active?


--
--
Any Opinions, Thoughts, Solutions, or Blog Entries are my own and may or
may not be shared by Micro Focus or any Sane Person
Please Use at your Own Risk.

Blog - https://forums.novell.com/blog.php/5830-CRAIGDWILSON

https://ideas.microfocus.com/mfi/novell-zcm

Want to Turbo charge your apps and put an end to compatability issues?
https://www.microfocus.com/products/zenworks/desktop-containers
------------------------------------------------------------------------
CRAIGDWILSON's Profile: https://forums.novell.com/member.php?userid=5830
View this thread: https://forums.novell.com/showthread.php?t=510638

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.