Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Highlighted
shawniverson2 Absent Member.
Absent Member.
1559 views

Unable to Enable Authentication Satellite Role

Hello,

I am unable to get my Satellite Servers to go active with the authentication role. I am running Windows Server 2008 R2 fully patched and Zenworks 11.2.0.

I use external certificates.

I created a my certificates in DER format, and imported them successfully.

I enabled the Authentication role on the Satellite and assigned my User Sources.

Zenworks Agent on satellite stays "Disabled" for the Authentication role. This is happening on all of my satellites.

Agent log is completely devoid of any errors.

Other roles are functioning normally.

Anywhere I can dig or execute to look into this issue deeper?
Labels (2)
0 Likes
7 Replies
shawniverson2 Absent Member.
Absent Member.

Re: Unable to Enable Authentication Satellite Role

Okay I think I found the problem. The machine store has a bad certificate higher up on the list. Not sure how to remove the faulty cert from the machine store...
0 Likes
shawniverson2 Absent Member.
Absent Member.

Re: Unable to Enable Authentication Satellite Role

Okay, that wasn't it. Completely removed the agent and reinstalled. Same results on all Satellites
0 Likes
shawniverson2 Absent Member.
Absent Member.

Re: Unable to Enable Authentication Satellite Role

Tried installing on a SLES box instead of Windows. I am seeing the following in the zmd-messages.log

[Debug] [06/27/2013 18:09:41.868] [] [32399] [ZenworksAgent] [255] [SSConfig] [zoneConfigService.getSatelliteServerConfigEx() returned error: -1 (Exception getting SatelliteServerConfigExjava.lang.IllegalArgumentException: value can not be null for any0)] [] []

Not sure if it is relevant to this problem, but looks suspicious.
0 Likes
shawniverson2 Absent Member.
Absent Member.

Re: Unable to Enable Authentication Satellite Role

Okay, due to the nature of this problem I went ahead and upgraded my primary and satellites to 11.2.3a in hopes that it might resolve my issue.

Now, I cannot import the external certificate at all.

The funny thing is that is says that the import was successful, but the agent log follows up with some errors...

[DEBUG] [06/28/2013 20:38:45.449] [272] [ZenworksWindowsService] [32] [] [ZMD] [] [Finished Processing Command for handler import-authentication-cert. Result = SUCCESS] [] []
[DEBUG] [06/28/2013 20:38:45.449] [272] [ZenworksWindowsService] [32] [] [CLM] [] [After call to ProcessCommand. Result = SUCCESS] [] []
[DEBUG] [06/28/2013 20:38:45.449] [272] [ZenworksWindowsService] [32] [] [CLM] [] [After call to ParseArgs. Result = SUCCESS] [] []
[DEBUG] [06/28/2013 20:38:45.449] [272] [ZenworksWindowsService] [32] [] [CLM] [] [After call to StopDisplaySpinner()] [] []
[DEBUG] [06/28/2013 20:38:51.939] [272] [ZenworksWindowsService] [32] [] [CLM] [] [Before call to ParseArgs] [] []
[DEBUG] [06/28/2013 20:38:51.939] [272] [ZenworksWindowsService] [32] [] [CLM] [] [Before call to ProcessCommand] [] []
[DEBUG] [06/28/2013 20:38:51.954] [272] [ZenworksWindowsService] [32] [] [ZMD] [] [Processing Command for handler cert-info] [] []
[DEBUG] [06/28/2013 20:38:52.137] [272] [ZenworksWindowsService] [32] [] [ZMD] [] [Finished Processing Command for handler cert-info. Result = ERROR] [] []
[DEBUG] [06/28/2013 20:38:52.137] [272] [ZenworksWindowsService] [32] [] [CLM] [] [After call to ProcessCommand. Result = ERROR] [] []
[DEBUG] [06/28/2013 20:38:52.137] [272] [ZenworksWindowsService] [32] [] [CLM] [] [After call to ParseArgs. Result = ERROR] [] []
[DEBUG] [06/28/2013 20:38:52.137] [272] [ZenworksWindowsService] [32] [] [CLM] [] [After call to StopDisplaySpinner()] [] []
0 Likes
shawniverson2 Absent Member.
Absent Member.

Re: Unable to Enable Authentication Satellite Role

I just realized that the cert-info error is caused each time that "zac ci" is run. Not sure why it throws an error...

Anyway, the certificate showed up after some time, which is good.

However, the Authentication Server Role is still in a Disabled state.

I am going to give it some time to see if something happens.
0 Likes
shawniverson2 Absent Member.
Absent Member.

Re: Unable to Enable Authentication Satellite Role

Nope. Looks like I may need to open an SR.

SatelliteServerRoleConfigHandler] [] [zoneConfigService.getSatelliteServerConfigEx() returned error: -1 (Exception getting SatelliteServerConfigExjava.lang.IllegalArgumentException: value can not be null for any0)] [] []
0 Likes
dmilam Absent Member.
Absent Member.

Re: Unable to Enable Authentication Satellite Role

Did you ever find an answer / solution?
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.