Highlighted
tkp Absent Member.
Absent Member.
3629 views

Unable to PXE boot DELL T1700

I'm trying to PXE boot a DELL T1700, but had issues with USB3 and recieves the following error and the Desktop freezes:
pci:v00008086d00008C31sv00008086sd00002052bc0Csc03i30' unexpected exit with status 0x0009
where hardware ID belongs to USB 3.0 compatible controller.
I managed to get around this by adding "brokenmodules=xhci-hcd" into the start parameters. Now the network is not reconized and I managed to boot from CD and get to the bash a record network card information using "hwinfo --netcard" and adding newid="VendorID DeviceID, Driver" for the secific card. Now the Desktop boots, and If I do a hwinfo --netcard it will show that the Intel E1000E driver is loaded, however I'm unable to get an IP address. If I try to assing a IP manually using dhcpcd or ifoconfig it will say that the eth0 eth1 and is unknown.

Any ideas?
Labels (2)
0 Likes
18 Replies
shaunpond Absent Member.
Absent Member.

Re: Unable to PXE boot DELL T1700

Tkp,

the next Imaging update (September) should have an updated e1000 driver
in it. If you can't wait for that, I'd suggest a SR, and they may be
able to get you an FTF as a temporary measure

--

Shaun Pond


0 Likes
tkp Absent Member.
Absent Member.

Re: Unable to PXE boot DELL T1700

Shaun, I opened a SR last night (and recieved the FTF), and it does contain another e1000e driver, but it will not load automatically and detect the card even if I use newid=" ". But I found out that doing a pxe boot and ending up at "Could not find zenworks repository", I then tried to go to "Expert" -> "Kernel Modules (Hardware Drivers)" -> "Load Network Card Modules" -> selected the "e1000e" driver - didn't provide any parameters and the module loaded fine. Went back to "Start Installation" -> "Start Installation or Update" -> "Network" -> "TFTP" -> and then it did send a dhcp request - so accepting the preboot server address and the boot folder I came to the bash with a functionel netcard. So I will upload the boot.log to the sr and hopefully we can fix the detection - can't see right now why it wont since the driver is working, and I have "helped it" with the newid mapping.

/Thomas
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Unable to PXE boot DELL T1700

Tkp,

nice - if you can help fix that before the next update, you'll make
lots of people happy 🙂

--

Shaun Pond


0 Likes
stesjo Absent Member.
Absent Member.

Re: Unable to PXE boot DELL T1700

Hi.
Have any of you heard any solution on this?
I have the exact same problem, but with HP Probook 430 G1.
Any new driver-update in the pipeline?
Seems like its long time since april.
Or does drivers help the problem, or is itanything else?
/Stefan
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Unable to PXE boot DELL T1700

Stesjo,

I am trying to get an Imaging update for next month - if you opened a
SR you may be able to get an early fix

--

Shaun Pond


0 Likes
stesjo Absent Member.
Absent Member.

Re: Unable to PXE boot DELL T1700

Thanks Shaun.
I did get it to work.
First to get quit och the USB3-problems with "brokenmodules", and the point the netcard to old e1000 in the menu-startup file.

brokenmodules=xhci-hcd,usbcore,usb_common newid="0x8086 0x08b1,e1000"

Customer is evaluating this machine. This will for for now.
When they order, and come in production, hopefully the next Img-drv -update is in place.

Tnx for now.
/Stefan
0 Likes
stesjo Absent Member.
Absent Member.

Re: Unable to PXE boot DELL T1700

Hi.
Just wanted to check.
Shaun, any new info about a imagedriver-update?
Long time since april now 🙂
/Stefan

stesjo;2283173 wrote:
Thanks Shaun.
I did get it to work.
First to get quit och the USB3-problems with "brokenmodules", and the point the netcard to old e1000 in the menu-startup file.

brokenmodules=xhci-hcd,usbcore,usb_common newid="0x8086 0x08b1,e1000"

Customer is evaluating this machine. This will for for now.
When they order, and come in production, hopefully the next Img-drv -update is in place.

Tnx for now.
/Stefan
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Unable to PXE boot DELL T1700

Stesjo,

they're working on one - but first we need to get 11.2.4 released...

--

Shaun Pond


0 Likes
stesjo Absent Member.
Absent Member.

Re: Unable to PXE boot DELL T1700

Thanks Shaun!
Any clue about when?
/Stefan

spond;2287156 wrote:
Stesjo,

they're working on one - but first we need to get 11.2.4 released...

--

Shaun Pond
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Unable to PXE boot DELL T1700

Stesjo,

ASAP, that's all I can say 🙂

--

Shaun Pond


0 Likes
shaunpond Absent Member.
Absent Member.

Re: Unable to PXE boot DELL T1700

Stesjo,

To keep folks up to date: during testing at a Lighthouse customer site,
NTS found a couple of System Update issues, one which could affect any
customer who has slow hardware. Because of this, it was felt that the
problem needed to be fixed, and engineering believe that they have
coded a fix (it worked in my test lab, where I could reproduce the
problem). Testing is the thing that's going to take time, we don't want
to rush this out, making assumptions that a small fix won't need much
testing (we've been caught like that before). So, the new build will
not be ready for posting before next Tuesday, October 15. Not that I am
promising it will be on October 15, just that you will not see it
before that date.

--

Shaun Pond


0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.