Kelvarr Absent Member.
Absent Member.
1857 views

Upgraded Server to 11.2.3a, Agent version didn't upgrade

So I upgraded our server to 11.2.3a, and all went well. I am in the process of deploying the new agent to machines. When I push the agent through the System updates, everything is well and fine, and version 11.2.3.21755 gets installed. However, when I manually download the agent via the "Download Zenworks Tools", version 11.2.0.16022 gets installed. Is there anywhere to download the latest version? Or, where is the location on the server of the files I need?
Labels (2)
0 Likes
15 Replies
shaunpond Absent Member.
Absent Member.

Re: Upgraded Server to 11.2.3a, Agent version didn't upgrade

Kelvarr,

did the status on the deployment change to succeeded? The deployment
packages need time to rebuild...

--

Shaun Pond


0 Likes
Kelvarr Absent Member.
Absent Member.

Re: Upgraded Server to 11.2.3a, Agent version didn't upgrade

I did the upgrade 2 weeks ago, and just downloaded the agent today. However, I did see this under the server deployment:

An error occurred when trying to start the /etc/init.d/casa_atsd service: -1. Check the system-update.log on the device for details.


However, the server is running the 11.2.3.21755 version
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Upgraded Server to 11.2.3a, Agent version didn't upgrade

Kelvarr,

I would do
novell-zenworks-configure -c CreateExtractorPacks -Z
and see what happens...

--

Shaun Pond


0 Likes
Kelvarr Absent Member.
Absent Member.

Re: Upgraded Server to 11.2.3a, Agent version didn't upgrade

Thanks Shaun! The actual command/process worked like a charm! Now what I can't figure out is why the push uses version 11.2.3.21755, and the rebuilt Extractor Packs downloads 11.2.3.18534...
0 Likes
Kelvarr Absent Member.
Absent Member.

Re: Upgraded Server to 11.2.3a, Agent version didn't upgrade

I spoke too soon. The process completed fine, and the wrapper .exe says version 11.2.3.18534, but the actual agent version under properties is 11.2.0.16117 (which is the same version that the package was at before I ran your command).
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Upgraded Server to 11.2.3a, Agent version didn't upgrade

Kelvarr,

> but the actual agent version under properties is
> 11.2.0.16117


which properties?

--

Shaun Pond


0 Likes
Kelvarr Absent Member.
Absent Member.

Re: Upgraded Server to 11.2.3a, Agent version didn't upgrade

spond;2281190 wrote:
Kelvarr,

> but the actual agent version under properties is
> 11.2.0.16117


which properties?

--

Shaun Pond


Right-Click on the ZENworks Adaptive Agent > Show Properties > ZENworks Adaptive Agent Version: 11.2.0.16117

Right-Click on the PreAgentPkg_AgentComplete.exe that is downloaded from the server > Properties > Version tab > Version: 11.2.3.18534

So the file properties of the wrapper show 11.2.3.x, but once installed from the wrapper, the Adaptive Agent shows 11.2.0.x

I hope that helps.
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Upgraded Server to 11.2.3a, Agent version didn't upgrade

Kelvarr,

I think you should tun the ZDC against your server - I think that some
of the files may not be correctly updated. You could also try
zman sup "Update for ZENworks 11 SP (11.2.3a)"

--

Shaun Pond


0 Likes
Kelvarr Absent Member.
Absent Member.

Re: Upgraded Server to 11.2.3a, Agent version didn't upgrade

spond;2281370 wrote:
Kelvarr,

I think you should tun the ZDC against your server - I think that some
of the files may not be correctly updated. You could also try
zman sup "Update for ZENworks 11 SP (11.2.3a)"

--

Shaun Pond



I will try the zman command and report back. In the meantime...ZDC? I don't recall what that is/does, or where it is located.
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Upgraded Server to 11.2.3a, Agent version didn't upgrade

0 Likes
Highlighted
Kelvarr Absent Member.
Absent Member.

Re: Upgraded Server to 11.2.3a, Agent version didn't upgrade

spond;2281370 wrote:
Kelvarr,

I think you should tun the ZDC against your server - I think that some
of the files may not be correctly updated. You could also try
zman sup "Update for ZENworks 11 SP (11.2.3a)"

--

Shaun Pond


zman sud "Update for ZENworks 11 SP (11.2.3a)"

This update is not currently available


Is there any other way to re-install the update? I have the following file: ZENworks_11.2.3a_Update.zip
I know where the files I need inside it are: ZENworks_11.2.3a_Update.zip\zcm\10.1\5011020300fc50000000002013041002\msi\
I don't know where on the server these files need to be copied to.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.