Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

WinPE Imaging and TPM

Hello everyone,

I thought I'd write this up and share an issue I've been having with the switch to WinPE based Zenworks imaging (ZCM 17.3) from Linux based imaging.

Since day one (approx. 18 months ago), I was struggling with imaging particular models. Some models were imaging, some were failing with "Cannot read from archive" or "Could not connect to server".

After overcoming the "Could not connect to server" issue by adding drivers to my winpe.wim file, half of the models in our fleet were failing to apply WinPE based Zenworks preboot bundles with "Error: Error reading from archive". I outlined more about this here:

In attempt to overcome this, I changed my preboot bundles from Zenworks image bundles to WinPE imaging scripts, as I found that using diskpart to clean the disk and create a single partition prior to applying image files worked. More info here:

This left me stumped for ages. Until one day I noticed that several devices' C: drives were BitLocker enabled. At first, I thought that it was kids messing around with the systems (school environment) and enabling it somehow. But then it struck me:

Upon first boot after applying a Windows 10 image, Windows was detecting the TPM (Trusted Platform Module) within that device and automatically started encrypting the C: drive.

New devices out of the box were imaging perfectly for the first time with hardware rules, but once you tried to re-image the device via WinPE, it was failing due to the volume being encrypted and therefor it couldn't write to it.

Disabling TPM in the BIOS has solved this for me.

P.S. Interesting how this wasn't an issue with Linux based imaging!
Labels (1)
1 Reply
Absent Member.
Absent Member.


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.

Be sure to read the forum FAQ about what to expect in the way of responses:

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.