Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
sbocinec Absent Member.
Absent Member.
1804 views

ZCM 10.2 Blank version numbers - unable to update to 10.2.2

Hi all,

i've problem with ZCM 10. I've installed ZCM 10.2 on SLES 11 64bit. Then i've manually imported 10.2.2 update and status of the update in ZCC is "Downloaded". But i was unable to deploy this update to the server with error message:
"The Update for ZCM (10.2.2) update requires the following update(s) to be applied before it can be deployed: Support Pack 2 for ZCM (10.2) ".

I was really shocked as i installed ZCM from 10.2 iso file. Then I checked the version number of ZCM components through ZCC and in the Server Hierarchy field of my primary server in ZCC Configuration tab i can't see version number for any of the ZCM components (ZCM Version, ZAM Version,...). The version field is blank without any number.

Could anyone tell me, how to fix this version & update problem?

Thanks in advance,

Stanley
Labels (2)
0 Likes
7 Replies
sbocinec Absent Member.
Absent Member.

Re: ZCM 10.2 Blank version numbers - unable to update to 10.

ou, i already see where could be the problem..
SLES 11 is additionally supported from version 10.2.1, 10.2.0 seems to be unsupported.

Is there any chance to fix the problem although on the SLES 11?

Thanks,
S.
0 Likes
Knowledge Partner
Knowledge Partner

Re: ZCM 10.2 Blank version numbers - unable to update to 10.

sbocinec;1934534 wrote:
ou, i already see where could be the problem..
SLES 11 is additionally supported from version 10.2.1, 10.2.0 seems to be unsupported.

Is there any chance to fix the problem although on the SLES 11?

Thanks,
S.


Have you rebooted the server after you installed ZCM?

Thomas
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: ZCM 10.2 Blank version numbers - unable to update to 10.2.2

The basic issue is that the Server did not register itself properly
because it's unsupported in 10.2.0 and thus it cannot receive system
updates.

the OSTarget Table will need to be updated and so the server can
register and then receive updates.


On 2/17/2010 12:46 PM, thsundel wrote:
>
> sbocinec;1934534 Wrote:
>> ou, i already see where could be the problem..
>> SLES 11 is additionally supported from version 10.2.1, 10.2.0 seems to
>> be unsupported.
>>
>> Is there any chance to fix the problem although on the SLES 11?
>>
>> Thanks,
>> S.

>
> Have you rebooted the server after you installed ZCM?
>
> Thomas
>
>


--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
Knowledge Partner
Knowledge Partner

Re: ZCM 10.2 Blank version numbers - unable to update to 10.

craig_wilson;1934582 wrote:
The basic issue is that the Server did not register itself properly
because it's unsupported in 10.2.0 and thus it cannot receive system
updates.

the OSTarget Table will need to be updated and so the server can
register and then receive updates.


On 2/17/2010 12:46 PM, thsundel wrote:
>
> sbocinec;1934534 Wrote:
>> ou, i already see where could be the problem..
>> SLES 11 is additionally supported from version 10.2.1, 10.2.0 seems to
>> be unsupported.
>>
>> Is there any chance to fix the problem although on the SLES 11?
>>
>> Thanks,
>> S.

>
> Have you rebooted the server after you installed ZCM?
>
> Thomas
>
>


Does this mean that you need to install ZCM 10.2 on SLES10SP2 and then update ZCM to 10.2.2 and after that upgrade SLES10SP2 to SLES11?

Or could this be hacked some way, like editing the suse-release file?

Thomas
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: ZCM 10.2 Blank version numbers - unable to update to 10.2.2

This TID shows you how to update the zOSTARGET Table.
http://www.novell.com/support/viewContent.do?externalId=7001860

If a Device will not register because the OS is not recognized, this
will add the OS to the list and allow it to be registered.

Of Course, Care should be taken since that OS was not tested.
However, If it's simply a matter of getting the device registered so it
can be updated to a supported version that is less of an issue.

Checking the OSTARGETS.XML would help verify the OS is missing from the
table.

This is basically what you need to do for Windows 2008 R2 to get it
working on 10.2.2

There is supposed to be "Experimental Support" for 10.2.2, but the
released version was omitted from that table. Only the Final RC for
2008 R2 is actually there.

On 2/17/2010 1:06 PM, thsundel wrote:
>
> craig_wilson;1934582 Wrote:
>> The basic issue is that the Server did not register itself properly
>> because it's unsupported in 10.2.0 and thus it cannot receive system
>> updates.
>>
>> the OSTarget Table will need to be updated and so the server can
>> register and then receive updates.
>>
>>
>> On 2/17/2010 12:46 PM, thsundel wrote:
>>>
>>> sbocinec;1934534 Wrote:
>>>> ou, i already see where could be the problem..
>>>> SLES 11 is additionally supported from version 10.2.1, 10.2.0 seems

>> to
>>>> be unsupported.
>>>>
>>>> Is there any chance to fix the problem although on the SLES 11?
>>>>
>>>> Thanks,
>>>> S.
>>>
>>> Have you rebooted the server after you installed ZCM?
>>>
>>> Thomas
>>>
>>>

>
> Does this mean that you need to install ZCM 10.2 on SLES10SP2 and then
> update ZCM to 10.2.2 and after that upgrade SLES10SP2 to SLES11?
>
> Or could this be hacked some way, like editing the suse-release file?
>
> Thomas
>
>


--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
sbocinec Absent Member.
Absent Member.

Re: ZCM 10.2 Blank version numbers - unable to update to 10.

thanks for your help!
i checked the ostargets.xml and there is a definition for SLES 11 64bit and is following:

<name>sles-11-x86_64</name>
<product_name>SuSE Linux Enterprise Server 11</product_name>
<version>11</version>
<arch>x86_64</arch>
<vendor>Novell</vendor>
<pkgmgr>rpm</pkgmgr>
<primary_role>Server</primary_role>
<detect>
<file source="/etc/SuSE-release" substring="SUSE LINUX Enterprise Server 1
1 (x86_64)" />


My /etc/resolv.conf file contains following string:
"SUSE Linux Enterprise Server 11 (x86_64)"

There is a case mismatch (Linux vs LINUX) between SuSE-release and substring string, could that be the problem? I will try to change one of the files.

And yes, server was rebooted after the ZCM install.
S.
0 Likes
sbocinec Absent Member.
Absent Member.

Re: ZCM 10.2 Blank version numbers - unable to update to 10.

I've found probable problem source.

There is a problem with server agent:
zcm:~ # zac ref
Exception: Connection refused
UnableToCommunicateRemotingError
zcm:~ # zac cc
Exception: Connection refused
UnableToCommunicateRemotingError

Agent crashes just after start:
zcm:~ # /etc/init.d/novell-zenagent start
Starting Novell ZENworks Agent done
zcm:~ # /etc/init.d/novell-zenagent status
Checking for Novell ZENworks Agentzcm:~ #

I tried to fix it using hints in http://forums.novell.com/novell-product-support-forums/zenworks/configuration-management/zcm-agent-deployment/400503-zcm-agent-upgraded-10-2-2-but-shows-update-pending.html
http://forums.novell.com/novell-product-support-forums/zenworks/configuration-management/zcm-server-install/396437-10-2-2-primary-servers-not-refreshing.html

and TID #7000913, but nothing helps..

It seems there is really no way to run it on SLES 11 64bit running on XEN..

Thanks for all the help,
S.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.