Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Highlighted
preinhar Absent Member.
Absent Member.
4180 views

ZCM 11.4.1 update stuck on Update Assigned.

I have the ZCM 11.4 Appliance in a single primary server system that I have successfully deployed the "Post 11SP4 Update Prereq" to. I then downloaded and ran the "Update for ZENworks 11 SP4 (11.4.1)" specifying selected devices and only doing the primary server. However, it has been sitting at "Update Assigned' to the primary server for hours. If I check /var/opt/novell/log/zenworks/xplat-agent/zmd-messages.log I see the following at the end of the log:

[TRACE] [12/29/2015 19:22:05.023] [3041] [ZenworksAgent] [66] [] [Patch Module] [] [Registering Events] [] [] [] [ZENworks Agent]
[TRACE] [12/29/2015 19:22:34.739] [3041] [ZenworksAgent] [66] [] [ZenCache] [] [(Thread 66) PutFile(ZenCompMgmt::temp::novell-zenworks-libso
lv-helpers-11.4.1_0.6.6-6.1.x86_64.rpm, UserContext{{_LocalId=(Anonymous); _RemoteId=(Public)}}, (BypassAgentThrottle => false, Priority =>
-1, MoveFile => false, ContentType => null, ContentTypeThrottle => 0, External Path => null)) called] [] [] [] [ZENworks Agent]
[TRACE] [12/29/2015 19:22:34.863] [3041] [ZenworksAgent] [66] [] [PackageSourceService] [] [Failed to download install package novell-zenwor
ks-libsolv-helpers-11.4.1_0.6.6-6.1.x86_64.rpm from remote source(s)] [] [] [] [ZENworks Agent]

I'm not sure what the 'remote source' is. Looking in Configuration - System Updates, under Available system Updates it shows that "Update for ZENworks 11 SP4 (11.4.1)" is ready.

Also if I go to /var/opt/novell/log/zenworks/system-update/5011040100fc50000000002015121012 all of the log files there have a date of Dec 17 which is when I first tried to do the update and it failed because of disk space. I successfully increased the disk space for /vastorage then re-ran the update but it is stuck at Update Assigned. Why don't I see log files with today's date in this dir?

What should I look for? How can I get this update to continue?

Thanks,

Paul
Labels (2)
0 Likes
6 Replies
preinhar Absent Member.
Absent Member.

Re: ZCM 11.4.1 update stuck on Update Assigned.

Any thoughts on this issue?

Thanks,

Paul
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: ZCM 11.4.1 update stuck on Update Assigned.

Simplest may be to delete, re-import and re-assign the system update.

You can also try to manually kick-start the system update using zenupdater.exe
See - https://www.novell.com/support/kb/doc.php?id=7000751 (old but the process is still the same)
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: ZCM 11.4.1 update stuck on Update Assigned.

On Mon, 04 Jan 2016 16:16:02 GMT, CRAIGDWILSON
<CRAIGDWILSON@no-mx.forums.microfocus.com> wrote:

Johan reports:

A bug is being reported on the missing
novell-zenworks-libsolv-helpers-11.4.1_0.6.6-6.1.x86_64.rpm

>
> Simplest may be to delete, re-import and re-assign the system update.
>
> You can also try to manually kick-start the system update using
> zenupdater.exe
> See - https://www.novell.com/support/kb/doc.php?id=7000751 (old but the
> process is still the same)
>
>
> --


0 Likes
preinhar Absent Member.
Absent Member.

Re: ZCM 11.4.1 update stuck on Update Assigned.

After waiting for a couple days, I went in this morning and lo and behold, the primary server had successfully upgraded to 11.4.1. I don't know why it took so long but I am glad it updated.

Thanks. I'll post some more questions in another thread.

Paul
0 Likes
besjog Absent Member.
Absent Member.

Re: ZCM 11.4.1 update stuck on Update Assigned.

I am seeing a minor issue with the zcm upgrade where on some server in the Message log in ZCM on the affected servers “Unable to install or uninstall components:”
In the zmd-messages logs on the majority of satellite servers I am seeing the following:-

[TRACE] [01/22/2016 07:34:50.302] [14534] [ZenworksAgent] [955] [] [PackageSourceService] [] [Failed to download install package novell-zenworks-libsolv-helpers-11.4.1_0.6.6-6.1.x86_64.rpm from remote source(s)] [] [] [] [ZENworks Agent]

Interestingly I have unzipped the 11.4.1 upgrade file and have checked in /content-repo/system-update/5011040100fc50000000002015121012/rpm/sles-11-x86_64 on a few satellites and Novell don’t have
novell-zenworks-libsolv-helpers-11.4.1_0.6.6-6.1.x86_64.rpm anywhere in the rpm directory but do have novell-zenworks-libsolv-helpers-11.4.0_0.6.6-6.1.x86_64.rpm in that directory so looks like the
incorrect version has been shipped with the update or the upgrade installer is looking for the wrong version. None of the Linux rpm folder in the unzipped upgrade file have the version in the logs--only the older version


/content-repo/system-update/5011040100fc50000000002015121012/ is the folder created for the 11.4.1 upgrade file
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: ZCM 11.4.1 update stuck on Update Assigned.

besjog;2417666 wrote:
I am seeing a minor issue with the zcm upgrade where on some server in the Message log in ZCM on the affected servers “Unable to install or uninstall components:”
In the zmd-messages logs on the majority of satellite servers I am seeing the following:-

[TRACE] [01/22/2016 07:34:50.302] [14534] [ZenworksAgent] [955] [] [PackageSourceService] [] [Failed to download install package novell-zenworks-libsolv-helpers-11.4.1_0.6.6-6.1.x86_64.rpm from remote source(s)] [] [] [] [ZENworks Agent]

Interestingly I have unzipped the 11.4.1 upgrade file and have checked in /content-repo/system-update/5011040100fc50000000002015121012/rpm/sles-11-x86_64 on a few satellites and Novell don’t have
novell-zenworks-libsolv-helpers-11.4.1_0.6.6-6.1.x86_64.rpm anywhere in the rpm directory but do have novell-zenworks-libsolv-helpers-11.4.0_0.6.6-6.1.x86_64.rpm in that directory so looks like the
incorrect version has been shipped with the update or the upgrade installer is looking for the wrong version. None of the Linux rpm folder in the unzipped upgrade file have the version in the logs--only the older version


/content-repo/system-update/5011040100fc50000000002015121012/ is the folder created for the 11.4.1 upgrade file



Known issue, but does not cause any upgrade failure or functional/operational issue.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.