m0del101 Absent Member.
Absent Member.
1533 views

ZCM 17.2 pxe boot WinPE Auto mode?

Hi

I'm trying to get third party preboot script to run but i can't find any information on how to enable WinPE Auto mode that's mentioned in the documentation.
i can only seem to boot into winpe maintenance mode.

"In WinPE Maintenance mode: On querying for work from the Novell ZENworks Third-Party
Imaging utility, the script is downloaded with the WinScript<file number>.<ext> file name, where
ext is the type of the script. You need to execute this script in the command prompt.

In WinPE Auto mode: The script is downloaded and executed."

https://www.novell.com/documentation/zenworks-2017-update-2/pdfdoc/zen_cm_preboot_imaging/zen_cm_preboot_imaging.pdf

page 220

these are the options in my EUFI pxemenu file

[Main]
MenuTitle = ZENworks Preboot Options
option = "execute;Start ZENworks Imaging;ZENworks Imaging in Automated Mode;efi/x86_64/bootx64.efi;efi/x86_64/z_auto.conf"
option = "execute;Start ZENworks Imaging Maintenance;ZENworks Imaging Linux Session in Interactive Mode;efi/x86_64/bootx64.efi;efi/x86_64/z_maint.conf"
option = "execute;WinPE Maintenance Mode;Launch WADK WinPE environment;efi/x86_64/bootmgfw.efi;efi/x86_64/winpe.conf"
option = "execute;Disable ZENworks Partition;Disable Existing ZENworks partition;efi/x86_64/bootx64.efi;efi/x86_64/z_zpdis.conf"
option = "execute;Enable ZENworks Partition;Re-enable Existing ZENworks partition;efi/x86_64/bootx64.efi;efi/x86_64/z_zpen.conf"
option = "execute;Start DELL DTK;DELL DTK Task in Automated Mode;efi/x86_64/bootx64.efi;efi/x86_64/dell-dtk.conf"
option = "execute;Start DELL DTK Maintenance;DELL DTK Task in Interactive Mode;efi/x86_64/bootx64.efi;efi/x86_64/dell-dtk_maint.conf"
#option = "submenu;Sub Menu Options >>;Submenu example with more options1;SUBMenu"
option = "exit;Exit;Boot to local hard drive"
Labels (1)
0 Likes
5 Replies
AutomaticReply Absent Member.
Absent Member.

Re: ZCM 17.2 pxe boot WinPE Auto mode?

m0del101,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.
https://www.partnernetprogram.com/partnerfinder/find.html

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.microfocus.com/faq.php

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team
http://forums.microfocus.com



0 Likes
xsisbest1 Absent Member.
Absent Member.

Re: ZCM 17.2 pxe boot WinPE Auto mode?

WINPE Auto mode I would describe as unattended mode in which you don't have to push ctl alt to bring up the menu you are seeing. If you have assigned a 3rd party image or bundle to an existing computer, you should just reboot the computer and let it pxe boot and it should auto launch winpe and start the image process automatically. If you see the Zenworks preboot menu is coming up automatically without pushing ctl alt, you need to go to the zenworks control center, Configuration, Preboot Services and make sure the menu option is set to Only show if alt clt is pushed or not at all whatever you want.. just not Always show menu. Hope that helps.
0 Likes
m0del101 Absent Member.
Absent Member.

Re: ZCM 17.2 pxe boot WinPE Auto mode?

xsisbest;2482978 wrote:
WINPE Auto mode I would describe as unattended mode in which you don't have to push ctl alt to bring up the menu you are seeing. If you have assigned a 3rd party image or bundle to an existing computer, you should just reboot the computer and let it pxe boot and it should auto launch winpe and start the image process automatically. If you see the Zenworks preboot menu is coming up automatically without pushing ctl alt, you need to go to the zenworks control center, Configuration, Preboot Services and make sure the menu option is set to Only show if alt clt is pushed or not at all whatever you want.. just not Always show menu. Hope that helps.


thanks for your reply!. I have raised a service request as our preboot environment is not behaving as expected. with a third party powershell script pre boot bundle assigned to a device the pxe boot queries the server for work then boots into the linux imaging rather than winpe.
0 Likes
xsisbest1 Absent Member.
Absent Member.

Re: ZCM 17.2 pxe boot WinPE Auto mode?

One that I had to do to kickstart my 3rd party bundle (mdt) was copy the MDT x64 contents (whatever os your using.. x86..x64 etc), which is a set of custom winpe files, to the srv\tftp\Boot folder and overwrite the contents. Then winpe would launch appropriately. Seems crazy you would have to do that but it's what worked for us. The winpe files you upload via the 3rd party image section are uploaded into the tftp\efi\Microsoft\Boot folder.
0 Likes
Highlighted
m0del101 Absent Member.
Absent Member.

Re: ZCM 17.2 pxe boot WinPE Auto mode?

xsisbest;2483039 wrote:
One that I had to do to kickstart my 3rd party bundle (mdt) was copy the MDT x64 contents (whatever os your using.. x86..x64 etc), which is a set of custom winpe files, to the srv\tftp\Boot folder and overwrite the contents. Then winpe would launch appropriately. Seems crazy you would have to do that but it's what worked for us. The winpe files you upload via the 3rd party image section are uploaded into the tftp\efi\Microsoft\Boot folder.



our pre-boot started behaving once we changed the boot option to Show Imaging menu if CTRL+ALT pressed and commented out the #ForceOption in the pxemenu.txt. now pre-boot is processing hardware rules and assigned work or just boots into windows if there isn't any work to do.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.