Highlighted
kennolson Absent Member.
Absent Member.
2128 views

ZCM 2017 satellite replication errors

We're experiencing extremely high volumes of error messages on our ZCM 2017 Update 1 Satellites. The problem seems similar to that described in TID 7021167, except that in our case the content never syncs because, well, it doesn't appear to exist. Example error message:
Failed to replicate content 119b7dcde6e977a71f622a316398146d
Additional Information:
None
Severity: Error
Date: January 19, 2018 3:52:25 AM
Source: /Devices/Servers/zcmswo sles-11-x86_64
Message ID: CDP.CdpContentFileError
Probable Cause URL: None
Related Objects: None

If I zman ogp 119b7dcde6e977a71f622a316398146d on a primary, I get error 22 (could not find object). If I browse to https://<a primary server URL>/zenworks-contentadmin?test=invoke&method=11&arg0=119b7dcde6e977a71f622a316398146d I get a blank result. If I dir *119b7dcde6e977a71f622a316398146d* /s in the content-repo directory on a Windows primary I get "file not found".

Over the course of a day, one satellite will pile up nearly 100,000 error messages of this flavour, each with a unique GUID-that-doesn't-seem-to-point-anywhere. During the same day, the other satellite will record nearly 150,000 error mesages like this!

I have tried, at the satellite, the following:
zac cc
zac ref
zac cvc
zac cdp replicate

I tried removing the content role from the satellite, renaming the content directory in content-repo to content.old, restoring the content role to the satellite and allowing time for the content repository to be rebuilt. And after all was said and done, the flood of error messages had resumed, just as before. The TID says I can set a system variable to ignore the errors, but that would have the effect of masking any problems that might occur. I'm not keen on that. On the other hand, having hundreds of thousands of messages that don't seem to mean anything is in some respects quite similar in effect to having no logging, now that I reflect on it.

The satellites are running SLES, and they are set to replicate once per day, with the full 24 hours as the window to complete. There is no throttling via ZCC, although their bandwidth is constrained by the nature of their connection to our WAN. One has a 100 mbps connection and the other only 10. (I think.) Before anyone gets too hung up on worrying about the physical connection limitations, I hasten to point out that we have had these satellites up and running with ZCM 11 for several years and no problems. The excessive errors began exactly when we upgraded to ZCM 2017, and did not magically disappear when we installed Update 1. I don't believe hardware is to blame here.

It seems to me somehow the satellites have gotten corrupted or outdated information on the content they must replicate, and they are trying to replicate non-existent content.

If anyone has a suggestion as to how I can persuade the satellites they needn't look for this nonexistent content, or any other possible solutions to this issue, I would be most appreciative.
Labels (1)
0 Likes
7 Replies
AutomaticReply Absent Member.
Absent Member.

Re: ZCM 2017 satellite replication errors

kennolson,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.
https://www.partnernetprogram.com/partnerfinder/find.html

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.microfocus.com/faq.php

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team
http://forums.microfocus.com



0 Likes
Micro Focus Expert
Micro Focus Expert

Re: ZCM 2017 satellite replication errors

If you are able to open an SR, I would recommend you do so.
There are some patches around content for ZCM 2017 Update 1.

Primarily it revolves around making sure details around deleted content are fully removed from the DB, which can lead to similar errors and sats wasting time looking for content that was already removed from the system.

Note: ZCM 2017 Update 2 is expected to be available for download in a few hours and contain all of the same fixes.
If issues persist after Update 2 and you are an educational institution that cannot open an SR please send me a private message with contact info on the forums or email CRAIG_D_WILSON at Yahoo as well as post in this thread you have contacted me so I don't miss it.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
kennolson Absent Member.
Absent Member.

Re: ZCM 2017 satellite replication errors

Thanks for the info. I plan to install Update 2 sooner rather than later, to take advantage of the High Sierra compatibility. I'll wait to see if the problems go away after that.
0 Likes
landrich Respected Contributor.
Respected Contributor.

Re: ZCM 2017 satellite replication errors

CRAIGDWILSON;2474127 wrote:

Primarily it revolves around making sure details around deleted content are fully removed from the DB, which can lead to similar errors and sats wasting time looking for content that was already removed from the system.


Hello,

we have the same problem like kennolson.
How can we make sure that the DB is clean of deleted contend?

For information, we Upgrade with the Zennworks appliance 2017.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: ZCM 2017 satellite replication errors

Primary Recommendation would be to apply ZCM 2017 Update 2.

"Updating the Appliance" would not do anything more to address ZCM issues than running Windows Update if ZCM was running on a Windows server.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
rmurley Absent Member.
Absent Member.

Re: ZCM 2017 satellite replication errors

Hi, Craig.

This is a fairly old thread, but we are having the same issue here on our satellites. It has been going on for years, and, like kennolson, the content doesn't seem to exist on the primaries. Running a zac cvc on a satellite consistently reports 3 items out of sync. We are running 2017u4.

Thanks
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: ZCM 2017 satellite replication errors

The issue sounds more like a "Bundle" issue than a satellite issue.
The Satellite is assigned content that does not exist.

I'd open an SR and they can help identify and cleanup (Maybe fix) the bad bundle.
The bad bundle could even be an older version of a current bundle.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.