UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Vice Admiral
Vice Admiral
226 views

ZENworks 2017 SP4 User Assigned Applications not Showing up in ZAL

Jump to solution

User Assigned Applications are showing up in the ZENworks Agent Under Windows Drives:

ZEN Agent 1ZEN Agent 1ZEN Agent 2ZEN Agent 2

BUT NOT in the ZENworks Application Launcher:

Zen ZAL.png

They also show up as properly assigned when viewing the Agent Technician Application-->Bundles,

ZEN tech app.png

and also they show up as assigned properly with zac bl:

ZEN BL.png

Why would they show up in ALL these places and NOT in the ZAL (ZENworks Application Launcher? Has Anyone seen this before?

 

0 Likes
1 Solution

Accepted Solutions
Knowledge Partner Knowledge Partner
Knowledge Partner

Because you typed "adobe" in the search box and everything is filtered.  Clear that and they should appear.

--
Ken
Knowledge Partner

Create and vote for enhancements in the Idea Exchange forums!
Don't forget to Like helpful posts and mark Solutions!

View solution in original post

7 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

Because you typed "adobe" in the search box and everything is filtered.  Clear that and they should appear.

--
Ken
Knowledge Partner

Create and vote for enhancements in the Idea Exchange forums!
Don't forget to Like helpful posts and mark Solutions!

View solution in original post

Micro Focus Expert
Micro Focus Expert

I don't remember witnessing that issue.
I didn't see a defect with that type scenario.

I see the user is logged in so ZAPP hasn't crashed.
There are a couple more logs you can investigate -
In the %ZENworks_Home%\logs there should be a zapp.<username> file which is that users zapp log?
Does this exist? Every refresh should update this user log.
You can also check the %localappdata%\ZENworks\User Data\Default

Login Data
Preferences
\Cache\data_x should contain bread crumbs (guid's) of the related apps.

These might bring clues...

Is the agent the same version as the zone?

Does this happen on other managed devices?

Any anomalies in the Event log?

Do those apps show up in ZAPP if they are assigned to the managed device?

 

0 Likes
Micro Focus Expert
Micro Focus Expert

@ketter 

Agree...That is the most likely scenario....Either accidentally or intentionally and forgotten...they have entered data into the Seach field in the top right of the ZAPP Window.  Heck may even be a hidden ASCII character if their fingers were particularly unlucky that day they flew off course.

--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

@CRAIGDWILSON  Most likely?  The screen capture of the ZAPP window shows it.  I've done the same thing.  🙂

--
Ken
Knowledge Partner

Create and vote for enhancements in the Idea Exchange forums!
Don't forget to Like helpful posts and mark Solutions!
Micro Focus Expert
Micro Focus Expert

Missed checking the search myself. 😃

0 Likes
Vice Admiral
Vice Admiral

I can;t believe the user did that...and I cannot believe I missed that....Shame on me, shame on me.

0 Likes
Micro Focus Expert
Micro Focus Expert

The more you know, the harder it is to spot simple issues.

If you know 10,000 things to check, your mind runs through them all.

If you know 1 thing to check....you check that one thing and if it is that one thing, you seem brilliant for finding it so fast 😆

 

--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.