Highlighted
NParkFSTS Frequent Contributor.
Frequent Contributor.
433 views

ZENworks 2017 to 2020 PostgreSQL Database Version Issues?

I'm testing a lab zone migrating from ZCM 2017 to 2020 with an external SyBase (and thus PostgreSQL) database running on Windows Server 2016.  Installing the latest 10.x or 11.x PostgreSQL works fine on the DB server, and I'm able to migrate the existing zone and audit database, but when I go to run the ZENworks 2020 install, I receive the error "This database version is not supported for ZENworks."

Looking in ZCC, my ZENworks 2017 zone is happily using PostgreSQL version 10.11 for instance, but I cannot upgrade to ZCM 2020 from here.

On the website for PostgreSQL, there is only one installer for each major version (the latest for the 9.x, 10.x, 11.x series) - not sure if that's the issue?  The requirements only say 9.x 10.x 11.x so one would assume that any point version on that major version would work.  And if not, it doesn't seem to be possible to obtain an older/specific point version of the PostgreSQL installer for Windows. 

I have not yet tried using the repo version on a SLE install for the DB server.

Not sure if the DB version is the actual issue or if anyone else has encountered this?

 

Labels (1)
0 Likes
8 Replies
Micro Focus Expert
Micro Focus Expert

Re: ZENworks 2017 to 2020 PostgreSQL Database Version Issues?

If you are able to open an SR, please do so and reference defect#1157613

It short, it's the difficulty using externalPOstgreSQL going to 2020 since 2017 support 9.x and 10.x, but 2020 only supports 11.x

https://www.novell.com/documentation/zenworks-2017-update-4/zen_system_requirements/data/zen_system_requirements.html#database_requirements

https://www.novell.com/documentation/zenworks-2020/zen_system_requirements/data/zen_system_requirements.html#database_requirements

With Internal Sybase, the Upgrade handles upgrading PostGres for you.

I suspect there will be some updated docs shortly.  I suspect it will be resolved by adding support for 11.x in ZCM 2017, but the details are still being worked out...

 

--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
nuborgh Super Contributor.
Super Contributor.

Re: ZENworks 2017 to 2020 PostgreSQL Database Version Issues?

same issue here.

NParkFSTS Frequent Contributor.
Frequent Contributor.

Re: ZENworks 2017 to 2020 PostgreSQL Database Version Issues?

I updated my lab zone to 2017.4, and located the installer for PostgreSQL 11.4 (while not linked, the URLs on their site for downloads are predictable so I was able to get the older version) and am not able to use the ZCM 2020 installer or the DB migration tool same as before.  The migration tool says 'PostgreSQL 11.x is not supported for Database migration'

An SR really isn't going to be workable as a path forward - I'm with an MSP and we manage about 60 or so independent ZENworks zones and presumably all of them will be going to ZCM 2020 at some point, and nearly all of them are using external Sybase zone and audit databases.  Really hoping this can get smoothed out so there's a path forward.

Thanks!

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: ZENworks 2017 to 2020 PostgreSQL Database Version Issues?

Things should get worked out sooner rather later.  The difficulties you are describing had already been raised to development before this post.  I don't have an ETA.

--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
NParkFSTS Frequent Contributor.
Frequent Contributor.

Re: ZENworks 2017 to 2020 PostgreSQL Database Version Issues?

Understood!  Just jumping the gun testing the latest while R&D time presents itself. 

Thanks for letting us know.

0 Likes
jeffm53
New Member.

Re: ZENworks 2017 to 2020 PostgreSQL Database Version Issues?

Hello Craig,

I saw that version 1.1 of the DB Migration tool is available.  Does this new version allow for a direct migration from external Sybase to external PostgreSQL version 11.4?  The current zone is 2017 Update 4.  The documentation indicates that PostgreSQL 11.4 is supported with 2017 Update 4:

https://www.novell.com/documentation/zenworks-2017-update-4/pdfdoc/zen_system_requirements/zen_system_requirements.pdf

Thank you for any information you have about version 1.1 of the migration tool.

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: ZENworks 2017 to 2020 PostgreSQL Database Version Issues?

Yes, I believe it should work with the 1.1 version of the Tool based on my reading of various internal email threads.

There is not much really different about the tool, other than it tries to address a few issues here or there such as the version checking gotcha seen with the issue in this thread.

The on-line docs should be current with whatever is in the Version 1.1 of the tool.  I saw a note from just before Christmas where the Docs had actually be updated prior to the release of 1.1

Not sure if the Holidays caused the delay between the update of the docs and release of the new version of the tool.

--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
dbriese Contributor.
Contributor.

Re: ZENworks 2017 to 2020 PostgreSQL Database Version Issues?

I faced this Catch22 situation as well. I solved it by first installing and configuring PostgreSQL 10.11 on the remote DB server (https://www.novell.com/documentation/zenworks-2020/zen_sybase_postgre_migration/data/zen_sybase_postgre_migration.html#t4ajdjd2hq0g) and then use the ZENworks 2020 setup on the first Primary to migrate the database from remote Sybase to remote PostgreSQL (https://www.novell.com/documentation/zenworks-2020/zen_sybase_postgre_migration/data/zen_sybase_postgre_migration.html#t4aaqgc5uiwm).

After that, because the ZENworks 2020 setup will complain about PostgreSQL not being 11.x, I followed this guide to manually upgrade 10.11 to 11.4: https://www.arencambre.com/blog/2014/12/24/postgress-pg_upgrade-on-windows-the-documentation-misses-a-lot/comment-page-1/ The procedure might look more complicated than it actually is. The biggest challenge after finding the guide was to get my hands on the PostgreSQL 11.4 installer, which according to the ZCM 2020 docs is the maximum supported 11.x version but it's not easily available from neither postgresql.org nor enterprisedb.com. Through a little trial and error I finally found the download link: https://get.enterprisedb.com/postgresql/postgresql-11.4-1-windows-x64.exe.

With this I was able to upgrade two ZENworks 17.4.1 Primaries with a remote Sybase DB to ZENworks 2020 and a remote PostgreSQL 11.4 DB. Hope this helps!

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.