Highlighted
New Member.
2125 views

ZNEWS service

I think something broke.
It was working before with the last item I remember being an invitation to some training in December 09 and Dec PRU. Not sure when it happened but I think it was after the 10.2.2 update ie not as a result of it. Currently its latest news item is 'Aug 6 Tip & Tricks'. Yes, have tried the Update now button.

Version on the server are

novell-zenworks-znews-langs-server 10.2.2.44767
novell-zenworks-znews-server 10.2.2.44767

Loader-messages log

[DEBUG] [1/29/10 8:00:01 AM] [] [Loader.Zenworks News Handler] [] [Zenworks News Component: NewsActionHandler] [] []
[DEBUG] [1/29/10 8:00:01 AM] [] [Zenworks News Component] [] [The requesting URL: https://nu.novell.com/znews/10.2/NewsListVersion.properties] [] []
[DEBUG] [1/29/10 8:00:01 AM] [] [Zenworks News Component] [] [The requesting URL: https://nu.novell.com/znews/10.2/NewsListVersion.properties] [] []
[DEBUG] [1/29/10 8:00:02 AM] [] [Zenworks News Component] [] [No of Files in the Directory are:0] [] []


https://nu.novell.com/znews/10.2/NewsListVersion.properties
#NewsList Version for product version 10.2
#Mon Dec 07 15:00:10 GMT-6:00 2009
newslistversion=53


However
https://nu.novell.com/znews/NewsListVersion.properties
#NewsList Version for product version 10.2
#Thu Jun 11 11:50:16 GMT-6:00 2009
newslistversion=25

an old version I guess.

Only thing I've done is set up a satellite server as a collection server.
Is there a way to restart the znews service?

Anyone with the same?
Cheers
Labels (2)
0 Likes
21 Replies
Highlighted
Absent Member.
Absent Member.

Re: ZNEWS service

Hello I am on ZCM10.2 and am seeing the same issue: my latest news is
date August 2009.

The dedicated news server has access to the Internet directly but I don't
get any new News by either running the job manually or from a scheduled
job.

0 Likes
Highlighted
New Member.

Re: ZNEWS service

Either we both have screwed up or on to something.

Thanks for the reply
Cheers
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: ZNEWS service

Gerwil,

there isn't any more recent news, I am chasing this now...

--

Shaun Pond


0 Likes
Highlighted
New Member.

Re: ZNEWS service

Thanks. I'm sure there were messages around December 09.

🙂 🙂 🙂
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: ZNEWS service

Gerwil,

yeah, but messages can expire... we're looking round to think what news
we can put out...

--

Shaun Pond


0 Likes
Highlighted
New Member.

Re: ZNEWS service

Back online. Two messages appeared today - Feb 18 and Feb 22.

Thanks Shaun 🙂
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: ZNEWS service

Gerwil,

we aim to please... 🙂

--

Shaun Pond


0 Likes
Highlighted
New Member.

Re: ZNEWS service

oh oh
Loader-messages.log


[DEBUG] [3/2/10 8:00:01 AM] [] [Loader.Zenworks News Handler] [] [Zenworks News Component: NewsActionHandler] [] []
[DEBUG] [3/2/10 8:00:01 AM] [] [Zenworks News Component] [] [The requesting URL: https://nu.novell.com/znews/10.2/NewsListVersion.properties] [] []
[DEBUG] [3/2/10 8:00:01 AM] [] [Zenworks News Component] [] [The requesting URL: https://nu.novell.com/znews/10.2/NewsListVersion.properties] [] []
[DEBUG] [3/2/10 8:00:02 AM] [] [Loader.QueueRunner] [] [Handler failed to process action ID : 77970, Type: zenworks.news.action, ] [] []
[DEBUG] [3/2/10 8:00:02 AM] [] [Loader.QueueRunner] [] [java.lang.NullPointerException
at com.novell.zenworks.loader.modules.queue.handlers.znews.ZNewsActionHandler.httpDownload(ZNewsActionHandler.java:591)
at com.novell.zenworks.loader.modules.queue.handlers.znews.ZNewsActionHandler.getNewsDataFromServer(ZNewsActionHandler.java:434)
at com.novell.zenworks.loader.modules.queue.handlers.znews.ZNewsActionHandler.processAction(ZNewsActionHandler.java:122)
at com.novell.zenworks.loader.modules.queue.runner.QueueThreadWorker.processAction(QueueThreadWorker.java:208)
at com.novell.zenworks.loader.modules.queue.runner.QueueThreadWorker.run(QueueThreadWorker.java:139)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
at java.lang.Thread.run(Thread.java:595)
] [] []


Not sure how long its been like this. Only thing I can thing of is updates for mono but not sure if this was before/after etc.

lawzcm:/ # rpm -qa |grep mono
Gives
mono-core-32bit-1.2.2-12.27
mono-winforms-2.4.3-26.1
mono-data-2.4.3-26.1
mono-web-2.4.3-26.1
mono-core-2.4.3-26.1
mono-data-sqlite-2.4.3-26.1
mono-extras-2.4.3-26.1
dbus-1-mono-0.60-33.25


Sorry Shaun
Cheers
0 Likes
Highlighted
New Member.

Re: ZNEWS service

First error on the 27/2/10 so nothing to do with mono.

Cheers
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: ZNEWS service

Gerwil,

I see this, too...

--

Shaun Pond


0 Likes
Highlighted
Absent Member.
Absent Member.

Re: ZNEWS service

I'm getting same ZNewsActionHandler java errors in loader-messages.log too (on SLES, ZCM 10.2.2) and no recent news updates. First occurence of error in my logs is 26th Feb, so broke sometime before then. 😞
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.