postaszewski Absent Member.
Absent Member.
1516 views

source connection lost after all sources certificates expire

Hello all...

running the latest zcm 11 and found out today that all my sources server certificates expired at the same time and left me with no connection for zcm. I fixed all the certificates but still can't get it to connect.

The errors i get are: Unable to read contexts. One or more of your connections don't support non-SSL. AND Unable to connect to the ZENworks database.: 10.10.2.5:636

I try to remove the sources and re-add them but that doesn't work either.

HALP!
Labels (2)
0 Likes
4 Replies
Knowledge Partner
Knowledge Partner

Re: source connection lost after all sources certificates ex

postaszewski;2283375 wrote:
Hello all...

running the latest zcm 11 and found out today that all my sources server certificates expired at the same time and left me with no connection for zcm. I fixed all the certificates but still can't get it to connect.

The errors i get are: Unable to read contexts. One or more of your connections don't support non-SSL. AND Unable to connect to the ZENworks database.: 10.10.2.5:636

I try to remove the sources and re-add them but that doesn't work either.

HALP!


Have you also tried just updating the SSL certificate for each and every server that has been defined in the user source (in the configuration > user source server settings within ZCC)?

If that won't budge with the update options you have within ZCC and the system being in such a state, I'd advice to directly open a call/SR with Novell.

-Willem
0 Likes
postaszewski Absent Member.
Absent Member.

Re: source connection lost after all sources certificates ex

magic31;2283485 wrote:
Have you also tried just updating the SSL certificate for each and every server that has been defined in the user source (in the configuration > user source server settings within ZCC)?

If that won't budge with the update options you have within ZCC and the system being in such a state, I'd advice to directly open a call/SR with Novell.

-Willem


I have. All certificates have been updated.

I was hoping someone on here could help me before it got to the point that I had to open an SR with novell.
0 Likes
postaszewski Absent Member.
Absent Member.

Re: source connection lost after all sources certificates ex

I figured it out. I first did what's written here: https://www.novell.com/support/kb/doc.php?id=7007411 and then did an rcndsd restart on the servers that i use for the sources for zcc. I then went back into the zcc sources and clicked on each individual source and clicked the update button to refresh the ssl certs in zcc. All is well now.
0 Likes
Knowledge Partner
Knowledge Partner

Re: source connection lost after all sources certificates ex

postaszewski;2283547 wrote:
I figured it out. I first did what's written here: https://www.novell.com/support/kb/doc.php?id=7007411 and then did an rcndsd restart on the servers that i use for the sources for zcc. I then went back into the zcc sources and clicked on each individual source and clicked the update button to refresh the ssl certs in zcc. All is well now.


Ah, the new server certificates where not yet active? E.g. they where renewed in iManager or other, but servers/services hadn't yet been bounced after that?

Glad to hear you have it sorted & thanks for feeding your solution back to the forums!

Cheers,
Willem
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.