New Ranks & Badges For The Community!
Notice something different? The ranks and associated badges have gone "Star Fleet". See what they all mean HERE
Highlighted
Captain
Captain
362 views

zenworks failover?

I have 2 ZENworks 2020 running on seperate VM with a remote database of postgres 11.

I was testing if there would be a failover between the 2 ZENworks in the same zone but once the primary server where i configured first shuts down my workstations and even the second server wont connect.

Is there a way to configure two ZENworks server with failover? also having 2 zenworks server offloads the request between the workstation with the help of the closes server rule?

 

Thanks and regards,

Lyle

Labels (1)
0 Likes
5 Replies
Highlighted
Lieutenant
Lieutenant

Hi,

Having multiple Primary servers is mainly used to distribute the back-end services within the product.  In order to accommodate your need, you'll need to setup load balancing over an L4 switch.  Essentially you'd be setting up a virtual IP and pointing DNS to this address where your clients would be registered to.

More details can be found on page 177 of this best practice guide:  https://www.novell.com/documentation/zenworks-2020/pdfdoc/zen_cm_deployment_bp/zen_cm_deployment_bp.pdf

Regards.

Highlighted
Fleet Admiral
Fleet Admiral

Assuming an External DB, the fail-over should be automatic.

Further, there is not any need for an L4.  In your location rules, you can configure your servers to be in a group, this will randomize the order in which devices hit the servers.  If one is down, then they would use the other.

Check your location rules to ensure both servers are flowing down in your location for all roles.

L4s can be used and may eliminate a short delay the 1st time a device tries to hit a down server before it moves on to the other server.  The first server will then be marked 'bad' for a while so it is not hit again while it is down.

Drawbacks include troubleshooting difficulty when there are issues on a single server behind an L4.  Client-side logs will show the error, but not which specific server.  The same is true for the use of groups, but to a lesser extend.  Some folks prefer to just have specific orders for different locations to minimize randomness.

 

--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
Highlighted
Captain
Captain

I see I have not configured the location and grouped my servers maybe that is why when the 1st primary server is down my workstations can't connect to the second one.

 

Is there a guide on how to group servers up?

Thanks and kind regards,

Lyle

0 Likes
Highlighted
Fleet Admiral
Fleet Admiral

Normally no action is required....

ZCC->Configuration->Infrastructure Management->Closest Server Default Rule

Will define "Default Values".  Your second server should have been added automatically here.  Even w/o groups, devices will always try Server1 and then Server2.  Groups would just balance the load. 

ZCC->Configuration-> (Locations Tab) is where you can define specific servers for specific locations.

By Default, the "Closest Server Default Rule" will be appended on the end for any location, but there is a check box to prevent this.

So check both the Default Rule and any defined locations to make sure "Server2" is there.

Since it would be by default, it is quite possible you have some operational issue with your second server.

Sometimes I setup a Location Rule that is specific to just "One" IP address which is a lab device.  Then set that location to just use ONE SERVER and exclude the others.  This way I can easily test functionality of a given server if I think it may be bad.  You may want to try that for Server2 so you can troubleshoot w/o bringing down Server1.

--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
Highlighted
Captain
Captain

oh, I see I'll try the location rule with my second server.

 

the funny thing is that I grouped my server 1 & 2 and it suddenly works whenever I bring down server 1or 2 the end devices connect to whichever server is alive. I have not made a location rule yet.

Thanks and regards,

Lyle

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.