Highlighted
Absent Member.
Absent Member.
3787 views

zenworksuserdaemon.exe command windows hangs

Hello all,

We recently updated to 11.2.4 MU1 and I've noticed that on our Win7 x64 devices the zenworksuserdaemon opens a black command window that stays empty. It sits there for 4 or 5 minutes before finally disappearing. It does this every log in. It uses 0 of the CPU and about 18,500 k of memory. Doesn't seem like its really doing much, just kind of sitting there. There are a couple small bundles that run on login but they finish as expected and the black command window stays open long after they are finished running so I have no idea if there is any relation between zenworksuserdaemon.exe and run on login bundles.

You can see an irrecoverable error in the log file below. Any help in a direction to go would be appreciated. Im not even fully sure what zenuserdaemon does so i don't even know where to begin troubleshooting.

Thanks.

I cleared the log file, logged out and back in. The window stayed open for about 4 minutes before closing and then i copied this log file.

[DEBUG] [01/30/2014 09:30:34.527] [1340] [ZenworksWindowsService] [4] [] [ZenCache] [] [DeleteFiles called for (printer policy#2e72861b0a2b4643ae2c8c2c5ba8e3d4_printer policy.xml, UserContext{_LocalId=none; _RemoteId=(ActionManager)SYSTEM})] [] []
[DEBUG] [01/30/2014 09:30:34.527] [1340] [ZenworksWindowsService] [4] [] [ZenCache] [] [DeleteFiles called for (printer policy#a28de4fd34cc3954a2f1cc34ade106cd~3d896697a8346944869a3d896697a834_printer policy.xml, UserContext{_LocalId=none; _RemoteId=(ActionManager)user})] [] []
[DEBUG] [01/30/2014 09:30:47.912] [1340] [ZenworksWindowsService] [43] [] [SoapUtility] [] [Checksumming soap call with UID: USER:Assignment:GetEffectiveAssignments] [] []
[DEBUG] [01/30/2014 09:30:47.912] [1340] [ZenworksWindowsService] [43] [] [SoapUtility] [] [Added checksum to request: 8fc755f03e93c06a7b45e06fd94836ed8ac15fc54315ff37a70a3c62100e9126] [] []
[DEBUG] [01/30/2014 09:30:50.454] [1340] [ZenworksWindowsService] [43] [] [SoapUtility] [] [Using cached response.] [] []
[DEBUG] [01/30/2014 09:30:50.454] [1340] [ZenworksWindowsService] [43] [] [CacheableHttpWebResponse] [] [Getting Response Stream] [] []
[DEBUG] [01/30/2014 09:30:50.517] [1340] [ZenworksWindowsService] [43] [] [ContentManager] [] [metadataUpdatedNeeded = False] [] []
[DEBUG] [01/30/2014 09:30:51.078] [1340] [ZenworksWindowsService] [37] [] [ZESMEnterprisePolicySettings] [] [Is all the ZESM Policies accepted by ZID:true] [] []
[DEBUG] [01/30/2014 09:30:51.078] [1340] [ZenworksWindowsService] [37] [] [ZESMEnterprisePolicySettings] [] [Is all the ZESM Policies enforced by ZID:true] [] []
[DEBUG] [01/30/2014 09:30:51.078] [1340] [ZenworksWindowsService] [37] [] [ZESMEnterprisePolicySettings] [] [ZID Current status:Enforced - Feature is operating normally last time it was loaded or currently.] [] []
[DEBUG] [01/30/2014 09:30:51.297] [1340] [ZenworksWindowsService] [51] [] [ZESMEnterprisePolicySettings] [] [Is all the ZESM Policies accepted by ZID:true] [] []
[DEBUG] [01/30/2014 09:30:51.297] [1340] [ZenworksWindowsService] [51] [] [ZESMEnterprisePolicySettings] [] [Is all the ZESM Policies enforced by ZID:true] [] []
[DEBUG] [01/30/2014 09:30:51.297] [1340] [ZenworksWindowsService] [51] [] [ZESMEnterprisePolicySettings] [] [ZID Current status:Enforced - Feature is operating normally last time it was loaded or currently.] [] []
[DEBUG] [01/30/2014 09:30:53.403] [1340] [ZenworksWindowsService] [34] [] [SoapUtility] [] [Checksumming soap call with UID: USER:Assignment:GetEffectiveAssignments] [] []
[DEBUG] [01/30/2014 09:30:53.403] [1340] [ZenworksWindowsService] [34] [] [SoapUtility] [] [Added checksum to request: 8fc755f03e93c06a7b45e06fd94836ed8ac15fc54315ff37a70a3c62100e9126] [] []
[DEBUG] [01/30/2014 09:30:54.417] [1340] [ZenworksWindowsService] [34] [] [SoapUtility] [] [Found etag: 8ef6b1074d934a50d5edf8b023a62b4331555aa7e5b92c14d696ef7e1ddf2cc8] [] []
[DEBUG] [01/30/2014 09:30:54.417] [1340] [ZenworksWindowsService] [34] [] [SoapUtility] [] [Updating checksum for USER:Assignment:GetEffectiveAssignments. Value: 8ef6b1074d934a50d5edf8b023a62b4331555aa7e5b92c14d696ef7e1ddf2cc8] [] []
[DEBUG] [01/30/2014 09:30:54.432] [1340] [ZenworksWindowsService] [34] [] [SoapUtility] [] [Caching HTTP response, Key: USER:Assignment:GetEffectiveAssignments] [] []
[DEBUG] [01/30/2014 09:30:54.448] [1340] [ZenworksWindowsService] [34] [] [CacheableHttpWebResponse] [] [Getting Response Stream] [] []
[DEBUG] [01/30/2014 09:30:54.698] [1340] [ZenworksWindowsService] [34] [] [ContentManager] [] [metadataUpdatedNeeded = False] [] []
[DEBUG] [01/30/2014 09:31:04.260] [1340] [ZenworksWindowsService] [48] [] [ZESMEnterprisePolicySettings] [] [Is all the ZESM Policies accepted by ZID:true] [] []
[DEBUG] [01/30/2014 09:31:04.260] [1340] [ZenworksWindowsService] [48] [] [ZESMEnterprisePolicySettings] [] [Is all the ZESM Policies enforced by ZID:true] [] []
[DEBUG] [01/30/2014 09:31:04.260] [1340] [ZenworksWindowsService] [48] [] [ZESMEnterprisePolicySettings] [] [ZID Current status:Enforced - Feature is operating normally last time it was loaded or currently.] [] []
[DEBUG] [01/30/2014 09:31:04.869] [1340] [ZenworksWindowsService] [34] [] [SoapUtility] [] [Checksumming soap call with UID: USER:Containment:GetContainment] [] []
[DEBUG] [01/30/2014 09:31:17.536] [1340] [ZenworksWindowsService] [7] [] [ZenCache] [] [DeleteFiles called for (printer policy#2e72861b0a2b4643ae2c8c2c5ba8e3d4_printer policy.xml, UserContext{_LocalId=none; _RemoteId=(ActionManager)SYSTEM})] [] []
[DEBUG] [01/30/2014 09:31:17.536] [1340] [ZenworksWindowsService] [7] [] [ZenCache] [] [DeleteFiles called for (printer policy#a28de4fd34cc3954a2f1cc34ade106cd~3d896697a8346944869a3d896697a834_printer policy.xml, UserContext{_LocalId=none; _RemoteId=(ActionManager)user})] [] []
[DEBUG] [01/30/2014 09:31:20.750] [1340] [ZenworksWindowsService] [7] [] [ZESMEnterprisePolicySettings] [] [InstallPrepCalled value from session:true] [] []
[ INFO] [01/30/2014 09:31:22.247] [1340] [ZenworksWindowsService] [7] [apitt] [printer policy] [POLICYHANDLERS.PrinterPolicy.PrinterAlreadyExists] [Printer ipp://iprint01.cgresd.net/ipp/cgCentralHp4000 already exists for user , hence not adding.] [] [null]
[ INFO] [01/30/2014 09:31:22.247] [1340] [ZenworksWindowsService] [7] [apitt] [printer policy] [POLICYHANDLERS.PrinterPolicy.PrinterAlreadyExists] [Printer ipp://iprint01.cgresd.net/ipp/cgCentralXe6180 already exists for user , hence not adding.] [] [null]
[ INFO] [01/30/2014 09:31:22.247] [1340] [ZenworksWindowsService] [7] [apitt] [printer policy] [POLICYHANDLERS.PrinterPolicy.PrinterAlreadyExists] [Printer ipp://iprint01.cgresd.net/ipp/cgCentralRiMP8001 already exists for user , hence not adding.] [] [null]
[ INFO] [01/30/2014 09:31:22.247] [1340] [ZenworksWindowsService] [7] [apitt] [printer policy] [POLICYHANDLERS.PrinterPolicy.PrinterAlreadyExists] [Printer ipp://iprint01.cgresd.net/ipp/cgCentralRiMPC5000 already exists for user , hence not adding.] [] [null]
[DEBUG] [01/30/2014 09:31:23.027] [1340] [ZenworksWindowsService] [7] [] [ZenCache] [] [DeleteFiles called for (printer policy#2e72861b0a2b4643ae2c8c2c5ba8e3d4_printer policy.xml, UserContext{_LocalId=none; _RemoteId=(ActionManager)SYSTEM})] [] []
[DEBUG] [01/30/2014 09:31:23.043] [1340] [ZenworksWindowsService] [7] [] [ZenCache] [] [DeleteFiles called for (printer policy#a28de4fd34cc3954a2f1cc34ade106cd~3d896697a8346944869a3d896697a834_printer policy.xml, UserContext{_LocalId=none; _RemoteId=(ActionManager)user})] [] []
[DEBUG] [01/30/2014 09:31:28.394] [1340] [ZenworksWindowsService] [52] [] [ZESMEnterprisePolicySettings] [] [Is all the ZESM Policies accepted by ZID:true] [] []
[DEBUG] [01/30/2014 09:31:28.394] [1340] [ZenworksWindowsService] [52] [] [ZESMEnterprisePolicySettings] [] [Is all the ZESM Policies enforced by ZID:true] [] []
[DEBUG] [01/30/2014 09:31:28.394] [1340] [ZenworksWindowsService] [52] [] [ZESMEnterprisePolicySettings] [] [ZID Current status:Enforced - Feature is operating normally last time it was loaded or currently.] [] []
[DEBUG] [01/30/2014 09:30:03.311] [2864] [ZenUserDaemon] [1] [] [DeviceGuid] [] [Irrecoverable error!!! Error in creating Device Session.] [] []
[DEBUG] [01/30/2014 09:31:16.818] [2512] [ZenUserDaemon] [1] [] [ZenCache] [] [SqliteConnection:Setting for Asynchronous IO operation to sqlite DB read from registry is null so setting it to default to true] [] []
[DEBUG] [01/30/2014 09:31:35.180] [4216] [explorer] [1] [] [ZenCache] [] [SqliteConnection:Setting for Asynchronous IO operation to sqlite DB read from registry is null so setting it to default to true] [] []
[DEBUG] [01/30/2014 09:31:40.515] [2512] [ZenUserDaemon] [1] [] [DeviceGuid] [] [Irrecoverable error!!! Error in creating Device Session.] [] []
[DEBUG] [01/30/2014 09:31:40.515] [2512] [ZenUserDaemon] [1] [] [DeviceGuid] [] [Irrecoverable error!!! Error in creating Device Session.] [] []
[DEBUG] [01/30/2014 09:37:04.075] [1340] [ZenworksWindowsService] [17] [] [Full Disk Encryption Module] [] [Module statusStarted] [] []
Labels (2)
0 Likes
12 Replies
Highlighted
Absent Member.
Absent Member.

Re: zenworksuserdaemon.exe command windows hangs

Actually, part of that is incorrect. I meant to say ZenWindowsDaemon not ZenworksUserDaemon.

So, correct info is that ZenWindowsDaemon.exe is opening a black command window and hanging for 5+ minutes before exiting.

Thanks,

Adam
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: zenworksuserdaemon.exe command windows hangs

Apitt,

looking at bugzilla, there are a couple of times this error has been
seen, but it should be fixed - so I am going to suggest that you open a
SR

--

Shaun Pond


0 Likes
Highlighted
Absent Member.
Absent Member.

Re: zenworksuserdaemon.exe command windows hangs

Apitt,
Did you by chance find an answer to this issue? I am seeing the same items in my deployment. I have been trying to track down an issues with my Windows 7 systems which is causing the systems to hang. I just remoted in to a laptop that just BSOD and looked in the zmd-messages log and found around the same time an error reporting back

ZenWindowsDaemon [1] [ ] [DeviceGuid] [ ] [Irrecoverable error !!! Error in creating Device Session]
[DAUHelper] [1] [ ] ZenCommon] [ ] [ Failed to find sid in local accounts. looking in AD accounts]

This almost acts like a Microsoft Update is causing this. I don't seem to see this until after the latest (Dec or Jan) updates have been installed.

I had a fellow Tech look at my setup and am confident that I don't have a eDir issue or a problem with my core services.

Not even sure this is related since I am still trying to determine what might be causing the issue.

Thanks for any update you can provide.

Richard
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: zenworksuserdaemon.exe command windows hangs

Both of those errors are just noise in the logs.
They can occur during normal operations.

On 2/5/2014 10:56 PM, rhuhman wrote:
>
> Apitt,
> Did you by chance find an answer to this issue? I am seeing the same
> items in my deployment. I have been trying to track down an issues with
> my Windows 7 systems which is causing the systems to hang. I just
> remoted in to a laptop that just BSOD and looked in the zmd-messages log
> and found around the same time an error reporting back
>
> ZenWindowsDaemon [1] [ ] [DeviceGuid] [ ] [Irrecoverable error !!! Error
> in creating Device Session]
> [DAUHelper] [1] [ ] ZenCommon] [ ] [ Failed to find sid in local
> accounts. looking in AD accounts]
>
> This almost acts like a Microsoft Update is causing this. I don't seem
> to see this until after the latest (Dec or Jan) updates have been
> installed.
>
> I had a fellow Tech look at my setup and am confident that I don't have
> a eDir issue or a problem with my core services.
>
> Not even sure this is related since I am still trying to determine what
> might be causing the issue.
>
> Thanks for any update you can provide.
>
> Richard
>
>


--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: zenworksuserdaemon.exe command windows hangs

Still no resolution to this. Our computers don't have the latest windows updates on them. They were last updated in september-ish. This problem didn't appear until we updated our servers to 11.2.4
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: zenworksuserdaemon.exe command windows hangs

Updated to 11.3.1 FTF Roll UP 1 and are still getting this window just staying open indefinitely.

Where should i even begin looking? Which log files might enlighten me?
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: zenworksuserdaemon.exe command windows hangs

This is not a known issue.
Not sure why this is happening in your environment.
I would recommend an SR.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
Highlighted
New Member.

Re: zenworksuserdaemon.exe command windows hangs

apitt;2341056 wrote:
Updated to 11.3.1 FTF Roll UP 1 and are still getting this window just staying open indefinitely.

Where should i even begin looking? Which log files might enlighten me?




Did you ever get a resolve for this?

I have this issue as well.

Patrick
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: zenworksuserdaemon.exe command windows hangs

Patrick,

We never found a resolution. We recently had to deploy a secure browser for Measured Progress testing for our students and that secure browser will not run with that ZenWindowsDaemon.exe open so we had to train the staff to tell their students to make sure that minimized window is closed before trying to do their State Tests. Lovely.

Someday it will just quietly disappear forever if we're lucky.


Adam
0 Likes
Highlighted
New Member.

Re: zenworksuserdaemon.exe command windows hangs

apitt;2415752 wrote:
Patrick,

We never found a resolution. We recently had to deploy a secure browser for Measured Progress testing for our students and that secure browser will not run with that ZenWindowsDaemon.exe open so we had to train the staff to tell their students to make sure that minimized window is closed before trying to do their State Tests. Lovely.

Someday it will just quietly disappear forever if we're lucky.


Adam



I may have at least for now, worked around my issue. I hope...I have not seen the message for a couple days.

I have a primary bundle that runs on every login. It has 18 Install procedures, and 3 Launch procedures. I started disabling each until it went away. At the moment it appears be a Launch process causing the issue. I narrowed it down to a specific launch process that successfully finishes, however keeps the zenwindowsdaemon.exe cmd open.

I had a launch exe process set to run the following:

C:\Utilities\BGInfo\Bginfo.exe /timer:0 /NOLICPROMPT C:\utilities\bginfo\config.bgi

Of course it was carved up so the commands were on the parameters line.

Once I disabled this, I have not seen the issue. So...as a work around, I moved the call to launch the bginfo / EXE to the RUN key in the registry instead.

I will let you know if it comes back.

Patrick
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: zenworksuserdaemon.exe command windows hangs

Patrick,

Thanks, that was it. All this time and it was one little run on login bundle.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.