123newton Absent Member.
Absent Member.
1170 views

Facing issues with iManager 2.7.7 patch7

Hi,

After installing iManager 2.7.7 patch7.
Not able to save the changes, after hitting the save button its rotating and logout automatically.

And another issue while trying to install plugins from Configure-->Plugin Installation --> Available plugins.
As soon as i hit install, its showing plugin installed but not able to view in Roles and Tasks.

eDirectory : 8.8.8 patch7
iManager : 2.7.7 patch7

Thanks in Advance,
Labels (1)
0 Likes
4 Replies
Knowledge Partner
Knowledge Partner

Re: Facing issues with iManager 2.7.7 patch7

I am going to guess this has to do with a bug in iManager where it does
not handle redirecting properly from HTTP to HTTPS, which happens when
trying to get plugins. While that's annoying enough, my fear is that
iManager actually removes the old plugin before putting the new one in
place, and if it removed the old framework plugin then who knows what
could be broken.

You have at least two ways forward, three if you can restore iManager from
a backup:

1. Get iManager Workstation on your workstation; it's a great tool to
have anyway for when iManager servers go crazy.
2. Try to add the framework plugin via manual download and then upload to
iManager, then install that. Hopefully there is enough intact that it
will go ahead and put those files in place and be as good as new.

Alternatively, reinstall iManager and only add plugins, including the
framework ones, manually by downloading to your workstation then
uploading, or downloading to the server using 'curl'.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Facing issues with iManager 2.7.7 patch7

While Bug# 1039588 is getting fixed, if you end up with those pesky
zero-byte files instead of valid NPMs, you could copy the
iman_mod_desc.xml file, change all of the links within to 'https', and
then see if pointing to that with iManager fixes things. Testing on my
end seems to suggest this helps:

Like this: http://a2btech.com/tmp/iman_mod_desc.xml


--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.
0 Likes
shesser Absent Member.
Absent Member.

Re: Facing issues with iManager 2.7.7 patch7

I downloaded the plugin's in question from https://www.netiq.com/support/imanager/plugins/. Then in iManager under configure, plug-in installation, available plug-ins, I added the downloaded npm files. Once completed, back under available modules, I checked the boxes and they installed fine. It's a work around until they fix the issue. I believe the 3 I needed were pki.npm, nmas.npm and eDir_88_iMan27_Plugins.npm.
0 Likes
123newton Absent Member.
Absent Member.

Re: Facing issues with iManager 2.7.7 patch7

Thanks ab, will install the framework plugin.
And Will reinstall iManager server. If not will use iManager workstation.


Thanks.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.