Anonymous_User Absent Member.
Absent Member.
456 views

Help with Qlikview


Hi everyone,

Our client have requested an Integration between eDirectory and
Qlikview, some interesting tool. As far as I know it is supposed to be
able to authenticate with any LDAP Server, such as our beloved
eDirectory 😮 , but so far I've only achieved to "authenticate", using a
Proxy user, with the eDirectory in the Configurable LDAP tab first
settings. :rolleyes: Any other user we want to log into Qlikview fails
to do so.

Does anyone had some experience with this appliance that can give some
pointers? :confused:

It's just the first step in our to do list =/ We still have to make SSO
with Access Manager... Which I'm not sure it will be an easy task. 😞

Best regards.


--
KeinPashrek
------------------------------------------------------------------------
KeinPashrek's Profile: https://forums.netiq.com/member.php?userid=2228
View this thread: https://forums.netiq.com/showthread.php?t=42672

Labels (1)
0 Likes
7 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Help with Qlikview

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Turn up LDAP tracing on the appropriate LDAP Server object in eDirectory
under the tracing/screen options section; enable everything and save
that. Once done, use ndstrace to see what is happening between eDir and
the application:

ndstrace
set dstrace=nodebug
dstrace +time +tags +nmas +ldap +auth
dstrace file on
set dstrace=*r
<perform tests here>
dstrace file off
quit

See what you have in the ndstrace.log file and post it here so we can
help you.

Good luck.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

iQIcBAEBAgAGBQJQa5dDAAoJEF+XTK08PnB5r7kQALFxMa+rM+/pNJ9zxu7+ptw1
SwEW7K+2DbvvoqSwBRN7kbd/GpXAL8xYxLQkiiHaW78phMj0v44M8xqNNEyKJ3kd
oHNHXoWVm+GLw+pA9XemHsAOLW/SCNp0QP+/bYXKQtJtLAW05A8PyZ/2fjxCkTmQ
8JyaSo4bwCRV4xt8Peo+e8XNt8w29UAsjPU2JMr8KESHYCVJofXnCQC1O4u+0vl3
4Mzvz/JQJQdJcqqmHCH8dpQduvL2iklVX375EUGv6GPUdtjJQ1oxB+2I0uvNae6/
0M3toLcByby9vqHgZhh22pGOMPweApz1SYLa9zpb3xeWhfcdrMXZ4KMsJTMB4Avk
g1iBvkgaMTaw+zYXvWr67hOVvwjYIq5Gamy7OVjBxIjdxyyk379CzrftRLWvuYn7
8t/EEPoeJUgzNbfJIVD2GObsOinikVXONH45jPK5QD0e6klX7yc3NjQmMYuUnCN0
99dtCFYDRHbutbOYoahbz46BMK+2uVSW/BwRhj9QzarkoEBtJzCvQsMqLHXjf1Xn
m5BKBsoZspUV1KgGxChtkHyt7gw+YJ7yS37q7ephBA63PlttkUlKPrahxOJysXn3
4BmdHyYMuyUzzL+fJrZp01hnETH6zhjDoPE64Jmb8c0qh7Mh/bDLXWMCgQL3w1Mp
HQDdGT6xGwimVI4OpuzJ
=M+jM
-----END PGP SIGNATURE-----
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Help with Qlikview


Thanks a lot for answering!! 😄

I'll set this up for the tests we'll have shortly.

Greetings.


--
KeinPashrek
------------------------------------------------------------------------
KeinPashrek's Profile: https://forums.netiq.com/member.php?userid=2228
View this thread: https://forums.netiq.com/showthread.php?t=42672

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Help with Qlikview


Hi,

On every test we got this answer:

3400275728 LDAP: [2012/10/03 10:12:09.35] New cleartext connection
0x77229680 from 172.21.18.251:17893, monitor = 0xffffffffba1de710, index
= 1
3397117712 LDAP: [2012/10/03 10:12:09.35]
(172.21.18.251:17893)(0x0003:0x60) DoBind on connection 0x77229680
3397117712 LDAP: [2012/10/03 10:12:09.35]
(172.21.18.251:17893)(0x0003:0x60) Bind
name:cn=socex_proxy,ou=proxys,ou=socex,ou=aplicaciones,o=sat ,
version:3, authentication:simple
3397117712 AUTH: [2012/10/03 10:12:09.35] [0001908d]
<.socex_proxy.PROXYS.SOCEX.APLICACIONES.SAT.MIDSD-TREE.>
*LocalLoginRequest. Error success, conn: 17.
*3397117712 LDAP: [2012/10/03 10:12:09.36]
(172.21.18.251:17893)(0x0003:0x60) Sending operation result 0:"":"" to
connection 0x77229680
3406591760 LDAP: [2012/10/03 10:12:12.351]
(172.21.18.251:17893)(0x0004:0x42) DoUnbind on connection 0x77229680
3406591760 LDAP: [2012/10/03 10:12:12.351] Connection 0x77229680
closed

We tried with another user and sends the same thing.

Hope this can help.

Greetings.


--
KeinPashrek
------------------------------------------------------------------------
KeinPashrek's Profile: https://forums.netiq.com/member.php?userid=2228
View this thread: https://forums.netiq.com/showthread.php?t=42672

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Help with Qlikview

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Assuming all material pieces are the same (specifically after the bind
you see 'Sending operation result 0' then the LDAP side is accepting the
credentials and from there Qlikview is rejecting your login. This trace
shows exactly the following:

Connection from 172.21.18.251 (cleartext, not SSLized)
Binding as cn=socex_proxy,ou=proxys,ou=socex,ou=applicationes,o=sat
using a password.
Authentication successful.
Connection closed.

Good luck.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

iQIcBAEBAgAGBQJQbGtNAAoJEF+XTK08PnB5l6oP/AleMSr7uNZeS4mkTMyyU+q5
VIiNSTBhJdFBUrNWtufBrIOg4QSvvxjV0PHhuSHyI2S16gCbAOlvl3IsOhmNQ7xd
WXCh08azfB28PSuENLPt+wiRitD61aWLVXp9WAkWJpVGh45s80KQv4hhxjx2xQla
jwFy4xMtyLzivc9qs2yv7naZAYmlcdlF19T2P0BgCLjNrKCEB5O7aqxcZa9UyN/i
df599w++JgXiAMdZ1wSuY/YYVfgifiVkkSnYZBuD4F/69Yt5AxxU98Gvd9P6fzRy
zZ5rkzTIyISDjf+spLzK0gBWgEdXBOcnDrTTA/CNU/9v1TGBTo5Y6iZgSPvi181l
kvS/p3aEOahOdJZKce6JzwT5sYKZBcNbj+pm6GgUuTb9xzb53SHpbqD4p5QWp9IU
zf++CYW3l92IG5ctxE+h4hLG5gI5UvKBTUZJTvVNQOotHFpJ9BJzidIvli3833b/
FYuGt0zDThH7aGe7B7u0pZ2cKan8hKndShK2rtWhd5+MqzzxGIOlMLvSlSZ/6dwG
zM+aSexVckE2GY/S6F4wyqxUmKA0EUnbSdbQyRwgMINo+MDzJOlSthuhqF5/T8nK
DhXwOFPAKEcXqst2JtnQ16zbmMrKXg0wGMQ3XqfHQdXNVLoDtLbml/78Z1mj0dnO
x/AJFNwMpC3lsze+Imc0
=IRu9
-----END PGP SIGNATURE-----
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Help with Qlikview


Hi, thanks for answering!!

Ok yes, we can see when it fails to authenticate to eDirectory, yet we
just can't seem to log into Qlikview even with all the DSTrace flags
enabled, it looks that it can't past QV but it doesn't have any sort of
loggin logs due it leaves everything to the LDAP Server. The QV
consultant will check with his support team to see if they can help us
out, to anyone that have actually connect to any other LDAP excluding
AD. I'll feedback any advance we have.

Best regards!!


--
KeinPashrek
------------------------------------------------------------------------
KeinPashrek's Profile: https://forums.netiq.com/member.php?userid=2228
View this thread: https://forums.netiq.com/showthread.php?t=42672

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Help with Qlikview

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

> Ok yes, we can see when it fails to authenticate to eDirectory, yet
> we


Just to be clear, you have a trace of the login failing to eDirectory,
or do you mean the login to Qlikview is failing when using eDirectory as
the backend?

If Qlikview cannot figure this out other things we could do is compare
LDAP traces (LAN traces, if unencrypted) when authenticating to
something else such as MAD with the same user to see how things differ.
I doubt we'll see anything else at this point since there's nothing
besides a bind happening, but in that case I can't figure out what could
be wrong.

Good luck.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

iQIcBAEBAgAGBQJQbOu+AAoJEF+XTK08PnB599YP/0TPpuanvOEUf8aytOeFjFOp
tCqV1DEveDZGZNe8bNyYn8maKQa2pdhi7BVDQr9EiKbCUKqsbU/UL+5cYZprCeFY
neMVWS/cxTljd7MyNXU2vbr/W2eNs/98+QhW+Mf35oSsDyxz9QnS2d22IwLjjukw
ubrMwrfrJpmBcmSstDz3XjEgjRSKLVIAbDcXbMDLqTQa/i604wW7WByk0Sa0TtHA
w7hvmY7jRs6P2kClTu0uLCUE4Y2Rg0+4KS18EGeaQJ2mXjwoL94hcgKEZpoZJDBz
kPm/duuYFVWKVdIhAVRPzJscgDPQHPlvDjwMH2MdUhMa2Kty/QgDCA9Hd9OccPhx
ZpJuz/5l0qP9UueZjWZhWcAwQOE9ACwCjS5gOYJi3dT2QXs06zwI4arKnfgZsRyS
j+rOrbHtTe6vUHDqmC1BL1/LBXrStMgHDLRPK8tKyszi4ytHMpRN96hD3ozGQ3iK
Wup0oJjreqqFx4dPJCvEnYFyv0sSVaiMcggWB4ZUzx7svAsD4CQkQ92LFVx47Clv
Oa7uv4MlaQl8io22QC/f7ydNUmMBmC30+ehAi+JoeXY0MjEl6xNGGTdD/ALF1Ecy
a6S6/L3v+GxcazJGFSpxODoIQw2V19/SZ0/BZqlAsJpYsQUAh/zdTZdgtsPf9dmr
w/FiwD5FIXVFDZs7FPeJ
=fRSz
-----END PGP SIGNATURE-----
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Help with Qlikview


Hi!!

By failing I mean, I do have a trace of the login failing to eDirectory
but, from Qlikview.
It was one of the first tests we made in order to check if Qv could
actually reach the eDirectory, the server is in another State away from
where we are. Also it was useful to check the correct syntax for the
PATH configuration.

Hope we can get more, thanks for answering!!

Greetings


--
KeinPashrek
------------------------------------------------------------------------
KeinPashrek's Profile: https://forums.netiq.com/member.php?userid=2228
View this thread: https://forums.netiq.com/showthread.php?t=42672

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.