Anonymous_User Absent Member.
Absent Member.
691 views

Migrate data into the IDV: buttons of window not working iMa


Hi,

I am using iManager 2.7.7.

I am trying to migrate users from one eDir to other for this wrote
driver.
as per process when i am trying to select class to migrate, to click
"Edit List" button but this button is not working even none of buttons
are working in this window.

Process is:
1) Login iManager 2.7.7
2) click on "Identity Manager Overview".
3) Click Driver Set
4) Select your migration driver.
5) on right panel click on "Migrate" drop down and choose "Migrate data
into the ID".

new pop up window will open.
under this window none of buttons working probably JS issue.
tried Firefox 19.x IE 8, Chrome 29.x but same issue.

same thing is working with iManage 2.7.6.


Please help how can i use this functionality

Thanks,
Vaibhav


--
vaibhavkhare
------------------------------------------------------------------------
vaibhavkhare's Profile: https://forums.netiq.com/member.php?userid=5266
View this thread: https://forums.netiq.com/showthread.php?t=49688

Labels (1)
0 Likes
8 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Migrate data into the IDV: buttons of window not working iMa

This is an Identity Manager (IDM) question, really.

You cannot do a migrate-into with the original eDirectory drivers.
Instead go to the other side's driver and do a 'Migrate From' and you'll
be set. If you want to do that for all users you could just migrate the
container of those objects (all objects allowed by the filter will be
migrated). Otherwise the next-easiest way to do this is with a one-liner
in bash. If the options above (use the sending tree to migrate, not the
receiving) do not work post more about exactly which objects you want to
migrate (their context, their class(es)), and we can probably help you get
the script needed.


--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Migrate data into the IDV: buttons of window not working iMa


Thanks for your reply.

mine issue is not related to migrate users from one LDAP to other.
issue is one of iManager window's buttons not working.
as i mentioned on my post with previous version i was able to do the
same steps, but with iManager 2.7.7 not.
Here i am applying same steps was tested in previous iManager (i.e.
2.7.0).

Regarding migration:
I need migration of one class only with option migrate into identity
vault.


Thanks,
Vaibhav



ab;239161 Wrote:
> This is an Identity Manager (IDM) question, really.
>
> You cannot do a migrate-into with the original eDirectory drivers.
> Instead go to the other side's driver and do a 'Migrate From' and
> you'll
> be set. If you want to do that for all users you could just migrate
> the
> container of those objects (all objects allowed by the filter will be
> migrated). Otherwise the next-easiest way to do this is with a
> one-liner
> in bash. If the options above (use the sending tree to migrate, not
> the
> receiving) do not work post more about exactly which objects you want
> to
> migrate (their context, their class(es)), and we can probably help you
> get
> the script needed.
>
>
> --
> Good luck.
>
> If you find this post helpful and are logged into the web interface,
> show your appreciation and click on the star below...



--
vaibhavkhare
------------------------------------------------------------------------
vaibhavkhare's Profile: https://forums.netiq.com/member.php?userid=5266
View this thread: https://forums.netiq.com/showthread.php?t=49688

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Migrate data into the IDV: buttons of window not working iMa

Ah, I see. You may be experiencing Bug# 826026 which is worked-around
with instructions in TID# 7012959 until the plugins are all updated. Give
that TID a try and let us know if it helps or not, please.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Migrate data into the IDV: buttons of window not working iMa

ab wrote:

> Ah, I see. You may be experiencing Bug# 826026 which is worked-around
> with instructions in TID# 7012959 until the plugins are all updated.
> Give that TID a try and let us know if it helps or not, please.


Just a note: Aaron is referring to this article
https://www.netiq.com/support/kb/doc.php?id=7012959

The TID is written with the assumption that you have installed iManager
on linux. The procedure also works if you have a windows-based iManager
install - however the paths and command lines differ.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Migrate data into the IDV: buttons of window not working iMa


FWIW I experienced the same problem in iManager 2.7.7 on RHEL 5.10 when
trying to Migrate Into Identity Vault. The first pop-up window would
come up correctly, but when clicking on the "Edit List" or any other
button in that window, nothing would happen. Firebug showed that the
Javascript being invoked was undefined. That's when I went searching on
the forums and found this thread. I'm not sure that the Migrate
function would fall under the category of an iManager plugin though...?


--
brucetimberlake
------------------------------------------------------------------------
brucetimberlake's Profile: https://forums.netiq.com/member.php?userid=1036
View this thread: https://forums.netiq.com/showthread.php?t=49688

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Migrate data into the IDV: buttons of window not working iMa

brucetimberlake wrote:

>
> FWIW I experienced the same problem in iManager 2.7.7 on RHEL 5.10
> when trying to Migrate Into Identity Vault. The first pop-up window
> would come up correctly, but when clicking on the "Edit List" or any
> other button in that window, nothing would happen. Firebug showed
> that the Javascript being invoked was undefined. That's when I went
> searching on the forums and found this thread. I'm not sure that the
> Migrate function would fall under the category of an iManager plugin
> though...?


The interface to trigger a "migrate into IDV" is implemented as an
imanager plugin. So yes, you likely have the same issue.

Once you are finished specifying the criteria to migrate, then the
iManager plugin injects a specially formatted XDS query document into
the IDM event cache for this connected system and the engine processes
that triggering a "migrate into IDV" for any objects in the connected
system which are matched by the query.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Migrate data into the IDV: buttons of window not working iMa


I am having the same problem. I have followed carefully the
instrucitions in the below references article but all that results in is
a non-functioning iManager install. Tomcat starts, but the /nps instance
does not.

alexmchugh;239229 Wrote:
> ab wrote:
>
> > Ah, I see. You may be experiencing Bug# 826026 which is

> worked-around
> > with instructions in TID# 7012959 until the plugins are all updated.
> > Give that TID a try and let us know if it helps or not, please.

>
> Just a note: Aaron is referring to this article
> https://www.netiq.com/support/kb/doc.php?id=7012959
>
> The TID is written with the assumption that you have installed iManager
> on linux. The procedure also works if you have a windows-based iManager
> install - however the paths and command lines differ.



--
keithbmartin
------------------------------------------------------------------------
keithbmartin's Profile: https://forums.netiq.com/member.php?userid=524
View this thread: https://forums.netiq.com/showthread.php?t=49688

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Migrate data into the IDV: buttons of window not working iMa

keithbmartin wrote:

>
> I am having the same problem. I have followed carefully the
> instrucitions in the below references article but all that results in
> is a non-functioning iManager install. Tomcat starts, but the /nps
> instance does not.


You most likely have incorrectly edited the web.xml file for the nps
instance.

Did you make a backup of this file before editing it? If so, when you
restore the backup file - does iManager start?

Otherwise - could you post a snippet of your web.xml file (the portion
you edited).
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.