Highlighted
Absent Member.
Absent Member.
863 views

NetIQ eDirectory Agent Closed


As I can only find old threads on this issue, and still no one with a
solution, I'll create a new thread...

Scenario:
- New Windows Server 2012 R2 (64 bit)
- Installed eDir 8.8 SP8 Patch 5

eDirectory is up and running, netstat is showing server is listening on
524 and other servers sees it as Up. Though the eDirectory Services in
Control Panel indicates it's closed so we're not able to administer, or
run dsrepair etc.
- Are there different ways to view this information, needed rights or
someway to enable viewing information correctly??

Other things I see when comparing to another Windows 2003 server
(running an older version of eDir):
- "_NetIQ_eDirectory_Services_" in Control Panel is
_not_showing_the_server_name_ in its header
- -Server Field- states: [NetIQ eDirectory Agent Closed] and no services
are shown
We've checked that the service is set to interact with desktop and have
tried restarting eDir, but no changes.

I was wondering if the change of name in services would have something
to do With it ("x63 NDS..." instead of just "NDS..."), but as this is an
old thread I guess it must be something else...

Anyone have found a solution to this??

regards,
Patrick


--
pfronteri
------------------------------------------------------------------------
pfronteri's Profile: https://forums.netiq.com/member.php?userid=9685
View this thread: https://forums.netiq.com/showthread.php?t=53738


Patrick Frontéri # GroupWiseR of Norway # Active part of the OpenHorizons and NetworkPartners.no Collaboration
Labels (1)
0 Likes
6 Replies
Absent Member.
Absent Member.

Re: NetIQ eDirectory Agent Closed


BTW: This is a VMware server and we have the same result either using
RDP or vSphere client to view console.

At the moment there are no replica on the server, as it's a test server,
but all other servers see the new server and sync is fine.

:-Patrick


--
pfronteri
------------------------------------------------------------------------
pfronteri's Profile: https://forums.netiq.com/member.php?userid=9685
View this thread: https://forums.netiq.com/showthread.php?t=53738


Patrick Frontéri # GroupWiseR of Norway # Active part of the OpenHorizons and NetworkPartners.no Collaboration
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: NetIQ eDirectory Agent Closed

If your other servers can communicate with this one, or if you can using
an external client (NDAP or LDAP), then the message in windows is wrong
and you can probably ignore it. Chances are rights at some level are
preventing you from seeing what you expect, so maybe you need to become
'Administrator' and not just some lower level member of a powerful group.

One of the reasons that eDirectory on windows is so hard is because of
issues like this one. The other platforms are better-suited to hosting
services, and eDirectory is a service, so things just get along better.

The name of the service itself is irrelevant.

You may want to look at the service definition to see which user is
configured to run the service; if you become that user then perhaps things
will show up better. If that user is SYSTEM (thus somebody as whom you
cannot login directly) perhaps try changing it to a regular user, although
keep in mind that right now things are (mostly) working, and you may break
t by doing this kind of thing.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: NetIQ eDirectory Agent Closed


why don't you try to put a replica on the new server?, if the sync is
ok, then I think it is running like it should?


--
paulvandercruyssen
------------------------------------------------------------------------
paulvandercruyssen's Profile: https://forums.netiq.com/member.php?userid=61
View this thread: https://forums.netiq.com/showthread.php?t=53738


0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: NetIQ eDirectory Agent Closed

pfronteri wrote:

>
> We've checked that the service is set to interact with desktop and have
> tried restarting eDir, but no changes.
>
> I was wondering if the change of name in services would have something
> to do With it ("x63 NDS..." instead of just "NDS..."), but as this is an
> old thread I guess it must be something else...
>
> Anyone have found a solution to this??



Have you looked in the readme?
https://www.netiq.com/documentation/edir88/edir888_windows_readme/data/edir888_windows_readme.html#bjqwx5t

Try re-enabling the "interactive services detection" function of the OS and see if your problem goes away. I suspect it might.
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: NetIQ eDirectory Agent Closed

On 6/23/2015 2:58 AM, pfronteri wrote:
> Though the eDirectory Services in
> Control Panel indicates it's closed so we're not able to administer, or
> run dsrepair etc.
> - Are there different ways to view this information, needed rights or
> someway to enable viewing information correctly??


When you launch the interface from the control panel, be sure to right click and choose Run as Administrator.
Without this, even when logged in as an administrator, the applet frequently fails.

--
-----------------------------------------------------------------------
Will Schneider
Knowledge Partner http://forums.netiq.com

If you find this post helpful, please click on the star below.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: NetIQ eDirectory Agent Closed

Will Schneider wrote:

> On 6/23/2015 2:58 AM, pfronteri wrote:
> > Though the eDirectory Services in
> > Control Panel indicates it's closed so we're not able to administer, or
> > run dsrepair etc.
> > - Are there different ways to view this information, needed rights or
> > someway to enable viewing information correctly??

>
> When you launch the interface from the control panel, be sure to right click and choose Run as Administrator.
> Without this, even when logged in as an administrator, the applet frequently fails.


I tried this on my VM running Windows 2012 R2 and eDire 8.8 SP8 patch 5.
It didn't help in that scenario. I still was not able to run dsrepair or load/configure other dlms which have a separate UI.
(but has helped on older windows - for example Windows 2008 R2)

The main cause for the different behaviour seems to be the change in the interactive services detection (as I mentioned in my prior reply. This is highlighted in the readme).
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.