Highlighted
Knowledge Partner
Knowledge Partner
399 views

Replica add stuck on -603 and -608 on the destination server.

A largely NetWare based tree (if its not broke, why fix it?) for a
school (so no SRs available), with oldest eDir being 10554.34

In February the first OES (11.2) server was introduced, naturally after
making sure eDir was healthy (did have to fix a few things but nothing
major needed). What I didn't get to at the time was to make this new
box the master, though it does have a full R/W replica of both
partitions)
We added another OES 11.2 server, but I get the -603 and -608 errors as
soon as it goes 'new'. I can't back out this partition operation.
I've done the -XK2 route to get it out of the ring a few times already,
including having done a couple rebuilds of the server.
The local guys have run Unattended full DSRepairs since I put in that
first server, apparently I didn't smack them hard enough back in
February.

I did find a reference to an OES2 problem, but there are no and not
been such beasts on this network.
The unattended repair was the most catastrophic thing to happen to this
tree in any memory of it.
I have shifted the Master of Root to the first OES 11.2 server
I created a test box that is a basic OES11.2 server in its own tree and
I could do a schema comparison between it, but for some reason
iManager's ICE doesn't like any of the DER files I have extracted that
have otherwise worked elsewhere. So actual imports haven't been done,
not that the differences make any sense to me.
http://www.konecnyad.ca/andyk/kp/schemacompare.ldif

running a ndstrace on the OES11.2 master with +scma +scmd +sync
I am seeing 'lots' (~ once every 5 seconds or so, more than other trees
I've looked at for this) of
**Processing incoming value for attribute .Transitive Vector.[Attribute
Definitions].[Schema Root]
but haven't been able to nail down any meaning of that, pushes my eDir
learning as I don't know how to check the state of that on each local
replica without dsbrowse for the OES boxes.


Andy Konecny
KonecnyConsulting.ca in Toronto
----------------------------------------------------------------------
Andy's Profile: https://forums.netiq.com/member.php?3330-konecnya
If you find a post helpful, please show your appreciation by clicking
on the star below it. Thanks!

___
“i’ve sworn an oath of solitude til the blight is purged from these lands”
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
Labels (1)
0 Likes
5 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: Replica add stuck on -603 and -608 on the destination server.

On 08/24/2015 01:42 PM, Andy Konecny wrote:
> In February the first OES (11.2) server was introduced, naturally after
> making sure eDir was healthy (did have to fix a few things but nothing
> major needed). What I didn't get to at the time was to make this new
> box the master, though it does have a full R/W replica of both
> partitions)
> We added another OES 11.2 server, but I get the -603 and -608 errors as
> soon as it goes 'new'. I can't back out this partition operation.
> I've done the -XK2 route to get it out of the ring a few times already,


XK2 does not remove a server from a ring at all, so maybe that's your new
problem. The XK2 process only modifies the server on which it is run,
specifically removing all replicas, but you then need to go to other
servers in the affected replica rings (potentially all servers in all
rings if things do not synchronize properly) and clean the replica rings
of this now-XK2-ing server. You should do this while the XK2 process
still has the DIB locked. If you do not do this, you are causing yourself
more problems.

> including having done a couple rebuilds of the server.
> The local guys have run Unattended full DSRepairs since I put in that
> first server, apparently I didn't smack them hard enough back in
> February.


Give up on Unattended repairs forever. This is not a drill, or a joke.
Either repair specifically what is wrong, using repair options that are
meant to fix it, or leave repairs out of the picture.

> running a ndstrace on the OES11.2 master with +scma +scmd +sync
> I am seeing 'lots' (~ once every 5 seconds or so, more than other trees
> I've looked at for this) of
> **Processing incoming value for attribute .Transitive Vector.[Attribute
> Definitions].[Schema Root]
> but haven't been able to nail down any meaning of that, pushes my eDir
> learning as I don't know how to check the state of that on each local
> replica without dsbrowse for the OES boxes.


iMonitor can be used to compare schema between servers in a replica ring.
Using this is the best way of which I am aware to compare schema between
servers to look for major/minor differences. Some differences are
less-critical than others. If you are lacking certain classes entirely
from certain servers, though, then that will cause replication problems,
so that is likely where you currently stand.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Replica add stuck on -603 and -608 on the destination server.

In article <ZMYCx.469$In6.255@novprvlin0914.provo.novell.com>, Ab wrote:
> The XK2 process only modifies the server on which it is run,
> specifically removing all replicas, but you then need to go to other
> servers in the affected replica rings (potentially all servers in all
> rings if things do not synchronize properly) and clean the replica rings
> of this now-XK2-ing server. You should do this while the XK2 process
> still has the DIB locked. If you do not do this, you are causing yourself
> more problems.

Shows how tired I was as I wrote that, as while the XK2 was running, I
removed the server from the ring on the master. The one thing that was a
little concerting was that I didn't see a clear locking of the DIB as I had
when I had last done this sort of thing on NetWare. Perhaps the command I'm
using isn't entirely correct ndsrepair -R -Ad Xk2


> Give up on Unattended repairs forever. This is not a drill, or a joke.
> Either repair specifically what is wrong, using repair options that are
> meant to fix it, or leave repairs out of the picture.


I certainly have long given up on those, it was the local guys who are
getting a repeated smacking for having run it after I told them in February
that it was past tense.


> iMonitor can be used to compare schema between servers in a replica ring.
> Using this is the best way of which I am aware to compare schema between
> servers to look for major/minor differences. Some differences are
> less-critical than others. If you are lacking certain classes entirely
> from certain servers, though, then that will cause replication problems,
> so that is likely where you currently stand.


The challenge here will be that iMonitor is not functional on all the
NetWare boxes. <sigh> the 'fun' of having to clean up stuff that was never
bothered with. </sigh>


Andy Konecny
KonecnyConsulting.ca in Toronto
----------------------------------------------------------------------
Andy's Profile: https://forums.netiq.com/member.php?3330-konecnya
If you find a post helpful, please show your appreciation by clicking on the
star below it. Thanks!

___
“i’ve sworn an oath of solitude til the blight is purged from these lands”
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Replica add stuck on -603 and -608 on the destination server.

Andy Konecny wrote:

> NetWare


Are you time-travelling to your customer? 🙂
______________________________________________
https://www.is4it.de/identity-access-management
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Replica add stuck on -603 and -608 on the destination server.

In article <xn0jqjuez3e7njt00t@nntp.suse.com>, Lothar Haeger wrote:
> Are you time-travelling to your customer? 🙂


Nope, there really is a lot of NetWare still out there in production as
'it just works'
this case is a private school and they are cheap, if it isn't broken,
don't fix it.

mind you this case is the only one of mine that still has a majority on
NetWare. All the other just have bits here and there doing things they
just haven't gotten around to getting on a newer platform, or are
keeping it around to get at old data media "just in case" such as
ARCserve tapes where we discovered restore to OES Linux issues for
stuff backed up from NetWare.



Andy Konecny
KonecnyConsulting.ca in Toronto
----------------------------------------------------------------------
Andy's Profile: https://forums.netiq.com/member.php?3330-konecnya
If you find a post helpful, please show your appreciation by clicking
on the star below it. Thanks!

___
“i’ve sworn an oath of solitude til the blight is purged from these lands”
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Replica add stuck on -603 and -608 on the destination server.

In article <ZMYCx.469$In6.255@novprvlin0914.provo.novell.com>, Ab wrote:
> iMonitor can be used to compare schema between servers in a replica ring.
> Using this is the best way of which I am aware to compare schema between
> servers to look for major/minor differences.


It wasn't a schema issue. I used ICE (hiding under eDirectory Maintenance)
to run compares but nothing showed up. I built up a standalone OES11.2 box
to compare against, but everything it had was fully in the production tree.
While almost going cross eyed getting my iMonitor skills more up to date
found it was stuck on one object. Seeing that it was NFAUuser and a quick
check verified that the old services it was for are no longer used, just
killing it cleared things up, with the new replica going on within a minute
or so.

Noticed along the way is that ICE's schema compare just didn't like any of
the der files I generated so it is a good thing I only needed to compare
and not use it to write any. Something to sort out as the relevant docs
don't show what is needed, so hopefully my proddings will get that fixed
for the next person who needs it.


Andy Konecny
KonecnyConsulting.ca in Toronto
----------------------------------------------------------------------
Andy's Profile: https://forums.netiq.com/member.php?3330-konecnya
If you find a post helpful, please show your appreciation by clicking on
the star below it. Thanks!

___
“i’ve sworn an oath of solitude til the blight is purged from these lands”
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.