fartyalvikram Contributor.
Contributor.
1906 views

Unable to initialize JClient

I am trying to install iManager 3.0.0 on Red Hat Enterprise Linux Server release 6.9 (Santiago).
I was successffully installed iManager on the RHELS and then installed the following plugins
NetIQ Identity Manager (IDMPlugins_IMAN_3_0_IDM_4_6_2_0.n)
eDirectory88 Plugins (eDir_88_iMan27_Plugins.npm)
And test these pluging, I am successfully able to login logout and see these plugin is working properly.

But when I try to install plugins NetIQ Certificate Server Plug-ins for iManager (pki.npm) version 8.8811.2017090. This plugin is also installed successfully and when I restart tomcat and try to login again on iManager, I am getting the following error
Unable to initialize JClient: java.lang.UnsatisfiedLinkError: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libJClient.so.1.0.0: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libntls.so: version `OPENSSL_VERSION_NUMBER' not found (required by /opt/novell/lib64/libnpkit.so)

On tomcat logs (/var/opt/novell/tomcat8/logs/catalina.out) I am getting the below error
31-Jan-2018 07:20:33.997 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in 12163 ms
input to ShellCommand: rpm -q novell-oes-install
java.lang.UnsatisfiedLinkError: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libJClient.so.1.0.0: /var/opt/novell/iManager
/nps/WEB-INF/bin/linux/libntls.so: version `OPENSSL_VERSION_NUMBER' not found (required by /opt/novell/lib64/libnpkit.so)
NDSNamespaceImpl....238 java.lang.Exception: Unable to initialize JClient: java.lang.UnsatisfiedLinkError: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libJClient.so.1.0.0: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libntls.so: version `OPENSSL_VERSION_NUMBER' not found (required by /opt/novell/lib64/libnpkit.so)
NDSNamespaceImpl....239 This could be because of NICI or native library issues

DirAuthenticator...1871 Unable to initialize JClient: java.lang.UnsatisfiedLinkError: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libJClient.so.1.0.0: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libntls.so: version `OPENSSL_VERSION_NUMBER' not found (required by /opt/novell/lib64/libnpkit.so)
DirAuthenticator...1267 Unable to initialize JClient: java.lang.UnsatisfiedLinkError: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libJClient.so.1.0.0: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libntls.so: version `OPENSSL_VERSION_NUMBER' not found (required by /opt/novell/lib64/libnpkit.so)
Labels (1)
0 Likes
5 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Unable to initialize JClient

On 01/31/2018 05:54 AM, fartyalvikram wrote:
>
> I am trying to install iManager 3.0.0 on Red Hat Enterprise Linux Server
> release 6.9 (Santiago).
> I was successffully installed iManager on the RHELS and then installed
> the following plugins
> NetIQ Identity Manager (IDMPlugins_IMAN_3_0_IDM_4_6_2_0.n)


These plugins were made for iManager 3.x, so that is good.

> eDirectory88 Plugins (eDir_88_iMan27_Plugins.npm)


These plugins were made for iManager 2.7, which is NOT good. YOu probably
need to redo your installation at this point.

> And test these pluging, I am successfully able to login logout and see
> these plugin is working properly.


That may be luck. What is also odd is that the certificate server bits
usually come with eDirectory, so you should not need to add them separately.

> But when I try to install plugins *NetIQ Certificate Server Plug-ins for
> iManager (pki.npm) version 8.8811.2017090*. This plugin is also
> installed successfully and when I restart tomcat and try to login again
> on iManager, I am getting the following error
>
> Code:
> --------------------
> Unable to initialize JClient: java.lang.UnsatisfiedLinkError: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libJClient.so.1.0.0: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libntls.so: version `OPENSSL_VERSION_NUMBER' not found (required by /opt/novell/lib64/libnpkit.so)
> --------------------


One of the big changes with eDirectory 9.x and iManager 3.x is a change of
PKI code in the NPKI libraries; essentially they changed to now use
OpenSSL internally. If you are mixing/matching iManager 3.x and 2.7.x
code, that will likely fail, particulary if it is PKI code you are mixing
as you are. Use the right versions of plugins for iManager, and do not
bother installing things you do not need; you should not need certificate
server if you have eDirectory. If you did not see it before, that was
probably the first problem.

Whenever I build an iManager install I add three packages, in this order,
as they include everything I need for eDirectory, IDM, Sentinel, etc.:

eDirectory
IDM
NMAS, purely to easily enable auditing to Sentinel of NMAS-specific events

> On tomcat logs (/var/opt/novell/tomcat8/logs/catalina.out) I am getting
> the below error
>
> Code:
> --------------------
> 31-Jan-2018 07:20:33.997 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in 12163 ms
> input to ShellCommand: rpm -q novell-oes-install
> java.lang.UnsatisfiedLinkError: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libJClient.so.1.0.0: /var/opt/novell/iManager
> /nps/WEB-INF/bin/linux/libntls.so: version `OPENSSL_VERSION_NUMBER' not found (required by /opt/novell/lib64/libnpkit.so)
> NDSNamespaceImpl....238 java.lang.Exception: Unable to initialize JClient: java.lang.UnsatisfiedLinkError: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libJClient.so.1.0.0: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libntls.so: version `OPENSSL_VERSION_NUMBER' not found (required by /opt/novell/lib64/libnpkit.so)
> NDSNamespaceImpl....239 This could be because of NICI or native library issues
>
> DirAuthenticator...1871 Unable to initialize JClient: java.lang.UnsatisfiedLinkError: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libJClient.so.1.0.0: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libntls.so: version `OPENSSL_VERSION_NUMBER' not found (required by /opt/novell/lib64/libnpkit.so)
> DirAuthenticator...1267 Unable to initialize JClient: java.lang.UnsatisfiedLinkError: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libJClient.so.1.0.0: /var/opt/novell/iManager/nps/WEB-INF/bin/linux/libntls.so: version `OPENSSL_VERSION_NUMBER' not found (required by /opt/novell/lib64/libnpkit.so)
> --------------------


If this happens to also be an eDirectory box, and if it has eDirectory
8.8.x, you CANNOT install iManager 3.x on there safely. iManager 3.x
requires NICI 3.x, and you cannot have NICI 3.x on an eDirectory 8.8.x
box, so be sure you have eDirectory 9.x on a box, if eDirectory is there
at all, before you try to use iManager 3.x on the same box. The install
and documentation warn about this, but I want to make sure this is not
your current path as you will break eDirectory 8.8.x if you put iManager
3.x on the same system.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.
0 Likes
fartyalvikram Contributor.
Contributor.

Re: Unable to initialize JClient

When I try to install iManager 3.0.0, this was installed successfully but I am not able to login into eDir via iManager they gives the following error inside the iManager logs (less /var/opt/novell/tomcat8/logs/catalina.out)
DirAuthenticator...1267 (Error-632)Unexpected results have occurred.
DirAuthenticator...1292 Login failed: admin.sa.system: 192.168.1.110

My eDir is running properly in 192.168.1.110 server and iManager is also installed on the same server.

My Second problem is that when I try to see the Workflows using iManager, perform the following steps
Step 1 : Click Identity Manager Administration in iManager
Step 2 : Click the Workflows
Step 3 : Select the User Application Driver
When I select User Application Driver then I got the error message alert "The URI of the workflow server has not been configured for the selected driver."
So is there a way to downgrade the iManager from 3.0.0 to 2.7.7.
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Unable to initialize JClient

On 02/02/2018 11:44 AM, fartyalvikram wrote:
>
> When I try to install iManager 3.0.0, this was installed successfully
> but I am not able to login into eDir via iManager they gives the
> following error inside the iManager logs (less
> /var/opt/novell/tomcat8/logs/catalina.out)
>
> Code:
> --------------------
> DirAuthenticator...1267 (Error-632)Unexpected results have occurred.
> DirAuthenticator...1292 Login failed: admin.sa.system: 192.168.1.110
> --------------------


The only data there are that the credentials are somehow wrong. If that
is not the case, I would guess maybe NICI is broken on your box, but I'd
like to see a message indicating as much.

Perhaps try iManager Workstation on your workstation. If you use the OES
client on there, be sure the newer iManager 3.x and OES Client are
compatible because of NICI changes, but otherwise you should be fine.
iManager Workstation basically runs a simple version of iMangaer right on
your workstation, connecting to the tree as you tell it to on the login
screen, so it is great for most things, including testing simple stuff
like this.

> My eDir is running properly in 192.168.1.110 server and iManager is also
> installed on the same server.
>
> My Second problem is that when I try to see the Workflows using
> iManager, perform the following steps
> Step 1 : Click Identity Manager Administration in iManager
> Step 2 : Click the Workflows
> Step 3 : Select the User Application Driver
> When I select User Application Driver then I got the error message alert
> *"The URI of the workflow server has not been configured for the
> selected driver."*
> So is there a way to downgrade the iManager from 3.0.0 to 2.7.7.


Downgrading is possible if you remove and reinstall, sure; if you have
eDirectory 9.x on a box you probably should not do this, maybe cannot;
doing so would jeopardize the eDirectory instance.

Again, use iManager Workstation to see if things work there. That last
bit about the bad URL doens't seem like anything that downgrading iManager
would ever help; it sounds like you just have not configured your UserApp
driver config properly.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.
0 Likes
fartyalvikram Contributor.
Contributor.

Re: Unable to initialize JClient

I am using NetIQ eDirectory 8.8 SP8 v20811.09 on Red Hat Enterprise Linux Server release 6.8 (Santiago).
So do we required to install iManager 2.7.7.
0 Likes
fartyalvikram Contributor.
Contributor.

Re: Unable to initialize JClient

Now I can able to see Workflow server URI but when I select Workflow server URI and my user uaadmin is automatically retrieved then I enter the password and hit login.
After click on login button they gives the following error
Workflow server URI
Workflow - Error 
The following Workflow administration exception occurred: Connection timed out
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.