mjg2xw
New Member.
732 views

Version 3.0.1 (20160613_1159) is extreme slow, on login

Hi

I have a iManager 3.0.1 running on Windows Server 2012R2 where it takes 1½ minutes from pressing the login, to the "main screen" is loaded. The navigation is also slow.

Same problem in IE,FireFix, Chrom, both direct on the server and on a remote workstation.

IDM Version is 4.5.3 SE

Any Ideas?

/Michael
Labels (1)
0 Likes
2 Replies
Knowledge Partner
Knowledge Partner

Re: Version 3.0.1 (20160613_1159) is extreme slow, on login

I would probably start by using iManager Workstation to see if it has the
same slowness, particularly testing before and after adding any plugins in
case those matter.

iManager has a few places where it can be tuned. First, it uses NCP to
talk to eDirectory, and possibly to multiple eDirectory servers all during
the login depending on how your tree is setup, and where you tell iManager
to login (via the 'Tree' field). Because NCP discovers a lot as it goes,
it can have a lot of packets for what we may incorrectly assume should be
nothing more than a single "verify this username/password" followed by
"ok, good", and that's definitely not the case. As a result, I always
recommend having iManager as close to the eDirctory boxes (with replicas,
of course) as possible, specifically with as little latency as possible;
you don't need gigabit connections, but try to keep round-trip times (RTT)
as low as possible between iManager and eDirectory so lots of little
packets are handled immediately.

Next, you have the browser-to-iManager connection. It is usually not a
big deal these days, and iManager Workstation will basically have nothing
there since everything is local except eDirectory, but it's something you
can test if you use something like Firebug or Live HTTP Headers add-ons in
Firefox (or similar tools in Chrome, etc.). If you are on a slow
connection (low throughput) then something here could cause you issues
potentially, but taking a minute to login is pretty unusual.

With that written, see these threads from a couple weeks ago:

https://forums.novell.com/showthread.php?t=503334
https://forums.novell.com/showthread.php?t=503385

In the latter especially is some testing done with results that you could
apply to your iManager servers (warning: may void warranty, so test it
first) to improve the HTTP performance significantly.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.
0 Likes
mjg2xw
New Member.

Re: Version 3.0.1 (20160613_1159) is extreme slow, on login

Hi

I will try the different suggestion:)

Thanks.

/michael
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.