nkululeko1 Absent Member.
Absent Member.
519 views

eDir8.8.8.9 hot fix 2 fails to start undefined symbol: LogOp

I am running redhat 6.9 , edirectory 8.8.8.9 hot fix 2 and IDM engine 4.0.2
I am doing an inplace upgrade from IDM 4.0.2 and IDM 4.5.5 .
Idm install completes with errors and edirectory fails to start with below error from the log file

opt/novell/eDirectory/sbin/ndsd: symbol lookup error: /opt/novell/eDirectory/lib64/nds-modules/libauditds.so: undefined symbol: LogOpenV2q .
Labels (1)
0 Likes
3 Replies
Micro Focus Expert
Micro Focus Expert

Re: eDir8.8.8.9 hot fix 2 fails to start undefined symbol: LogOp

Hi,

On 18.09.2017 12:04, nkululeko wrote:
>
> I am running redhat 6.9 , edirectory 8.8.8.9 hot fix 2 and IDM engine
> 4.0.2
> I am doing an inplace upgrade from IDM 4.0.2 and IDM 4.5.5 .
> Idm install completes with errors and edirectory fails to start with
> below error from the log file
>
> opt/novell/eDirectory/sbin/ndsd: symbol lookup error:
> /opt/novell/eDirectory/lib64/nds-modules/libauditds.so: undefined
> symbol: LogOpenV2q .


Have you upgraded the platform agent as well?
https://dl.netiq.com/Download?buildid=vyGEsQgINDk~



--
Norbert
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: eDir8.8.8.9 hot fix 2 fails to start undefined symbol: LogOp

That particular file comes from the eDirectory instrumentation RPM, so you
may need to make sure you have that applied:

novell-AUDTedirinst

It should be part of the eDirectory installation media, but it is not
usually installed by default. Once you find it, point to it with one of
these commands to install it:


sudo zypper install /path/to/novell-AUDTedirinst*.rpm
sudo rpm -Uvh /path/to/novell-AUDTedirinst*.rpm


--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.
0 Likes
Knowledge Partner
Knowledge Partner

Re: eDir8.8.8.9 hot fix 2 fails to start undefined symbol: LogOp

nkululeko wrote:

> I am running redhat 6.9 , edirectory 8.8.8.9 hot fix 2 and IDM engine 4.0.2


I'd suggest you update Edirectory to the latest version (8.8.8.10HF1, IIRC)
first and then rerun the IDM update.

--
http://www.is4it.de/en/solution/identity-access-management/

(If you find this post helpful, please click on the star below.)
______________________________________________
https://www.is4it.de/identity-access-management
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.