thundercoug Absent Member.
Absent Member.
866 views

iMontitor Not Loading after eDir 8.8.8 Patch 7 Applied


I have a windows 2012 R2 server running IdM 4.5.3 & eDir 8.8.8 that will
no longer load iMonitor. (Single server instance of eDir) The server
was listening on port 8028 (secure 8030) and I previously logged in to
iManager. I think it was after I patched eDir with patch 7 that caused
the server to be in a state where it is no longer listening on port 8028
or 8030. I get an error that says page cannot be displayed when trying
to access iMonitor. I tried to telnet to those ports to see if they
were open, but they were not. iManager (installed on the same server)
still loads so Tomcat seems to be working. I checked the NetIQ eDir
windows control panel that reports the iMonitor (ndsimon.dlm) as
running. Any ideas as to why iMonitor will no longer load?

Specifically:

Does iMonitor use the same Tomcat instance as iManager (iManager being
installed on the same eDir server)?

Are there any log files for the iMonitor web server, if so where are
they? I've looked around \Novell\NDS and can find the ndsimonitor
config files, but no log files or anything else that looks like I could
modify to get iMonitor up and running.


Any other ideas of things I could check?


Thanks in advance for any help.


--
thundercoug
------------------------------------------------------------------------
thundercoug's Profile: https://forums.netiq.com/member.php?userid=11796
View this thread: https://forums.netiq.com/showthread.php?t=55742

Labels (1)
0 Likes
4 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: iMontitor Not Loading after eDir 8.8.8 Patch 7 Applied

On 04/19/2016 02:35 PM, thundercoug wrote:
>
> I have a windows 2012 R2 server running IdM 4.5.3 & eDir 8.8.8 that will
> no longer load iMonitor. (Single server instance of eDir) The server
> was listening on port 8028 (secure 8030) and I previously logged in to
> iManager. I think it was after I patched eDir with patch 7 that caused
> the server to be in a state where it is no longer listening on port 8028
> or 8030. I get an error that says page cannot be displayed when trying
> to access iMonitor. I tried to telnet to those ports to see if they
> were open, but they were not. iManager (installed on the same server)
> still loads so Tomcat seems to be working. I checked the NetIQ eDir


Irrelevant; iMonitor is part of ndsd only.

> windows control panel that reports the iMonitor (ndsimon.dlm) as
> running. Any ideas as to why iMonitor will no longer load?


Traces, specifically with +init enabled?

> Specifically:
>
> Does iMonitor use the same Tomcat instance as iManager (iManager being
> installed on the same eDir server)?


Does not use Tomcat, or anything else non-ndsd, at all.

> Are there any log files for the iMonitor web server, if so where are
> they? I've looked around \Novell\NDS and can find the ndsimonitor
> config files, but no log files or anything else that looks like I could
> modify to get iMonitor up and running.


Your best bet is ndstrace which is the tracing tool for everything eDirectory.

> Any other ideas of things I could check?


Be sure there isn't some dumb antivirus, or similar thing blocking you.
Also, be sure the firewall is not blocking ports. Rather than checking
from the outside, use netstat to look at open ports (regardless of
firewall settings) on the inside. Be sure that the friewall allows ndsd
to do whatever it wants, like listening and accepting connections on 8030.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
0 Likes
thundercoug Absent Member.
Absent Member.

Re: iMontitor Not Loading after eDir 8.8.8 Patch 7 Applied


Thanks for the tips. I was able to get dstrace running and turned on
the iMonitor flag and found a few errors (error: 200) when I restarted
iMonitor, but I couldn't find anything on those errors. Any ideas?
Here's a copy of the trace:

iMon : DiagLoggerThread shutting down err=0
iMon : Init routine SAL Layer, error: 0
iMon : Init routine DSUtilities Library, error: 0
iMon : Init routine DDS Functions, error: 0
iMon : Init routine Sync Primitives, error: 0
iMon : Init routine DNS Primitives, error: 0
iMon : Init routine Comm Primitives, error: 0
iMon : Init: LMInit(), error: 0
iMon : Init: LMRegisterResourcePath(E:\Novell\NDS\lang), error: 0
iMon : Init: LMSetLangProviderCB(), error: 0
iMon : Init: LMRegisterBuiltInMsgTable(ndsimon), error: 0
iMon : Init: BuiltInMsgTable version is 2080.0
iMon : Init routine Language Primitives, error: 0
iMon : Init routine Primitive Functions, error: 0
iMon : Init routine Formatter Functions, error: 0
iMon : Init routine DLList Functions, error: 0
iMon : Init routine Reference Class, error: 0
iMon : Init routine NDS Attribute Flags, error: 0
iMon : Init routine Thread Manager, error: 0
iMon : Init routine Configuration, error: 0
iMon : Init routine Working Context Mgr, error: 0
iMon : Init routine Http Server Functions, error: 0
iMon : Init routine CIA Client, error: 0
iMon : Init routine Reporting, error: 200
iMon : Init routine NDS Health Monitor, error: 200
iMon : Init routine NDS Trace, error: 0
iMon : Init routine NDS Repair Functions, error: 0
iMon : Init routine Utility Launching Functions, error: 0
iMon : Init routine NDS Activity Functions, error: 0
iMon : Init routine NDS Agent Functions, error: 200
iMon : DiagLoggerInit err = 0
iMon : Init routine Diagnostic Logger, error: 0
iMon : Init routine Http Server Functions, error: 200


--
thundercoug
------------------------------------------------------------------------
thundercoug's Profile: https://forums.netiq.com/member.php?userid=11796
View this thread: https://forums.netiq.com/showthread.php?t=55742

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: iMontitor Not Loading after eDir 8.8.8 Patch 7 Applied

thundercoug wrote:

>
> Are there any log files for the iMonitor web server, if so where are
> they? I've looked around \Novell\NDS and can find the ndsimonitor
> config files, but no log files or anything else that looks like I
> could modify to get iMonitor up and running.
>


Do you have a working version on another server?

I had this problem had to edit a file c:\Novell\NDS\Dibfiles\config.acs
and copy three lines that were missing in the broken server but present
in on the working server.

Used this KB as a starting point. The KB is not specifically for this
problem and refers to other lines/functionality in the same config file.
https://www.netiq.com/support/kb/doc.php?id=3095848

If I recall correctly, the lines in question were what ensured that
imonitor would bind to the correct interfaces on the local server
during startup.

Many of the lines contain info which is unique per-server, so don't
compare line contents, just try and identify any imonitor related
config which is absent.

Keep a backup of the config.acs in case you make a mistake.
0 Likes
thundercoug Absent Member.
Absent Member.

Re: iMontitor Not Loading after eDir 8.8.8 Patch 7 Applied


I was able to fix the problem. I went into the Novell\NDS\Dibfiles\
directory and found the config.acs file, I also noticed the
config.acs.backup file. I compared the two and noticed the following
two line were missing from the config file:

Http Server/HTTPS/Transports/Enum/000
Http Server/HTTPS/Transports/Enum/001

I copied those from the backup file to the regular file and restarted
the services. After restarting the services the server was listening on
port 8030 and I was able to log in.

Thanks again for your help.


--
thundercoug
------------------------------------------------------------------------
thundercoug's Profile: https://forums.netiq.com/member.php?userid=11796
View this thread: https://forums.netiq.com/showthread.php?t=55742

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.