Anonymous_User Absent Member.
Absent Member.
242 views

to xref, failed, directory full (-153) - Replica Dead


Novel eDirectory 8.8 SP5 / RedHat Enterprise Linux

We have removed a eDirectory server which was a RW replica for our root
partition. After removing it from iManager, We can see it as "Dead"
under the Replice View for Server Itself in iManager. and it no more
appears under
root partition as replica.

but if run iMonitor on that server, i can still see the root partition
with Error 1.

if i run the ndstrace on that server, following message appear:

Work info status: Total:2 Peak:2 Busy:0
Work info status: Total:2 Peak:0 Busy:0

Converting .ROOT_PARITION. to xref, failed, directory full (-153)
..ROOT PRAITION. cannot go away until schema has been synchronized
setting flag to seen dead state for [0000802a] <.ROOT_PRATITION.>


ndsrepiar -E on other replicas does not show error and does not list
this server.

What should i do?


Regards,
bElaie.


--
belaie
------------------------------------------------------------------------
belaie's Profile: https://forums.netiq.com/member.php?userid=308
View this thread: https://forums.netiq.com/showthread.php?t=50894

Labels (1)
0 Likes
2 Replies
Anonymous_User Absent Member.
Absent Member.

Re: to xref, failed, directory full (-153) - Replica Dead

Is your system out of space in the partition where eDirectory runs, thus
causing the -153 error? If so, free up some space by cleaning out
something that you do not need from the relevant partition and see if that
helps things proceed a bit.

Otherwise, what was your goal in removing the partition? Are you going to
remove this server from the tree? If so, and if you are done getting any
data from this machine, you could power off the server, be sure it never
comes up again, and then delete the server object for this server from
your tree and be done.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: to xref, failed, directory full (-153) - Replica Dead


If the (disk) partition isn't actually full, try restarting either ndsd
or the server itself. In the past, I have seen the old state being
"stuck" in cache somewhere and a restart cleared that up.


--
--
-eDirectory Rules!-

Peter
www.DreamLAN.com
------------------------------------------------------------------------
peterkuo's Profile: https://forums.netiq.com/member.php?userid=170
View this thread: https://forums.netiq.com/showthread.php?t=50894

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.