Highlighted
Visitor.
1845 views

Bug in version 1.1?

On Iprintappliance 1.1 (fresh install) Ldap User/Group import works OK
I tried to import the Printers with miggui, with migration status:Fatal.
After log file inspection and testing, I found that the /opt/novell/iprint/bin/iprintmig_ldap_ops generate that error:

/opt/novell/iprint/bin/iprintmig_ldap_ops -i ./psmimport.xml -d ipaddress -U cn=admin,o=iprintappliance -A
Enter Destination Server Password:
Information: In main () : Created a logger reference.
Information: In main () : Input XML file : ./psmimport.xml
Fatal(98): In parseXMLFile() : Failed to parse XML file, './psmimport.xml' : Invalid name in entity [Ln: 6500, Col: 61

Line 6500 im psmimport.xml:
<item><role>manager</role><trustee>cn=qmbw-HPLJ2055dn,ou=qm & bw,ou=opman,ou=active,ou=personal,o=JKU</trustee></item>

the "&" in the organzational unit is the problematic part.

with iprint 1.01 we had no problem importing.

claus
0 Likes
4 Replies
Highlighted
Absent Member.
Absent Member.

Re: Bug in version 1.1?

On 08/04/2014 09:06 AM, clausw wrote:
>
> On Iprintappliance 1.1 (fresh install) Ldap User/Group import works OK
> I tried to import the Printers with miggui, with migration
> status:Fatal.
> After log file inspection and testing, I found that the
> /opt/novell/iprint/bin/iprintmig_ldap_ops generate that error:
>
> /opt/novell/iprint/bin/iprintmig_ldap_ops -i ./psmimport.xml -d
> ipaddress -U cn=admin,o=iprintappliance -A
> Enter Destination Server Password:
> Information: In main () : Created a logger reference.
> Information: In main () : Input XML file : ./psmimport.xml
> Fatal(98): In parseXMLFile() : Failed to parse XML file,
> './psmimport.xml' : Invalid name in entity [Ln: 6500, Col: 61
>
> Line 6500 im psmimport.xml:
> <item><role>manager</role><trustee>cn=qmbw-HPLJ2055dn,ou=qm &
> bw,ou=opman,ou=active,ou=personal,o=JKU</trustee></item>
>
> the "&" in the organzational unit is the problematic part.
>
> with iprint 1.01 we had no problem importing.
>
> claus
>
>


Duplicated it on my setup and reported to novell engineering
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Bug in version 1.1?

On 08/04/2014 09:06 AM, clausw wrote:
>
> On Iprintappliance 1.1 (fresh install) Ldap User/Group import works OK
> I tried to import the Printers with miggui, with migration
> status:Fatal.
> After log file inspection and testing, I found that the
> /opt/novell/iprint/bin/iprintmig_ldap_ops generate that error:
>
> /opt/novell/iprint/bin/iprintmig_ldap_ops -i ./psmimport.xml -d
> ipaddress -U cn=admin,o=iprintappliance -A
> Enter Destination Server Password:
> Information: In main () : Created a logger reference.
> Information: In main () : Input XML file : ./psmimport.xml
> Fatal(98): In parseXMLFile() : Failed to parse XML file,
> './psmimport.xml' : Invalid name in entity [Ln: 6500, Col: 61
>
> Line 6500 im psmimport.xml:
> <item><role>manager</role><trustee>cn=qmbw-HPLJ2055dn,ou=qm &
> bw,ou=opman,ou=active,ou=personal,o=JKU</trustee></item>
>
> the "&" in the organzational unit is the problematic part.
>
> with iprint 1.01 we had no problem importing.
>
> claus
>
>



This is a bug on source server. The problem here
is, in case of 1.0.1, ACL were nto supported. So the string containing
'&' is coming inside the CDATA section of XML. While the support for ACL
is added in case of 1.1, so the string containing '&' is coming as it is
inside usual XML tags.The XML that is received from the source is
expected to be in proper format for the target to parse at it's end.
Novell will release the fix for oes11 in the September maintenance patch

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Bug in version 1.1?

On 08/08/2014 10:19 AM, Mysterious wrote:
> On 08/04/2014 09:06 AM, clausw wrote:
>>
>> On Iprintappliance 1.1 (fresh install) Ldap User/Group import works OK
>> I tried to import the Printers with miggui, with migration
>> status:Fatal.
>> After log file inspection and testing, I found that the
>> /opt/novell/iprint/bin/iprintmig_ldap_ops generate that error:
>>
>> /opt/novell/iprint/bin/iprintmig_ldap_ops -i ./psmimport.xml -d
>> ipaddress -U cn=admin,o=iprintappliance -A
>> Enter Destination Server Password:
>> Information: In main () : Created a logger reference.
>> Information: In main () : Input XML file : ./psmimport.xml
>> Fatal(98): In parseXMLFile() : Failed to parse XML file,
>> './psmimport.xml' : Invalid name in entity [Ln: 6500, Col: 61
>>
>> Line 6500 im psmimport.xml:
>> <item><role>manager</role><trustee>cn=qmbw-HPLJ2055dn,ou=qm &
>> bw,ou=opman,ou=active,ou=personal,o=JKU</trustee></item>
>>
>> the "&" in the organzational unit is the problematic part.
>>
>> with iprint 1.01 we had no problem importing.
>>
>> claus
>>
>>

>
>
> This is a bug on source server. The problem here
> is, in case of 1.0.1, ACL were nto supported. So the string containing
> '&' is coming inside the CDATA section of XML. While the support for ACL
> is added in case of 1.1, so the string containing '&' is coming as it is
> inside usual XML tags.The XML that is received from the source is
> expected to be in proper format for the target to parse at it's end.
> Novell will release the fix for oes11 in the September maintenance patch
>


correction ,it is on the target side
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Bug in version 1.1?

On 08/04/2014 09:06 AM, clausw wrote:
>
> On Iprintappliance 1.1 (fresh install) Ldap User/Group import works OK
> I tried to import the Printers with miggui, with migration
> status:Fatal.
> After log file inspection and testing, I found that the
> /opt/novell/iprint/bin/iprintmig_ldap_ops generate that error:
>
> /opt/novell/iprint/bin/iprintmig_ldap_ops -i ./psmimport.xml -d
> ipaddress -U cn=admin,o=iprintappliance -A
> Enter Destination Server Password:
> Information: In main () : Created a logger reference.
> Information: In main () : Input XML file : ./psmimport.xml
> Fatal(98): In parseXMLFile() : Failed to parse XML file,
> './psmimport.xml' : Invalid name in entity [Ln: 6500, Col: 61
>
> Line 6500 im psmimport.xml:
> <item><role>manager</role><trustee>cn=qmbw-HPLJ2055dn,ou=qm &
> bw,ou=opman,ou=active,ou=personal,o=JKU</trustee></item>
>
> the "&" in the organzational unit is the problematic part.
>
> with iprint 1.01 we had no problem importing.
>
> claus
>
>


I've got a fix from novell. If oyu're willing to test it, provide me
with a valid email address. Thanks
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.