Anonymous_User Absent Member.
Absent Member.
1773 views

Can't configure iPrint after iManager 2.6 install

Hi,

I have a OES-Linux box and decided to upgrade iManager from 2.5 to 2.6
iManager is working well as expected, but I decided to install iPrint
services on the same server later on. I added the packages with YaST.
When I try to configure a DriverStore in iManager I get the error
described in the following TID
http://www.novell.com/support/search.do?cmd=displayKC&docType=kc&externalId=10100124&sliceId=&dialogID=26880786&stateId=0%200%2026888276

The solution to the problem is to configure iPrint within YaST, but then
I get another error when I try to do this:

"Product iPrint can not be installed and/or configured until the
following products are installed: ["Novell iManager"] Do you want to
install them too?"

I allready have iManager 2.6 and it seems as YaST isn't aware of this.
I'm afraid that if I choose YES I'll break iManager.

I have exactly the same problem on another OES-Linux server with the
NetStorage package. It seems as iManager 2.6 does something to the rpm
dependencies.

Any suggestions?

Regards,

Cosmin
0 Likes
3 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Can't configure iPrint after iManager 2.6 install

Cosmin wrote:
> Hi,
>
> I have a OES-Linux box and decided to upgrade iManager from 2.5 to 2.6
> iManager is working well as expected, but I decided to install iPrint
> services on the same server later on. I added the packages with YaST.
> When I try to configure a DriverStore in iManager I get the error
> described in the following TID
> http://www.novell.com/support/search.do?cmd=displayKC&docType=kc&externalId=10100124&sliceId=&dialogID=26880786&stateId=0%200%2026888276
>
>
> The solution to the problem is to configure iPrint within YaST, but then
> I get another error when I try to do this:
>
> "Product iPrint can not be installed and/or configured until the
> following products are installed: ["Novell iManager"] Do you want to
> install them too?"
>
> I allready have iManager 2.6 and it seems as YaST isn't aware of this.
> I'm afraid that if I choose YES I'll break iManager.
>
> I have exactly the same problem on another OES-Linux server with the
> NetStorage package. It seems as iManager 2.6 does something to the rpm
> dependencies.
>
> Any suggestions?


Hmm. From looking at the RPM dependencies, it looks like there shouldn't
be a problem. I'm guessing that it's a yast thing.

You could try to install the RPMs manually. Try first from yast, and if
that doesn't work, find the RPMs on the CDs (perhaps on CD3?) in the
suse/i586 or suse/noarch directory, then from a shell, go to that
directory and run the command "rpm -Uvh file-version.rpm" where
file-version.rpm is the entire filename of the particular rpm that
you're trying to install.

First, make sure that packages iPrint depends upon are installed. You
should probably be able to install them from yast without any trouble if
you don't have them installed already. You'll need all of these:
novell-web-base
novell-tomcat4
novell-imanager
novell-welcomepage
NDScommon
openwbem
novell-openwbem-authorizer
novell-schema
aaa_base
novell-lum

Once you have those in place, try installing the iprint packages:
yast2-iprint
novell-iprint-welcome
novell-iprint-server
novell-iprint-client
novell-iprint-iprntman
novell-iprint-management

You'll probably have to manually edit the file
/etc/opt/novell/iprint/httpd/conf/iprint_ssl.conf to make the
AuthLDAPURL directive match your environment, since yast won't do it for
you. If it says "o=novell", you can change that to your base container.
Same with /etc/opt/novell/iprint/httpd/conf/iprint_g.conf where you'll
want to uncomment the ServerName directive and put your IP address, like
ServerName 10.0.0.1:631
Hope that helps.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Can't configure iPrint after iManager 2.6 install


Cosmin wrote:
> Hi,
>
> I have a OES-Linux box and decided to upgrade iManager from 2.5 to 2.6
> iManager is working well as expected, but I decided to install iPrint
> services on the same server later on. I added the packages with YaST.
> When I try to configure a DriverStore in iManager I get the error
> described in the following TID
> http://www.novell.com/support/search.do?cmd=displayKC&docType=kc&externalId=10100124&sliceId=&dialogID=26880786&stateId=0%200%2026888276
>
>
> The solution to the problem is to configure iPrint within YaST, but then
> I get another error when I try to do this:


Yikes... I guess I should have read your original message more
carefully. I think the issue is that the schema needs to be updated to
support the iPrint objects.

You can do that manually with this command:

/opt/novell/oes_install/util/extend_schema -d -p 636 \
"cn=admin,o=example" "adminPassword" 10.0.0.1 \
/opt/novell/ldif/iprint.ldif

You can enter it as three separate lines with the backslashes, or remove
the backslashes and put the whole command on one line. Don't forget to
update the admin DN, password and IP address of the server.

You'll also need to edit the iprint_ssl.conf and iprint_g.conf file as I
described in my other response.
Hope that helps.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Can't configure iPrint after iManager 2.6 install

It worked! Thank you!

I had to restart Apache as well because I got an authorization error
when trying to set up the Driver Store.

Works well now! 🙂



iPrint Linux wrote:
> Cosmin wrote:
>> Hi,
>>
>> I have a OES-Linux box and decided to upgrade iManager from 2.5 to 2.6
>> iManager is working well as expected, but I decided to install iPrint
>> services on the same server later on. I added the packages with YaST.
>> When I try to configure a DriverStore in iManager I get the error
>> described in the following TID
>> http://www.novell.com/support/search.do?cmd=displayKC&docType=kc&externalId=10100124&sliceId=&dialogID=26880786&stateId=0%200%2026888276
>>
>>
>> The solution to the problem is to configure iPrint within YaST, but then
>> I get another error when I try to do this:

>
> Yikes... I guess I should have read your original message more
> carefully. I think the issue is that the schema needs to be updated to
> support the iPrint objects.
>
> You can do that manually with this command:
>
> /opt/novell/oes_install/util/extend_schema -d -p 636 \
> "cn=admin,o=example" "adminPassword" 10.0.0.1 \
> /opt/novell/ldif/iprint.ldif
>
> You can enter it as three separate lines with the backslashes, or remove
> the backslashes and put the whole command on one line. Don't forget to
> update the admin DN, password and IP address of the server.
>
> You'll also need to edit the iprint_ssl.conf and iprint_g.conf file as I
> described in my other response.
> Hope that helps.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.