clarja Absent Member.
Absent Member.
1041 views

Cant use iPrint Map tool

Hi,

I have been using the Map tool for quite some years on a SLES OES2 server, haven't used it much this year if at all for the last 6 months.

However I have come to use it yesterday and experienced all sorts of issues where it would not even load or halve load, or appear on the screen but none of the menus would work to open a file.
I tried many different machines and browsers etc but found it would just freeze and not be useable.

I have been keeping the server up to date so it has been applying all the updates through 2015 including the clients having the latest iprint client 6.02.

I managed to get the map tool to open a htm map on a machine yesterday to find if I drag a printer icon and try to drop it - it would not work.

I saw a November 2015 update so applied this but I find the problem has become worse where by the map tool will not appear at all.

I have found TID 3956463 but unable to test as I cant even get the map tool to open correctly.

In my apache log I have the following error:

[Thu Dec 10 08:58:12 2015] [error] [client 10.37.200.249] File does not exist: /var/opt/novell/iprint/htdocs/styles/iprintappliance.css, referer: http://10.37.20.21/ippdocs/maptool.htm

Any help appreciated.
0 Likes
2 Replies
clarja Absent Member.
Absent Member.

Re: Cant use iPrint Map tool

Sorry TID 7016923
0 Likes
RSeifert Frequent Contributor.
Frequent Contributor.

Re: Cant use iPrint Map tool

Hi,

got the same problem on an existing OES11SP2 server and even on a OES2015 server installed from scratch, each fully patched...
Because of the error message, I set up an iPrint test appliance 1.1 and copied some files from the appliance to the OES server, and everything starts working again:
In case of the OES11SP2 server, I copied /var/opt/novell/iprint/htdocs/styles and ...scripts directories.
In case of the OES2015 server, it seems to be enough to copy /var/opt/novell/iprint/htdocs/scripts/maptool.js

Since the iPrint appliance is equivalent to an OES11SP2 system, it may not be the best thing, but it works...



clarja;2413395 wrote:
Hi,

I have been using the Map tool for quite some years on a SLES OES2 server, haven't used it much this year if at all for the last 6 months.

However I have come to use it yesterday and experienced all sorts of issues where it would not even load or halve load, or appear on the screen but none of the menus would work to open a file.
I tried many different machines and browsers etc but found it would just freeze and not be useable.

I have been keeping the server up to date so it has been applying all the updates through 2015 including the clients having the latest iprint client 6.02.

I managed to get the map tool to open a htm map on a machine yesterday to find if I drag a printer icon and try to drop it - it would not work.

I saw a November 2015 update so applied this but I find the problem has become worse where by the map tool will not appear at all.

I have found TID 3956463 but unable to test as I cant even get the map tool to open correctly.

In my apache log I have the following error:

[Thu Dec 10 08:58:12 2015] [error] [client 10.37.200.249] File does not exist: /var/opt/novell/iprint/htdocs/styles/iprintappliance.css, referer: http://10.37.20.21/ippdocs/maptool.htm

Any help appreciated.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.