Absent Member.
Absent Member.
2814 views

Delayed opening of word when not on network

We are currently having an issue where we have faculty members who have iPrint 5.2 installed and when they are not connected to our network, there is a 20+ second delay when opening word documents. The status bar on the bottom of word says "Looking for printer".

When they are connected to another internet connection, the delay is upwards of 2 minutes.

Any ideas?
Tags (1)
0 Likes
12 Replies
Absent Member.
Absent Member.

cliffnadeau;1916010 wrote:
We are currently having an issue where we have faculty members who have iPrint 5.2 installed and when they are not connected to our network, there is a 20+ second delay when opening word documents. The status bar on the bottom of word says "Looking for printer".

When they are connected to another internet connection, the delay is upwards of 2 minutes.

Any ideas?


I think Word wants to format the document based on the default printer capabilities. Try setting the default printer to something like the XPS printer (or something local if it exists). See if that has any effect.
0 Likes
Absent Member.
Absent Member.

We are having the same problem.. but only a couple of users have reported it as an issue. According to the user, it completely freezes all activity on the pc for 20 second to a minute or more.

iPrint client - 4.34
OS - XP SP3

I'll get the user to try a local printer and report back.
0 Likes
Absent Member.
Absent Member.

Michael_Fleming;1916247 wrote:
We are having the same problem.. but only a couple of users have reported it as an issue. According to the user, it completely freezes all activity on the pc for 20 second to a minute or more.

iPrint client - 4.34
OS - XP SP3

I'll get the user to try a local printer and report back.


What's odd is I set a local printer to default, it shortens the time the computer freezes, but doesn't eliminate it.
0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

What is the driver that you are using in both the cases? Are they the same.

Like how Tim mentioned the Word application might be trying to get the printers details. Now some drivers talk to the printer using SNMP communication this can be causing the delay. If you have XPS Document Writer kind of a printer marked as the default it would ensure that during the initial load of the application the printers are not communicated with.

Another thing that I could recommend you is that you can try and see in the printers properties if it gives you an option to disable Bi-Di (Bi-Directional) communication. Then you could disable that as well. If this works then you could create an iPrint Printer Profile with this setting so that printers installed will have Bi-Di disabled. That way even if the users install the printer as default they will not see the issue.

Hope something here works for you.

Thanks,
-Hitesh



>>> cliffnadeau<cliffnadeau@no-mx.forums.novell.com> 1/13/2010 6:36 PM >>>


Michael_Fleming;1916247 Wrote:

> We are having the same problem.. but only a couple of users have
> reported it as an issue. According to the user, it completely freezes
> all activity on the pc for 20 second to a minute or more.
>
> iPrint client - 4.34
> OS - XP SP3
>
> I'll get the user to try a local printer and report back.


What's odd is I set a local printer to default, it shortens the time
the computer freezes, but doesn't eliminate it.


--
cliffnadeau
------------------------------------------------------------------------
cliffnadeau's Profile: http://forums.novell.com/member.php?userid=75570
View this thread: http://forums.novell.com/showthread.php?t=398034

0 Likes
Absent Member.
Absent Member.

It happens with ANY printer / Copier when its set to Default when it is installed via iprint. Ip only printers / copiers dont have this issue.


mhitesh;1916410 wrote:
What is the driver that you are using in both the cases? Are they the same.

Like how Tim mentioned the Word application might be trying to get the printers details. Now some drivers talk to the printer using SNMP communication this can be causing the delay. If you have XPS Document Writer kind of a printer marked as the default it would ensure that during the initial load of the application the printers are not communicated with.

Another thing that I could recommend you is that you can try and see in the printers properties if it gives you an option to disable Bi-Di (Bi-Directional) communication. Then you could disable that as well. If this works then you could create an iPrint Printer Profile with this setting so that printers installed will have Bi-Di disabled. That way even if the users install the printer as default they will not see the issue.

Hope something here works for you.

Thanks,
-Hitesh



>>> cliffnadeau<cliffnadeau@no-mx.forums.novell.com> 1/13/2010 6:36 PM >>>


Michael_Fleming;1916247 Wrote:

> We are having the same problem.. but only a couple of users have
> reported it as an issue. According to the user, it completely freezes
> all activity on the pc for 20 second to a minute or more.
>
> iPrint client - 4.34
> OS - XP SP3
>
> I'll get the user to try a local printer and report back.


What's odd is I set a local printer to default, it shortens the time
the computer freezes, but doesn't eliminate it.


--
cliffnadeau
------------------------------------------------------------------------
cliffnadeau's Profile: NOVELL FORUMS - View Profile: cliffnadeau
View this thread: Delayed opening of word when not on network - NOVELL FORUMS
0 Likes
Absent Member.
Absent Member.

Also, the drivers do not have Bi-Di options.
0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

Is it possible that your iPrint server is remotely located and the connectivity between it and your clients is low. You could also try using iPrint Direct. iPrint direct is a feature to enable direct communication between client and the printers, this will bypass the server and directly talk to the printers.

Thanks,
-Hitesh



>>> cliffnadeau<cliffnadeau@no-mx.forums.novell.com> 1/14/2010 1:46 AM >>>


Also, the drivers do not have Bi-Di options.


--
cliffnadeau
------------------------------------------------------------------------
cliffnadeau's Profile: http://forums.novell.com/member.php?userid=75570
View this thread: http://forums.novell.com/showthread.php?t=398034

0 Likes
Absent Member.
Absent Member.

mhitesh;1917377 wrote:
Is it possible that your iPrint server is remotely located and the connectivity between it and your clients is low. You could also try using iPrint Direct. iPrint direct is a feature to enable direct communication between client and the printers, this will bypass the server and directly talk to the printers.
[/url]


This issue is for users which are NOT connected to the network and simply try to open Word and it freezes all activity on the pc.
0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

Oh, thanks for correcting. I am sorry, I lost the original context.

When there is no network connection, I would expect the printers queries to finish faster. Because the printers go to not available state and since there is no network connection available any further queries should fail immediately. Pressing CTRL+P should also give the UI faster.

Typically in the application address space the printer driver runs. That is the reason I was asking the driver details. We have seen some faulty drivers exhibiting such issue in past but those have been irrespective of the fact whether iPrint was there or not.

What is the printer's state as shown in the printer folder in this state?

Thanks,
-Hitesh



>>> Michael Fleming<Michael_Fleming@no-mx.forums.novell.com> 1/15/2010 3:46 PM >>>


mhitesh;1917377 Wrote:

> Is it possible that your iPrint server is remotely located and the
> connectivity between it and your clients is low. You could also try
> using iPrint Direct. iPrint direct is a feature to enable direct
> communication between client and the printers, this will bypass the
> server and directly talk to the printers.
> [/url]


This issue is for users which are NOT connected to the network and
simply try to open Word and it freezes all activity on the pc.


--
Michael_Fleming
------------------------------------------------------------------------
Michael_Fleming's Profile: http://forums.novell.com/member.php?userid=62364
View this thread: http://forums.novell.com/showthread.php?t=398034

0 Likes
Absent Member.
Absent Member.

We are still seeing this problem, we have been working around it by setting the default printer to CutePDF. We see this problem when the user is away from our network but are connected to their home internet. iPrint seems to be trying to communicate with the printer and taking a long time to time out.
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Jdofaz,
> iPrint seems to be trying to communicate with the printer and taking a
> long time to time out.


That is Word trying to or rather the Windows print subsystem... Try this:
http://www.saiweb.co.uk/windows/microsoft-office-word-excel-outlook-slow-when-connected-to-network-but-fast-when-not

- Anders Gustafsson (Sysop)
The Aaland Islands (N60 E20)


Novell has a new enhancement request system,
or what is now known as the requirement portal.
If customers would like to give input in the upcoming
releases of Novell products then they should go to
http://www.novell.com/rms

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.